RT and Oracle

Trying to setup RT with an oracle instance. Read the notes on Oracle
Setup and did as they recommended regarding manual install of schema and
comment out the line. When trying to run the rt-setup-database, I get:
Now creating a database for RT.
…skipped as rt is not rt or we’re working with Oracle.
Now populating database schema.
Now inserting database ACLs
Now inserting RT core system objects
[Fri Mar 3 20:07:25 2006] [crit]: Connect Failed Can’t connect using
this synta
x without specifying a HOST and a SID
at rt-setup line 393
(/opt/rt3/lib/RT.pm:295)

What am I missing? Something in the config?

Thanks you

At Friday 3/3/2006 01:28 PM, Don Beethe wrote:

Trying to setup RT with an oracle instance. Read the notes on Oracle
Setup and did as they recommended regarding manual install of schema and
comment out the line. When trying to run the rt-setup-database, I get:
Now creating a database for RT.
…skipped as rt is not rt or we’re working with Oracle.
Now populating database schema.
Now inserting database ACLs
Now inserting RT core system objects
[Fri Mar 3 20:07:25 2006] [crit]: Connect Failed Can’t connect using
this synta
x without specifying a HOST and a SID
at rt-setup line 393
(/opt/rt3/lib/RT.pm:295)

What am I missing? Something in the config?

Don,

What options did you supply when you ran the configure script?

Steve

At Monday 3/6/2006 09:49 AM, Don Beethe wrote:

Here is the configure line I used:
configure --with-db-type=Oracle --with-db-dba=rt
–with-db-host=rmtcdb01.rmtc.fedex.com -with-db-atabase=star
–with-db-rt-user=rt_user --with-db-rt-pass=rt_pass --with-web-user=cm
–with-web-group=cm

The problem could be just a typo: -with-db-atabase=star should be
–with-db-database=star .
(note the double ‘-’ at the beginning)

Steve

Here is the configure line I used:
configure --with-db-type=Oracle --with-db-dba=rt
–with-db-host=rmtcdb01.rmtc.fedex.com -with-db-atabase=star
–with-db-rt-user=rt_user --with-db-rt-pass=rt_pass --with-web-user=cm
–with-web-group=cmFrom: Stephen Turner [mailto:sturner@MIT.EDU]
Sent: March 06, 2006 7:51 AM
To: Don Beethe; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RT and Oracle

At Friday 3/3/2006 01:28 PM, Don Beethe wrote:

Trying to setup RT with an oracle instance. Read the notes on Oracle
Setup and did as they recommended regarding manual install of schema
and comment out the line. When trying to run the rt-setup-database, I
get:
Now creating a database for RT.
…skipped as rt is not rt or we’re working with Oracle.
Now populating database schema.
Now inserting database ACLs
Now inserting RT core system objects
[Fri Mar 3 20:07:25 2006] [crit]: Connect Failed Can’t connect using
this synta x without specifying a HOST and a SID
at rt-setup line 393
(/opt/rt3/lib/RT.pm:295)

What am I missing? Something in the config?

Don,

What options did you supply when you ran the configure script?

Steve

On Fri, 3 Mar 2006 16:24:13 -0500 (EST)

Trying to setup RT with an oracle instance. Read the notes on Oracle
Setup and did as they recommended regarding manual install of schema and
comment out the line. When trying to run the rt-setup-database, I get:
Now creating a database for RT.
…skipped as rt is not rt or we’re working with Oracle.
Now populating database schema.
Now inserting database ACLs
Now inserting RT core system objects
[Fri Mar 3 20:07:25 2006] [crit]: Connect Failed Can’t connect using
this synta
x without specifying a HOST and a SID
at rt-setup line 393
(/opt/rt3/lib/RT.pm:295)

What am I missing? Something in the config?

Don’t mess with the supplied scripts.

This is how I setup RT-3.4.2 using Oracle (XE) on Ubuntu:
root@ubuntu: export
ORACLE_HOME=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server
root@ubuntu: export ORACLE_SID=XE
root@ubuntu: export
LD_LIBRARY_PATH=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/lib
root@ubuntu: export
PATH=$PATH:/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin

root@ubuntu: sqlplus system/manager@XE
SQL> create user rt_user identified by 'your_password’
default tablespace your_preferred_tablespace_mostly_USERS
temporary tablespace TEMP;
grant connect,resource,dba to rt_user;
exit

root@ubuntu: rt-setup-database-3.4 --action init --dba rtuser
–prompt-for-dba-password
In order to create or update your RT database,this script needs to connect to your Oracle instance on localhost as rtuser.
Please specify that user’s database password below. If the user has no database
password, just press return.

Password:
Now creating a database for RT.
…skipped as rtuser is not rtuser or we’re working with Oracle.
Now populating database schema.
Creating database schema.
Done setting up database schema.
Now inserting database ACLs
Now inserting RT core system objects
Checking for existing system user…not found. This appears to be a new installation.
Creating system user…done.
Now inserting RT data
Creating Superuser ACL…done.
Creating groups…3.4.5.6.7.8.9.done.
Creating users…10.12.done.
Creating queues…1.2.done.
Creating ACL…2.3.done.
Creating ScripActions…1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.done.
Creating ScripConditions…1.2.3.4.5.6.7.8.9.10.done.
Creating templates…1.2.3.4.5.6.7.8.9.10.11.12.done.
Creating scrips…1.2.3.4.5.6.7.8.9.10.11.12.13.14.done.
Done setting up database content.
root@ubuntu:/#

If you want you can revoke the DBA right from rt_user
sqlplus system/manager@XE
SQL> revoke dba from rt_user;
exit

Joop

Joop van de Wege JoopvandeWege@mococo.nl