RT 5 Rich Text Spell Checker

We have recently moved from RT4 to RT5 and almost everything is working fine. Apart from the fact that the browser (or any checker) no longer works when we are typing.

I have a feeling I changed something in RT4 but that was a LONG time ago …

Are there any ways to set this working / any pointers ?


Without knowing what you had before can only suggest something new, but there are a bunch of CKEditor plugins you could try like:


Happy to look at that - is there any hints on where the config file for CKeditor is within RT ?

More than happy to configure / edit however is needed - if you could just provide a hint on where in the RT directory tree I should look I can make a copy / edit as need be

Thanks again for your help so far

Should be here: “share/static/RichText/config.js”

I added
config.disableNativeSpellChecker = false;
to the
file and restarted httpd. But this still doesn’t seem to enable the browser’s native spell checker in CKeditor. I also tried re-enabling some of the buttons but no change. Is there something else I have to do? It’s not like I’m changing Perl code and have to clear mason cache.

You may wish to flush the Mason cache anyway just in case it the setting you’ve changed gets put into Perl generated pages that the Mason system has cached.

So this isn’t ideal but switching your user preferences to not use the " WYSIWYG message composer " and having the config option you added seems to allow native spell checking. I am not sure why the WYSIWYG composer doesn’t support it.

Ah after some digging I found this:

It looks like the solution is create a local JS file:

mkdir -p local/static/js
touch local/static/js/myjs.js

Add the following content:

jQuery( document ).ready(function() {
  var $j = jQuery.noConflict();
  $j( function() {
    CKEDITOR.on( 'instanceLoaded', function( e ) {
      e.editor.config.disableNativeSpellChecker = false;

Then tell RT about the new JS file:

Set(@JSFiles, ('myjs.js'));

@knation that is awesome and works great! I’m still confused though why RT’s config.js is not being loaded. (clearing mason cache had no effect) Also should be documented somewhere…

Actually I think this is caching, can you try removing the custom JS file I told you to make and disable cache on page load?

Yesterday I had already tried to open from a browser that never logged into my RT before and it still didn’t work. But, anyway, it’s working now. :slight_smile:

I had the same issue. After some moments of frustration, i deleted all browser data and all changes was applied. As you have already solved your issue, keep this in mind for any future changes in CKEditor.

Below are the steps i follow to make changes to CKEditor :

  1. Copy the config from “share/static/RichText/config.js” to “local/static/RichText/” (do this only the first time)
  2. Make your changes to newly copied config.js
  3. rm -rf /opt/rt5/var/mason_data/obj && service apache2 restart
  4. Delete all browser data
  5. Refresh the page