RT 5.0.1 REST API attachment size

Hi there. Is there any setting limiting the size of files attached when creating tickets via REST API?
I can’t attach tickets bigger than 2MB.

Do you see anything in logs? I believe MySQL default max packet might be 2MB, you may also be hitting a web timeout

I don’t have access to logs but REST doesn’t report any error. It just creates the ticket without attaching large attachments.
I think there’s no problem with MySQL settings because max_allowed_packet is 32M.

I found out it was not related to RT settings. In fact, I’m sending the request from a PHP client, and the PHP settings needed to be updated. FYI, here is the list of PHP settings that I updated:

  • post_max_size
  • upload_max_filesize

Great job! As side note, in case others run into attachment size limits, I had a long-term problem with attachments that ended up being a maximum upload configuration size setting in Nginx, which I increased:

        # default: client_max_body_size 1m;
        client_max_body_size 10M;