RT 5.0.0 upgrade database issue

Hello everyone!

I was trying to upgrade my Request Tracker from 4.4.4 to 5.0.0, and everything seemed good until i got the following error in the database upgrade step:

[27761] [Wed Jul 29 20:48:01 2020] [critical]: DBD::Pg::st execute failed: ERROR: column “hotlist” of relation “classes” does not exist at /opt/rt-5.0.0/sbin/…/lib/RT/Handle.pm line 548. (/opt/rt-5.0.0/sbin/…/lib/RT.pm:409)
DBD::Pg::st execute failed: ERROR: column “hotlist” of relation “classes” does not exist at /opt/rt-5.0.0/sbin/…/lib/RT/Handle.pm line 548.
Makefile:393: recipe for target ‘upgrade-database’ failed
make: *** [upgrade-database] Error 255

All the previous steps are good. Any ideas?

Was this RT originally RT4.4.4 or was it upgraded in the past as well?

1 Like

Hi! Thanks for answering. It’s originally from 4.4.4.

From the docs:

With this simplified interface, the “hotlist” fea> ture is no longer needed as all articles in classes applied to a given queue are available in the dropdown/autocomplete field. To prevent articles in a class from appearing for a queue, you can unapply the class from that queue.

The upgrade steps remove the hotlist configuration from your RT database by removing that column from the Articles table. Since the article class must be applied to a queue for the hotlist items to appear, all articles should continue to appear in the new interface.

So its odd that the hottlist doesn’t exist already, maybe this step has already been run before?

1 Like

It’s odd indeed. I’m not sure if this step was already been run cuz I just literally have followed the README steps. It seems like i have an issue in the ./configure script, is it possible?

There’s an error when running configure?

1 Like

No, there isn’t. The ./configure step worked well. I mean, the error says “Makefile:393: recipe for target”, maybe there is an issue in the configure-database config file

The error is quoted above, the issue is the upgrade code is expecting to find a column ‘Hotlist’ in the table ‘Classes’. Does this table exist for you? If you open the file etc/upgrade/4.5.0/schema.Pg you can see the only thing it does is drop that column so if its already gone for you, you are probs safe to skip 4.5.0 upgrade step.

1 Like

Thanks for your help!

I really don’t know why this “hotlist” column already didn’t exist, but skiping the 4.5.0 upgrade worked fine!

1 Like

Hello Felipe,
How did you skip this step?

Hi Thiago!

The update-database script asks which version you are upgrading from. After doing this, the script asks for the version number you want to skip or, if you don’t want to, you can leave it blank. I just inserted the version number that I would like to skip. 4.5.0 and 4.5.1 in this case.

I think there are no significant changes in the database structure from version 4.4.4 to 5.0.0. Cuz the issues I had were with the updates that the script makes to the database (creating and changing tables, for example)

I had this issue also - skipping to the 4.5.2 start point also fixed it but now I have an issue with 4.5.7. Should I post a new thread for this or add it to this one?

The next one that fails for me is 4.5.7/acl.Pg

The specific error is as follows:

[5648] [Wed Oct 14 22:54:30 2020] [warning]: do “etc/upgrade/4.5.7/acl.Pg” failed, ‘.’ is no longer in @INC; did you mean do “./etc/upgrade/4.5.7/acl.Pg”? at /tmp/rt-5.0.0/sbin/…/lib/RT/Handle.pm line 467. (/tmp/rt-5.0.0/sbin/…/lib/RT/Handle.pm:467)
Couldn’t finish ‘upgrade’ step.
ERROR: Couldn’t load ACLs:

I found I can skip over this upgrade also. Looks like it’s granting permissions to tables.

Seems to be running fine after the database upgrade. Loaded it via the rt-server method and was able to log in with my credentials from the old server. Seems to be running ok - noticed my custom dashboards are missing but so far so good.

The saved searches were imported so wont be too much work to rebuild the dashboards.

Oh! Just found my missing dashboards. They’re under reports now.