RT 4.2.8: ran rt-serializer, now cannot see Tickets


#1

My RT is 4.2.8 running on Debian Linux. My Ticket database is small ~1000 tickets.

I need to move RT to a different server, so I ran “rt-serializer” as user root on my RT server.
rt-serializer produced the output directory without flagging any issues, so that is good.

However, now there’s a problem when I run a search for All Tickets through the web GUI.
when I run Search all Tickets with my personal account, it comes back empty - nothing returned.
when I run Search all Tickets as user root, it shows all my ~1000 Tickets.

Running mysql commands, I see the Tickets table in rtdb is fully populated with my ~1000 tickets.
I’ve checked log files and nothing is flagged:

  • apache2 logs show similar traces for the 2 use cases above
  • mysql error logs do not flag any issues
    It’s almost as if rt-serializer left the Tickets table locked or inaccessible for anyone other than root.

I see behaviors similar to this have been reported before in this forum.
Can anyone offer any guidance on the root cause, and how to clear it?

Thanks!