RT 4.2.8 and Internet Explorer problems

My company is investigating the latest version of RT as a possible option
to replace our outdated and out of support issue/request tracking
software. I was tasked with installing and testing RT and over the past
week, have installed/configured and tested the product extensively. The
issue i am having is weird and i have spent days on end searching the
internet for possible solutions and i have finally run into the proverbial

We are running RT 4.2.8 on a linux, RHEL 6.5 VMware server. I have httpd
2.2.15-31 installed with Perl v 5.10.1, mod_perl 2.0.4-11, mysql 5.1.73-3
and mod_fastcgi 2.4.6-2. Following the directions from
README - RT 4.2.17 Documentation - Best Practical, i have installed and
configured RT locally, having added modules RT-Extension-LDAPImport-0.36,
RT-Authen-ExternalAuth-0.23, RT-Extension-Assets-1.0.1, the first 2 to
allow integration into our internal AD structure. I originally installed
and ran by using the ./rt-server command located in /opt/rt4/sbin… i was
able to load up RT, configure and use with no issues on Firefox/Chrome.
When i tried on IE, i would receive the initial RT login screen and upon
putting in a username/password, it would come right back to the main RT
login screen.

I have since changed the way it runs on the server, testing via httpd
mod_perl and mod_fastcgi. Both options again render the program fine on all
browsers and on Firefox/Chrome, it allows the user to login and work within
the software, but again, IE does the same thing. I have tried on IE8,9 and
10, all doing the same exact thing.

I have searched tirelessly for a solution to this and most of the time i
come across the suggestion to make sure that :


<meta http-equiv="X-UA-Compatible" content="IE=edge" />

<!-- The X-UA-Compatible <meta> tag above must be very early in <head>

Is present in the code, which it is already within RT. i have tried
.htaccess files with similar lines of code in it to no avail. i have tried
to run IE with no add-ons, still the same result. I have used the developer
console in IE and found the only message to be HTML1113: Document mode
restart from Quirks to IE9 Standards. When looking in the RT logs,
comparing a login from Chrome to that of IE, they look exactly the same,
even to the point of saying that the user was successfully logged in, but
with IE, it bounces back to the authentication part of the log, where
Chrome moves on to the actual program.

I have had senior engineers look at this at our location as well as a
couple programmer/developers we have on staff and all are baffled on what
is causing this.

I am hoping that someone out there might have a solution/suggestion for
this problem. Maybe a configuration change that needs to be done on the
apache side?? I am not sure.

Oh, I am not running our URL as https either… i had seen a couple
instances of that on the internet as well.

Any suggestions/help would be appreciated


Chris Broadbent

I compiled RT from source on debian wheezy and i have also integrated it to
active directory and i have tested IE 11 on win 8.1 x64 against it and it
logs in just fine. I am using mod_fcgi and using https which seems to be the
difference between our setups.

View this message in context: http://requesttracker.8502.n7.nabble.com/RT-4-2-8-and-Internet-Explorer-problems-tp58769p58776.html