RT 4.0.8 and msmtp

Hello all,

I updated to 4.0.8 from 4.0.5 today and now outgoing emails are failing
with the following error:
[Thu Dec 13 20:21:48 2012] [crit]: <
rt-4.0.8-9327-1355430107-278.6585-4-0@example.com>: Could not send mail
with command /opt/rt3/etc/msmtp_wrapper -oi -t: program unexpectedly
closed pipe at /opt/rt4/sbin/…/lib/RT/Interface/Email.pm line 467.

Stack:
[/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:467]
[/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/IO/Handle.pm:401]
[/usr/lib/perl5/site_perl/5.8.8/MIME/Head.pm:535]
[/usr/lib/perl5/site_perl/5.8.8/Mail/Internet.pm:112]
[/usr/lib/perl5/site_perl/5.8.8/MIME/Entity.pm:1770]
[/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:474]
[/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:292]
[/opt/rt4/sbin/…/lib/RT/Action/SendEmail.pm:114]
[/opt/rt4/sbin/…/lib/RT/ScripAction.pm:232]
[/opt/rt4/sbin/…/lib/RT/Scrip.pm:475]
[/opt/rt4/sbin/…/lib/RT/Scrips.pm:188]
[/opt/rt4/sbin/…/lib/RT/Transaction.pm:201]
[/opt/rt4/sbin/…/lib/RT/Record.pm:1493]
[/opt/rt4/sbin/…/lib/RT/Ticket.pm:676]
[/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:1548]
[/opt/rt4/share/html/REST/1.0/NoAuth/mail-gateway:61]
(/opt/rt4/sbin/…/lib/RT/Interface/Email.pm:488)

Everything was working fine before the upgrade. I’m on mstmp version 1.4.16

Can anyone help out with this?
Thanks.

Hello all,

I updated to 4.0.8 from 4.0.5 today and now outgoing emails are failing
with the following error:
[Thu Dec 13 20:21:48 2012] [crit]:
<rt-4.0.8-9327-1355430107-278.6585-4-0@example.com
mailto:rt-4.0.8-9327-1355430107-278.6585-4-0@example.com>: Could not
send mail with command /opt/rt3/etc/msmtp_wrapper -oi -t: program
unexpectedly closed pipe at /opt/rt4/sbin/…/lib/RT/Interface/Email.pm
line 467.

Web server config and Configuration → Tools → System Configuration
output, please.

Web server config and Configuration -> Tools -> System Configuration
output, pleas

Here’s the sys config.

Thanks!

Please keep your replies to the list.

Your sys config suggests you’re running mod_perl, but you didn’t include
your web server config as requested.

Web server config and Configuration -> Tools -> System Configuration
output, pleas

Here’s the sys config.

Thanks!

Please keep your replies to the list.

Your sys config suggests you’re running mod_perl, but you didn’t include
your web server config as requested.

Sorry, but what server config do you want? The whole httpd.conf file?

Sorry, but what server config do you want? The whole httpd.conf file?

Yep, or at least the part with the VirtualHost settings for RT.

Your sys config suggests you’re running mod_perl, but you didn’t include
your web server config as requested.

Sorry, but what server config do you want? The whole httpd.conf file?

Here’s the rt.conf:
<VirtualHost 192.168.0.30>
ServerName rt.gourmettrading.local
### Optional apache logs for RT
# ErrorLog /opt/rt4/var/log/apache2.error
# TransferLog /opt/rt4/var/log/apache2.access
# LogLevel debug

           AddDefaultCharset UTF-8

           DocumentRoot "/opt/rt4/share/html"
           <Location />
               Order allow,deny
               Allow from all

               SetHandler perl-script
               PerlResponseHandler Plack::Handler::Apache2
               PerlSetVar psgi_app /opt/rt4/sbin/rt-server
           </Location>
           <Perl>
               use Plack::Handler::Apache2;

Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");

SetHandler perl-script

This line bites you, it should be “SetHandler modperl”.

Best regards, Ruslan.

SetHandler perl-script

This line bites you, it should be “SetHandler modperl”.


Best regards, Ruslan.

That fixed it! Thanks. I wonder how it’s been working all these years!

That fixed it! Thanks. I wonder how it’s been working all these years!

Behaviour changed from RT 3.8 to RT 4.0, and although there were still
problems with “SetHandler perl-script” under 3.8, sending mail was not
one of them.