Rt-4.0.0rc1 and MySQL 5.5.8

Has anyone seen and solved the problem below? All my efforts at Go-ogle have
yielded no solution.

mail# make initialize-database
/usr/bin/perl -I/opt/rt4/local/lib -I/opt/rt4/lib sbin/rt-setup-database
–action init --dba root --prompt-for-dba-password
In order to create or update your RT database, this script needs to connect
to your mysql instance on localhost as root
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Working with:
Type: mysql
Host: localhost
Name: rt4
User: rt3xuser
DBA: root
Character set ‘latin1’ is not a compiled character set and is not specified
in the ‘/usr/local/share/mysql/charsets/Index.xml’ file
Failed to connect to dbi:mysql:;host=localhost as user ‘root’: Can’t
initialize character set latin1 (path: /usr/local/share/mysql/charsets/)***
Error code 255

Stop in /usr/home/wash/Tools/RT/RT-4/rt-4.0.0rc1.

Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223


Damn!!

Has anyone seen and solved the problem below? All my efforts at Go-ogle have
yielded no solution.

This looks like you have mysql configured to default to latin1 tables,
but haven’t compiled in latin1. Is it possible that you have a my.cnf
from one version of mysql and have built your own newer version of
mysql without including latin1?

The sessions table doesn’t specify an encoding, so it uses the
default which appears to be set to latin1 for you.

-kevin

Hello Kevin,

When installing MyQL using FreeBSD ports, usually there is not much in the
way for the installer to customize, bar for doing a “make config”. In my
case, there is nothing in the options available to disable any encoding.
And yes, I was using my.conf which was from MySQL 5.5.7. I only upgraded
that to 5.5.8 and things broke! rt-3.9.7 was not complaining about this
latin1 encoding when I initialized the db. All I had to change was
s/TYPE=Innodb/ENGINE=Innodb/g in schema.mysql for MySQL-5.5 to agree to
initialize-database.

So this breakage seems to be in MySQL 5.5.8 itself, or the way the port
maintainer configured it.On Mon, Jan 3, 2011 at 7:01 PM, Kevin Falcone falcone@bestpractical.comwrote:

On Fri, Dec 31, 2010 at 01:42:33PM +0300, Odhiambo Washington wrote:

Has anyone seen and solved the problem below? All my efforts at Go-ogle
have
yielded no solution.

This looks like you have mysql configured to default to latin1 tables,
but haven’t compiled in latin1. Is it possible that you have a my.cnf
from one version of mysql and have built your own newer version of
mysql without including latin1?

The sessions table doesn’t specify an encoding, so it uses the
default which appears to be set to latin1 for you.

-kevin

mail# make initialize-database
/usr/bin/perl -I/opt/rt4/local/lib -I/opt/rt4/lib sbin/rt-setup-database
–action init --dba root --prompt-for-dba-password
In order to create or update your RT database, this script needs to
connect
to your mysql instance on localhost as root
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Working with:
Type: mysql
Host: localhost
Name: rt4
User: rt3xuser
DBA: root
Character set ‘latin1’ is not a compiled character set and is not
specified
in the ‘/usr/local/share/mysql/charsets/Index.xml’ file
Failed to connect to dbi:mysql:;host=localhost as user ‘root’: Can’t
initialize character set latin1 (path:
/usr/local/share/mysql/charsets/)***
Error code 255

Stop in /usr/home/wash/Tools/RT/RT-4/rt-4.0.0rc1.


List info:
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel

Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223


Damn!!

Hello Kevin,

When installing MyQL using FreeBSD ports, usually there is not much in the way for the
installer to customize, bar for doing a “make config”. In my case, there is nothing in the
options available to disable any encoding.
And yes, I was using my.conf which was from MySQL 5.5.7. I only upgraded that to 5.5.8 and
things broke! rt-3.9.7 was not complaining about this latin1 encoding when I initialized the
db. All I had to change was s/TYPE=Innodb/ENGINE=Innodb/g in schema.mysql for MySQL-5.5 to
agree to initialize-database.

Interesting. We’ve already changed TYPE to ENGINE for 4.0.0rc2, and
I’ll be tacking on an explicit charset of ascii for sessions (as well
as flagging that table as innodb).

-kevin