Rt 3.8.9 on ubuntu 8.04 - login problem

Dear friends.

I am setting up a rt 3.8.9 on Ubuntu 8.04

after successfully installed rt and start the apache2 by reading the README,
i met the following 2 problems:

  1. the display speed of the main page is very slow, it may take 1 minute to
    open the login screen.
  2. username “root” and the password “password” doesn’t work, I always get
    the “http://noauth/Login.html

I try to reset the root password, but doesn’t work for me by:

perl -I/opt/rt3/local/lib -I/opt/rt3/lib \
-MRT -MRT::User \
-e’RT::LoadConfig();RT::Init(); my $u = RT::User->new($RT::SystemUser);
$u->Load(“root”); $u->SetPassword(“secret”)’

So I guess something wrong with my configuration, can someone give me some
suggestion?

the site configration is:

Set($rtname, “kk”);
Set($Organization, “rt.kk.org”);
Set($Timezone, ‘US/Pacific’);
Set($WebBaseURL, “http://rt.kk.org”);
Set($WebPath, “/”);
Set($CorrespondAddress, ‘correspond@kk.org’);
Set($CommentAddress, ‘comment@kk.org’);
Set($SendmailPath, “/usr/lib/sendmail”);
Set($OwnerEmail, "admin@example.com");

and the apache configuration is:

<VirtualHost *> 
   ServerName rt.example.com 
   DocumentRoot /opt/rt3/share/html 
   AddDefaultCharset UTF-8 
   PerlModule Apache::DBI 
   PerlRequire /opt/rt3/bin/webmux.pl 

   <Location /> 
       SetHandler perl-script 
       PerlHandler RT::Mason 
   </Location> 

</VirtualHost> 

here is the warning information from apache2

[warning]: We opened /dev/null to protect FD #1, but descriptor #1 is
already occupied at /opt/rt3/bin/webmux.pl line 78.
(/opt/rt3/bin/webmux.pl:78)

No more other error information…

View this message in context: http://old.nabble.com/rt-3.8.9-on-ubuntu-8.04---login-problem-tp30977146p30977146.html

Dear friends.

I am setting up a rt 3.8.9 on Ubuntu 8.04

after successfully installed rt and start the apache2 by reading the README,
i met the following 2 problems:

  1. the display speed of the main page is very slow, it may take 1 minute to
    open the login screen.
  2. username “root” and the password “password” doesn’t work, I always get
    the “http://noauth/Login.html

Is that the actual URL you get?
Also, when RT fails a login, you should see ‘FAILED LOGIN for’ in the logs

-kevin

Hello

yes, it is the exact address I got.
I checked the /var/log/messages, the only thing regarding with RT is:

We opened /dev/null to protect FD #1, but descriptor #1 is already occupied
at /opt/rt3/bin/webmux.pl line 78. (/opt/rt3/bin /webmux.pl:78)

could you please adivce on this? Thanks man

Kevin Falcone-2 wrote:

Dear friends.

I am setting up a rt 3.8.9 on Ubuntu 8.04

after successfully installed rt and start the apache2 by reading the
README,
i met the following 2 problems:

  1. the display speed of the main page is very slow, it may take 1 minute
    to
    open the login screen.
  2. username “root” and the password “password” doesn’t work, I always get
    the “http://noauth/Login.html

Is that the actual URL you get?
Also, when RT fails a login, you should see ‘FAILED LOGIN for’ in the logs

-kevin

I try to reset the root password, but doesn’t work for me by:


perl -I/opt/rt3/local/lib -I/opt/rt3/lib \
-MRT -MRT::User \
-e’RT::LoadConfig();RT::Init(); my $u =
RT::User->new($RT::SystemUser);
$u->Load(“root”); $u->SetPassword(“secret”)’


So I guess something wrong with my configuration, can someone give me
some
suggestion?

the site configration is:


Set($rtname, “kk”);
Set($Organization, “rt.kk.org”);
Set($Timezone, ‘US/Pacific’);
Set($WebBaseURL, “http://rt.kk.org”);
Set($WebPath, “/”);
Set($CorrespondAddress, ‘correspond@kk.org’);
Set($CommentAddress, ‘comment@kk.org’);
Set($SendmailPath, “/usr/lib/sendmail”);
Set($OwnerEmail, "admin@example.com");

and the apache configuration is:


<VirtualHost *> 
   ServerName rt.example.com 
   DocumentRoot /opt/rt3/share/html 
   AddDefaultCharset UTF-8 
   PerlModule Apache::DBI 
   PerlRequire /opt/rt3/bin/webmux.pl 

   <Location /> 
       SetHandler perl-script 
       PerlHandler RT::Mason 
   </Location> 

</VirtualHost> 

here is the warning information from apache2


[warning]: We opened /dev/null to protect FD #1, but descriptor #1 is
already occupied at /opt/rt3/bin/webmux.pl line 78.
(/opt/rt3/bin/webmux.pl:78)

No more other error information…


View this message in context:
http://old.nabble.com/rt-3.8.9-on-ubuntu-8.04---login-problem-tp30977146p30977146.html
Sent from the Request Tracker - User mailing list archive at Nabble.com.

View this message in context: http://old.nabble.com/rt-3.8.9-on-ubuntu-8.04---login-problem-tp30977146p30985179.html

yes, it is the exact address I got.

Interesting, since it contains neither your hostname of rt.kk.org and
noauth is spelled wrong (RT uses NoAuth).

I checked the /var/log/messages, the only thing regarding with RT is:

We opened /dev/null to protect FD #1, but descriptor #1 is already occupied
at /opt/rt3/bin/webmux.pl line 78. (/opt/rt3/bin /webmux.pl:78)

What version of mod_perl2 are you running?

-kevin

Set WebDomain and don’t touch WebBaseURL.

Regards, Ruslan. From phone.

Dear friends.

I am setting up a rt 3.8.9 on Ubuntu 8.04

after successfully installed rt and start the apache2 by reading the
README,
i met the following 2 problems:

  1. the display speed of the main page is very slow, it may take 1 minute
    to
    open the login screen.
  2. username “root” and the password “password” doesn’t work, I always get
    the “http://noauth/Login.html

I try to reset the root password, but doesn’t work for me by:

perl -I/opt/rt3/local/lib -I/opt/rt3/lib
-MRT -MRT::User
-e’RT::LoadConfig();RT::Init(); my $u = RT::User->new($RT::SystemUser);
$u->Load(“root”); $u->SetPassword(“secret”)’

So I guess something wrong with my configuration, can someone give me some
suggestion?

the site configration is:


Set($rtname, “kk”);
Set($Organization, “rt.kk.org”);
Set($Timezone, ‘US/Pacific’);
Set($WebBaseURL, “http://rt.kk.org”);
Set($WebPath, “/”);
Set($CorrespondAddress, ‘correspond@kk.org’);
Set($CommentAddress, ‘comment@kk.org’);
Set($SendmailPath, “/usr/lib/sendmail”);
Set($OwnerEmail, "admin@example.com");

and the apache configuration is:


<VirtualHost *>
ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason

here is the warning information from apache2

[warning]: We opened /dev/null to protect FD #1, but descriptor #1 is
already occupied at /opt/rt3/bin/webmux.pl line 78.
(/opt/rt3/bin/webmux.pl:78)

No more other error information…


View this message in context:
http://old.nabble.com/rt-3.8.9-on-ubuntu-8.04---login-problem-tp30977146p30977146.html

Hello

from the dpkg --list, i see the mod_perl2 is:

root@yycat:~# dpkg --list | grep mod-perl
ii libapache2-mod-perl2 2.0.3-2ubuntu2
Integration of perl with the Apache2 web ser

nrtusern wrote:

Dear friends.

I am setting up a rt 3.8.9 on Ubuntu 8.04

after successfully installed rt and start the apache2 by reading the
README, i met the following 2 problems:

  1. the display speed of the main page is very slow, it may take 1 minute
    to open the login screen.
  2. username “root” and the password “password” doesn’t work, I always get
    the “http://noauth/Login.html

I try to reset the root password, but doesn’t work for me by:


perl -I/opt/rt3/local/lib -I/opt/rt3/lib \
-MRT -MRT::User \
-e’RT::LoadConfig();RT::Init(); my $u =
RT::User->new($RT::SystemUser); $u->Load(“root”);
$u->SetPassword(“secret”)’


So I guess something wrong with my configuration, can someone give me some
suggestion?

the site configration is:


Set($rtname, “kk”);
Set($Organization, “rt.kk.org”);
Set($Timezone, ‘US/Pacific’);
Set($WebBaseURL, “http://rt.kk.org”);
Set($WebPath, “/”);
Set($CorrespondAddress, ‘correspond@kk.org’);
Set($CommentAddress, ‘comment@kk.org’);
Set($SendmailPath, “/usr/lib/sendmail”);
Set($OwnerEmail, "admin@example.com");

and the apache configuration is:


<VirtualHost *> 
   ServerName rt.example.com 
   DocumentRoot /opt/rt3/share/html 
   AddDefaultCharset UTF-8 
   PerlModule Apache::DBI 
   PerlRequire /opt/rt3/bin/webmux.pl 

   <Location /> 
       SetHandler perl-script 
       PerlHandler RT::Mason 
   </Location> 

</VirtualHost> 

here is the warning information from apache2


[warning]: We opened /dev/null to protect FD #1, but descriptor #1 is
already occupied at /opt/rt3/bin/webmux.pl line 78.
(/opt/rt3/bin/webmux.pl:78)

No more other error information…

View this message in context: http://old.nabble.com/rt-3.8.9-on-ubuntu-8.04---login-problem-tp30977146p30994427.html