RT-3.8.8 Pg Ubuntu 10.10 amd64 - seeing login prompt at each page

I have an in install of RT-3.8.8 Pg backend Ubuntu 10.10 amd64.

Things seem to work OK, but the login prompt is displayed at every page link.

Since this is an internal test server, I am using http://serveralias/rt to
access rt instead of the FQDN entered in the Ubuntu package configuration step.
I would suspect this as a problem, but it worked fine with the initial sqlite
backend test.

Any ideas on misconfiguration I might look into?

Thanks,
Jeff

I have an in install of RT-3.8.8 Pg backend Ubuntu 10.10 amd64.

Things seem to work OK, but the login prompt is displayed at every page link.

Since this is an internal test server, I am using http://serveralias/rt to
access rt instead of the FQDN entered in the Ubuntu package configuration step.
I would suspect this as a problem, but it worked fine with the initial sqlite
backend test.

Any ideas on misconfiguration I might look into?

Pg puts sessions in the DB, sqlite puts sessions on the filesystem, so
there really isn’t much of a comparision there.

Normally accessing RT through an alias RT doesn’t know about results
in redirects to the wrong hostname and cookies aren’t sent.

As I usually advise when this comes up, you need to look at what
cookies RT is sending you and what cookies are sent back to RT to
begin untangling it. Anything else is speculation.

-kevin

Kevin Falcone <falcone bestpractical.com> writes:

Pg puts sessions in the DB, sqlite puts sessions on the filesystem, so
there really isn’t much of a comparision there.

Normally accessing RT through an alias RT doesn’t know about results
in redirects to the wrong hostname and cookies aren’t sent.

As I usually advise when this comes up, you need to look at what
cookies RT is sending you and what cookies are sent back to RT to
begin untangling it. Anything else is speculation.

-kevin

Thanks for the tip. I took the following steps, to no effect. Can you suggest
anything else I might look for?

  • remove all cookies, there were 2.
  • change configuration to 1.2.3.4 everywhere, restart apache.
  • sudo -u postgres psql -d rtdb -c “delete from sessions;” 73 rows.
  • browse to http://1.2.3.4/rt, login, check cookie, one created
    each link-login cycle, below:

rtdb=# select id, lastupdated from sessions;
id | lastupdated
(0 rows)

login, click link, login,
rtdb=# select id, lastupdated from sessions;
id | lastupdated
177274163d2d9e5c63d9206e59be8e7a | 2011-03-24 22:39:02.782436
2ae80cdb59debb85a8bd5e1586f94be1 | 2011-03-24 22:39:12.454886
96ec379e94a5aefa5ce9d6c2359ff8a3 | 2011-03-24 22:39:21.660138
(3 rows)

Cookie

http://1.2.3.4/rt/
1 cookie
Name RT_SID_test_it.80
Value 96ec379e94a5aefa5ce9d6c2359ff8a3
Host 10.132.3.17
Path /rt
Secure No
Expires At End Of Session

$ sudo cat /etc/request-tracker3.8/RT_SiteConfig.d/50-debconf

THE BASICS:

Set($rtname, ‘test_it’);
Set($Organization, ‘rt.acme.com’);

Set($CorrespondAddress , ‘rt@server1.acme.com’);
Set($CommentAddress , ‘rt-comment@server1.acme.com’);

THE WEBSERVER:

Set($WebPath , “/rt”);
#Set($WebBaseURL , “http://server1.acme.com”);
Set($WebBaseURL , “http://1.2.3.4”);

$ tail -n 1 /etc/apache2/apache2.conf
ServerName tickets

$ tail -n 5 /etc/apache2/sites-available/default

Include /etc/request-tracker3.8/apache2-modperl2.conf
RedirectMatch ^/$ /rt

Thanks for the tip. I took the following steps, to no effect. Can you suggest
anything else I might look for?

You need to check if your browser is sending a cookie to RT and RT is
refusing/ignoring it or if your browser isn’t sending the cookie.
Wireshark is probably your friend.

Also, the RT_SITE is for test_it which is tied to your rtname and
your port number, so if any of that changes (or if there is any
proxying happening) you may run into interesting problems.

Another common point is that setting $WebDomain is preferable to
setting $WebBaseURL, but it should all work out. You can confirm that
by looking in Configuration -> Tools -> System Configuration

Also, you provided 50-debconf, but did you rerun the RT_SiteConfig
generation tool to update RT_SiteConfig.pm with your changes?

-kevin

Another common point is that setting $WebDomain is preferable to
setting $WebBaseURL, but it should all work out. You can confirm that
by looking in Configuration -> Tools -> System Configuration

It’s not preferable, it’s required.

Best regards, Ruslan.