RT 3.8.7 + SLA 0.03 + RTFM 2.4.2 - How to setup holidays in ServiceBusinessHours?

Dear RT Community:
My SLA 3 and 4 never set the correct due date unless I mark #BusinessHours => ‘work’, in below configuration. After I did that, my SLA 3 and 4 work again without issue. They even calculate the due date based on my ‘work’ setting (0-6). But the problem now is, my holidays setting never apply to ticket. Can someone help to guide me thru on how to setup holidays in RT_SiteConfig.pm? Your advice will be much appreciated.
#Set Business HoursSet( %ServiceBusinessHours, ‘work’ => { 0 => {Name => ‘Sunday’,Start => ‘undef’, End => ‘undef’ }, 1 => {Name => ‘Monday’,Start => ‘07:30’, End => ‘17:30’ }, 2 => {Name => ‘Tuesday’,Start => ‘7:30’, End => ‘17:30’ }, 3 => {Name => ‘Wednesday’,Start => ‘7:30’, End => ‘17:30’ }, 4 => {Name => ‘Thursday’,Start => ‘7:30’, End => ‘17:30’ }, 5 => {Name => ‘Friday’,Start => ‘7:30’, End => ‘17:30’ }, 6 => {Name => ‘Saturday’,Start => ‘undef’, End => ‘undef’ }, holidays => [qw(2011-01-01 2011-01-02 2011-01-03 2011-01-07 2011-02-18 2011-03-8 2011-04-14 2011-04-15 2011-04-16 2011-04-17 2011-04-18 2011-05-01 2011-05-02 2011-05-13 2011-05-14 2011-05-15 2011-05-16 2011-05-17 2011-05-21 2011-05-22 2011-05-23 2011-06-1 2011-06-18 2011-06-18 2011-06-19 2011-06-20 2011-09-24 2011-09-25 2011-09-26 2011-09-27 2011-09-28 2011-10-29 2011-10-30 2011-10-31 2011-11-09 2011-11-10 2011-11-11 2011-12-10 2011-12-11 2011-12-12)], },);
#RT::Extension::SLA ConfigSet( %ServiceAgreements, Default => ‘sev4’, QueueDefault => { ‘General’ => ‘sev4’, }, Levels => { ‘sev1’ => { StartImmediately => 1, Response => { RealMinutes => 600.5 }, Resolve => { RealMinutes => 604 } }, ‘sev2’ => { StartImmediately => 1, Response => { RealMinutes => 600.5 }, Resolve => { RealMinutes => 6012 } }, ‘sev3’ => { #BusinessHours => ‘work’, OutOfHours => { Resolve => { RealMinutes => +6028 } }, Response => { BusinessMinutes => 604 }, Resolve => { BusinessMinutes => 6028 } }, ‘sev4’ => { #BusinessHours => ‘work’, OutOfHours => { Resolve => { RealMinutes => +6052 } }, Response => { BusinessMinutes => 608 }, Resolve => { BusinessMinutes => 6052 } }, }, );+++++Regards,Rithy

Please kindly help out…

Regards,RithyFrom: rithy4u_os@hotmail.com
To: rt-users@lists.bestpractical.com
Date: Mon, 6 Dec 2010 06:37:44 +0000
Subject: [rt-users] RT 3.8.7 + SLA 0.03 + RTFM 2.4.2 - How to setup holidays in ServiceBusinessHours?

Dear RT Community:
My SLA 3 and 4 never set the correct due date unless I mark #BusinessHours => ‘work’, in below configuration. After I did that, my SLA 3 and 4 work again without issue. They even calculate the due date based on my ‘work’ setting (0-6). But the problem now is, my holidays setting never apply to ticket. Can someone help to guide me thru on how to setup holidays in RT_SiteConfig.pm? Your advice will be much appreciated.
#Set Business HoursSet( %ServiceBusinessHours, ‘work’ => { 0 => {Name => ‘Sunday’,Start => ‘undef’, End => ‘undef’ }, 1 => {Name => ‘Monday’,Start => ‘07:30’, End => ‘17:30’ }, 2 => {Name => ‘Tuesday’,Start => ‘7:30’, End => ‘17:30’ }, 3 => {Name => ‘Wednesday’,Start => ‘7:30’, End => ‘17:30’ }, 4 => {Name => ‘Thursday’,Start => ‘7:30’, End => ‘17:30’ }, 5 => {Name => ‘Friday’,Start => ‘7:30’, End => ‘17:30’ }, 6 => {Name => ‘Saturday’,Start => ‘undef’, End => ‘undef’ }, holidays => [qw(2011-01-01 2011-01-02 2011-01-03 2011-01-07 2011-02-18 2011-03-8 2011-04-14 2011-04-15 2011-04-16 2011-04-17 2011-04-18 2011-05-01 2011-05-02 2011-05-13 2011-05-14 2011-05-15 2011-05-16 2011-05-17 2011-05-21 2011-05-22 2011-05-23 2011-06-1 2011-06-18 2011-06-18 2011-06-19 2011-06-20 2011-09-24 2011-09-25 2011-09-26 2011-09-27 2011-09-28 2011-10-29 2011-10-30 2011-10-31 2011-11-09 2011-11-10 2011-11-11 2011-12-10 2011-12-11 2011-12-12)], },);
#RT::Extension::SLA ConfigSet( %ServiceAgreements, Default => ‘sev4’, QueueDefault => { ‘General’ => ‘sev4’, }, Levels => { ‘sev1’ => { StartImmediately => 1, Response => { RealMinutes => 600.5 }, Resolve => { RealMinutes => 604 } }, ‘sev2’ => { StartImmediately => 1, Response => { RealMinutes => 600.5 }, Resolve => { RealMinutes => 6012 } }, ‘sev3’ => { #BusinessHours => ‘work’, OutOfHours => { Resolve => { RealMinutes => +6028 } }, Response => { BusinessMinutes => 604 }, Resolve => { BusinessMinutes => 6028 } }, ‘sev4’ => { #BusinessHours => ‘work’, OutOfHours => { Resolve => { RealMinutes => +6052 } }, Response => { BusinessMinutes => 608 }, Resolve => { BusinessMinutes => 6052 } }, }, );+++++Regards,Rithy

I beg for your help…

Regards,RithyFrom: rithy4u_os@hotmail.com
To: rt-users@lists.bestpractical.com
Date: Tue, 7 Dec 2010 05:12:15 +0000
Subject: Re: [rt-users] RT 3.8.7 + SLA 0.03 + RTFM 2.4.2 - How to setup holidays in ServiceBusinessHours?

Please kindly help out…

Regards,Rithy

From: rithy4u_os@hotmail.com
To: rt-users@lists.bestpractical.com
Date: Mon, 6 Dec 2010 06:37:44 +0000
Subject: [rt-users] RT 3.8.7 + SLA 0.03 + RTFM 2.4.2 - How to setup holidays in ServiceBusinessHours?

Dear RT Community:
My SLA 3 and 4 never set the correct due date unless I mark #BusinessHours => ‘work’, in below configuration. After I did that, my SLA 3 and 4 work again without issue. They even calculate the due date based on my ‘work’ setting (0-6). But the problem now is, my holidays setting never apply to ticket. Can someone help to guide me thru on how to setup holidays in RT_SiteConfig.pm? Your advice will be much appreciated.
#Set Business HoursSet( %ServiceBusinessHours, ‘work’ => { 0 => {Name => ‘Sunday’,Start => ‘undef’, End => ‘undef’ }, 1 => {Name => ‘Monday’,Start => ‘07:30’, End => ‘17:30’ }, 2 => {Name => ‘Tuesday’,Start => ‘7:30’, End => ‘17:30’ }, 3 => {Name => ‘Wednesday’,Start => ‘7:30’, End => ‘17:30’ }, 4 => {Name => ‘Thursday’,Start => ‘7:30’, End => ‘17:30’ }, 5 => {Name => ‘Friday’,Start => ‘7:30’, End => ‘17:30’ }, 6 => {Name => ‘Saturday’,Start => ‘undef’, End => ‘undef’ }, holidays => [qw(2011-01-01 2011-01-02 2011-01-03 2011-01-07 2011-02-18 2011-03-8 2011-04-14 2011-04-15 2011-04-16 2011-04-17 2011-04-18 2011-05-01 2011-05-02 2011-05-13 2011-05-14 2011-05-15 2011-05-16 2011-05-17 2011-05-21 2011-05-22 2011-05-23 2011-06-1 2011-06-18 2011-06-18 2011-06-19 2011-06-20 2011-09-24 2011-09-25 2011-09-26 2011-09-27 2011-09-28 2011-10-29 2011-10-30 2011-10-31 2011-11-09 2011-11-10 2011-11-11 2011-12-10 2011-12-11 2011-12-12)], },);
#RT::Extension::SLA ConfigSet( %ServiceAgreements, Default => ‘sev4’, QueueDefault => { ‘General’ => ‘sev4’, }, Levels => { ‘sev1’ => { StartImmediately => 1, Response => { RealMinutes => 600.5 }, Resolve => { RealMinutes => 604 } }, ‘sev2’ => { StartImmediately => 1, Response => { RealMinutes => 600.5 }, Resolve => { RealMinutes => 6012 } }, ‘sev3’ => { #BusinessHours => ‘work’, OutOfHours => { Resolve => { RealMinutes => +6028 } }, Response => { BusinessMinutes => 604 }, Resolve => { BusinessMinutes => 6028 } }, ‘sev4’ => { #BusinessHours => ‘work’, OutOfHours => { Resolve => { RealMinutes => +6052 } }, Response => { BusinessMinutes => 608 }, Resolve => { BusinessMinutes => 6052 } }, }, );+++++Regards,Rithy

Hello,

Your config looks good. Please, turn on debug loggin in the RT config,
stop/start server and try again, then collect errors from logs.
Without logs it’s hard to guess what went wrong.

Holidays are supported in late versions of Business::Hours module, may
be version of the module you’re using is old.On Thu, Dec 9, 2010 at 6:28 AM, Rithy R rithy4u_os@hotmail.com wrote:

I beg for your help…

Regards,
Rithy


From: rithy4u_os@hotmail.com
To: rt-users@lists.bestpractical.com
Date: Tue, 7 Dec 2010 05:12:15 +0000
Subject: Re: [rt-users] RT 3.8.7 + SLA 0.03 + RTFM 2.4.2 - How to setup
holidays in ServiceBusinessHours?

Please kindly help out…

Regards,
Rithy


From: rithy4u_os@hotmail.com
To: rt-users@lists.bestpractical.com
Date: Mon, 6 Dec 2010 06:37:44 +0000
Subject: [rt-users] RT 3.8.7 + SLA 0.03 + RTFM 2.4.2 - How to setup holidays
in ServiceBusinessHours?

Dear RT Community:
My SLA 3 and 4 never set the correct due date unless I mark #BusinessHours
=> ‘work’, in below configuration. After I did that, my SLA 3 and 4 work
again without issue. They even calculate the due date based on my 'work’
setting (0-6). But the problem now is, my holidays setting never apply to
ticket. Can someone help to guide me thru on how to setup holidays in
RT_SiteConfig.pm? Your advice will be much appreciated.
+++++
#Set Business Hours
Set( %ServiceBusinessHours,
‘work’ => {
0 => {Name => ‘Sunday’,Start => ‘undef’, End => ‘undef’ },
1 => {Name => ‘Monday’,Start => ‘07:30’, End => ‘17:30’ },
2 => {Name => ‘Tuesday’,Start => ‘7:30’, End => ‘17:30’ },
3 => {Name => ‘Wednesday’,Start => ‘7:30’, End => ‘17:30’ },
4 => {Name => ‘Thursday’,Start => ‘7:30’, End => ‘17:30’ },
5 => {Name => ‘Friday’,Start => ‘7:30’, End => ‘17:30’ },
6 => {Name => ‘Saturday’,Start => ‘undef’, End => ‘undef’ },
holidays => [qw(2011-01-01 2011-01-02 2011-01-03 2011-01-07 2011-02-18
2011-03-8 2011-04-14 2011-04-15 2011-04-16 2011-04-17 2011-04-18 2011-05-01
2011-05-02 2011-05-13 2011-05-14 2011-05-15 2011-05-16 2011-05-17 2011-05-21
2011-05-22 2011-05-23 2011-06-1 2011-06-18 2011-06-18 2011-06-19 2011-06-20
2011-09-24 2011-09-25 2011-09-26 2011-09-27 2011-09-28 2011-10-29 2011-10-30
2011-10-31 2011-11-09 2011-11-10 2011-11-11 2011-12-10 2011-12-11
2011-12-12)],
},
);
#RT::Extension::SLA Config
Set( %ServiceAgreements,
Default => ‘sev4’,
QueueDefault => {
‘General’ => ‘sev4’,
},
Levels => {
‘sev1’ => {
StartImmediately => 1,
Response => { RealMinutes => 600.5 },
Resolve => { RealMinutes => 60
4 } },
‘sev2’ => {
StartImmediately => 1,
Response => { RealMinutes => 600.5 },
Resolve => { RealMinutes => 60
12 } },
‘sev3’ => {
#BusinessHours => ‘work’,
OutOfHours => { Resolve => { RealMinutes => +6028 } },
Response => { BusinessMinutes => 60
4 },
Resolve => { BusinessMinutes => 6028 } },
‘sev4’ => {
#BusinessHours => ‘work’,
OutOfHours => { Resolve => { RealMinutes => +60
52 } },
Response => { BusinessMinutes => 608 },
Resolve => { BusinessMinutes => 60
52 } },
},
);
+++++
Regards,
Rithy

Best regards, Ruslan.