RT 3.8.7 - How to configure RT::FM along with RT::Extension::SLA?

Dear RT Community,
My RT was working with with below config:
Set(@Plugins, qw( RT::Extension::SLA));
After setup RTFM 2.4.2 my config look like this:
Set(@Plugins, qw( RT::Extension::SLA RT::FM));
Once I restart apache, I found RTFM link in my RT home page but when new ticket is created, my SLA extension stop working and it is no longer change the due date based on SLA setup.
Please kindly help to advise.
Regards,Rithy

Please … any one can help me…

Regards,RithyFrom: rithy4u_os@hotmail.com
To: rt-users@lists.bestpractical.com
Date: Mon, 15 Nov 2010 09:16:08 +0000
Subject: [rt-users] RT 3.8.7 - How to configure RT::FM along with RT::Extension::SLA?

Dear RT Community,
My RT was working with with below config:
Set(@Plugins, qw( RT::Extension::SLA));
After setup RTFM 2.4.2 my config look like this:
Set(@Plugins, qw( RT::Extension::SLA RT::FM));
Once I restart apache, I found RTFM link in my RT home page but when new ticket is created, my SLA extension stop working and it is no longer change the due date based on SLA setup.
Please kindly help to advise.
Regards,Rithy

Please … any one can help me…

As mentioned in the bug report you filed, it is hard to help without
knowing more about your actual config (preferably from Configuration
-> Tools -> System COnfiguration) and what you mean by ‘the sla
extension stopped working’

I’ve run RTFM and SLA together without issue

-kevin

Hi Kevin,Let me try to explain the case. I installed RT 3.8.7 and SLA Extension 0.03. I have configured my RT_SiteConfig.pm as below:+++++#other settings#SLA configSet(@Plugins, qw(RT::Extension::SLA));#other settings+++++then I installed RTFM 2.4.1 but since I cannot new article with some error, I upgraded it to RTFM 2.4.2.After researching for some best practice I found a good setting and I apply it to my RT_SiteConfig.pm as below:+++++#other settings#SLA configSet(@Plugins, qw(RT::Extension::SLA RT::FM));#other settings+++++After I applied the setting, restart apache I found RTFM menu in RT 3.8.7 web interface (I logged in as root). I can create article at this time. The problem is, when create new ticket, my SLA extension assigned correct sla level I set up but it never change due date/time like before. What are missing here? Can you advise your configuration that made these two extensions work together? I do appreciate your advice and wish all the best.Regards,Rithy> Date: Tue, 16 Nov 2010 10:02:56 -0500> From: falcone@bestpractical.com> To: rt-users@lists.bestpractical.com> Subject: Re: [rt-users] RT 3.8.7 - Need urgent help to configure RT::FM> > On Tue, Nov 16, 2010 at 01:57:52PM +0000, Rithy R wrote:> > Please … any one can help me…> > As mentioned in the bug report you filed, it is hard to help without> knowing more about your actual config (preferably from Configuration> -> Tools -> System COnfiguration) and what you mean by ‘the sla> extension stopped working’> > I’ve run RTFM and SLA together without issue> > -kevin> > > > > ----------------------------------------------------------------------------------------------> > > > From: rithy4u_os@hotmail.com> > To: rt-users@lists.bestpractical.com> > Date: Mon, 15 Nov 2010 09:16:08 +0000> > Subject: [rt-users] RT 3.8.7 - How to configure RT::FM along with RT::Extension::SLA?> > > > Dear RT Community,> > My RT was working with with below config:> > Set(@Plugins, qw(> > RT::Extension::SLA> > ));> > After setup RTFM 2.4.2 my config look like this:> > Set(@Plugins, qw(> > RT::Extension::SLA> > RT::FM> > ));> > Once I restart apache, I found RTFM link in my RT home page but when new ticket is created, my> > SLA extension stop working and it is no longer change the due date based on SLA setup.> > Please kindly help to advise.> > Regards,> > Rithy

After I applied the setting, restart apache I found RTFM menu in RT 3.8.7 web interface (I
logged in as root). I can create article at this time. The problem is, when create new ticket,
my SLA extension assigned correct sla level I set up but it never change due date/time like
before. What are missing here? Can you advise your configuration that made these two
extensions work together? I do appreciate your advice and wish all the best.

If you disable RTFM does it suddenly work again? The SLA extension
works using Scrips, which RTFM doesn’t change.

-kevin

Hi Kevin,
If I remove RT::FM from RT_SiteConfig.pm, the SLA extension work immediately, it can set due date based on my setting just like before. Please kindly help out…

Regards,Rithy

If I remove RT::FM from RT_SiteConfig.pm, the SLA extension work immediately, it can set due
date based on my setting just like before. Please kindly help out…

Does it happen on 3.8.8?

-kevin

Hi Kevin,
I am new to RT so even I tried to download RT3.8.8 and install it manually on Ubuntu 10, I cannot complete it. The error return after I run:
/etc/request-tracker3.8/sbin/rt-setup-database –dba rt –prompt-for-dba-password –action upgradeThe RTAddressRegexp option is not set in the config. Not setting this option results in additional SQL queries to check whether each address belongs to RT or not. It is especially important to set this option if RT recieves emails on addresses that are not in the database or config. (/etc/request-tracker3.8/sbin/…/lib/RT/Config.pm:343)
Please help, I really need RTFM.

Regards,Rithy

Hi Kevin,
I am new to RT so even I tried to download RT3.8.8 and install it manually on Ubuntu 10, I
cannot complete it. The error return after I run:
/etc/request-tracker3.8/sbin/rt-setup-database *dba rt *prompt-for-dba-password *action
upgrade
The RTAddressRegexp option is not set in the config. Not setting this option results in
additional SQL queries to check whether each address belongs to RT or not. It is especially
important to set this option if RT recieves emails on addresses that are not in the database
or config. (/etc/request-tracker3.8/sbin/…/lib/RT/Config.pm:343)

You should configure your RTAddressRegexp in RT_SiteConfig.pm. If you
only use the addresses configured as CorrespondAddress/CommentAddress
on your queues or globally, then you can safely ignore this error (it
has been downgraded to a warning for 3.8.9)

I asked a coworker to investigate and he was able to use RTFM
and SLA simultaneously on 3.8.7 and 3.8.8.

-kevin

Hi Kevin,
I really want to run SLA and RTFM with RT 3.8.7 since I am new to RT. Can you please advise some configuration example? I am running Ubuntu 10. Thank you so much.

Regards,Rithy