RT 3.8.2 - httpd fails to start after CentOS 5.3 upgrade (from 5.2)

I just did yum updates on CentOS to take me from 5.2 to 5.3. Now, httpd fails to start.

/var/log/httpd/error_log shows:

[Sat Apr 18 16:24:36 2009] [error] File::Temp version 0.18 required–this is onl
y version 0.16 at /usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm line 14.\nBEGIN f
ailed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm line
14.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/MIME/Entity
.pm line 233.\nBEGIN failed–compilation aborted at /usr/lib/perl5/site_perl/5.8
.8/MIME/Entity.pm line 233.\nCompilation failed in require at /opt/rt3/bin/…/li
b/RT/I18N.pm line 65.\nBEGIN failed–compilation aborted at /opt/rt3/bin/…/lib/
RT/I18N.pm line 65.\nCompilation failed in require at /opt/rt3/bin/…/lib/RT.pm
line 152.\nBEGIN failed–compilation aborted at /opt/rt3/bin/webmux.pl line 102.
\nCompilation failed in require at (eval 2) line 1.\n
[Sat Apr 18 16:24:36 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl
for server itadmin.bigrocksports.com:0, exiting…

“yum list perl” shows:
Installed Packages
perl.i386 4:5.8.8-18.el5_3.1 installed

Can someone help me get running again? It would appear that the last perl upgrade is not compatible with RT 3.8.2? How do I downgrade perl if that is the problem? I am in a bind and would greatly appreciate any help.

The first line of the error log tells you everything. You need version 18,
but you only have version installed. This problem is likely due to the
perl upgrade that happened as a result of the system upgrade.
You can use CPAN to update the perl module, or you can install it via yum:
yum upgrade perl-File-Temp

There are probably a few more broken perl modules…

James Moseley

I just did yum updates on CentOS to take me from 5.2 to 5.3. Now, httpd
fails to start.

/var/log/httpd/error_log shows:

[Sat Apr 18 16:24:36 2009] [error] File::Temp version 0.18 required–this
is onl
y version 0.16 at /usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm line
14.\nBEGIN f
ailed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm
line
14.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8
/MIME/Entity
.pm line 233.\nBEGIN failed–compilation aborted at
/usr/lib/perl5/site_perl/5.8
.8/MIME/Entity.pm line 233.\nCompilation failed in require at
/opt/rt3/bin/…/li
b/RT/I18N.pm line 65.\nBEGIN failed–compilation aborted at
/opt/rt3/bin/…/lib/
RT/I18N.pm line 65.\nCompilation failed in require at
/opt/rt3/bin/…/lib/RT.pm
line 152.\nBEGIN failed–compilation aborted at /opt/rt3/bin/webmux.pl line
102.
\nCompilation failed in require at (eval 2) line 1.\n

[Sat Apr 18 16:24:36 2009] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl
for server itadmin.bigrocksports.com:0, exiting…

“yum list perl” shows:
Installed Packages

perl.i386 4:5.8.8-18.el5_3.1
installed

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I had to update the following modules:
File::Temp
Sys::Syslog

Now, apache starts and I am good to go. Thanks for the advice.----- Original Message ----
From: "jmoseley@corp.xanadoo.com" jmoseley@corp.xanadoo.com
To: Shannon Adams shannon_adams68@yahoo.com
Cc: rt-users@lists.bestpractical.com; rt-users-bounces@lists.bestpractical.com
Sent: Saturday, April 18, 2009 6:07:22 PM
Subject: Re: [rt-users] RT 3.8.2 - httpd fails to start after CentOS 5.3 upgrade (from 5.2)

The first line of the error log tells you everything. You need version 18,
but you only have version installed. This problem is likely due to the
perl upgrade that happened as a result of the system upgrade.
You can use CPAN to update the perl module, or you can install it via yum:
yum upgrade perl-File-Temp

There are probably a few more broken perl modules…

James Moseley

I just did yum updates on CentOS to take me from 5.2 to 5.3. Now, httpd
fails to start.

/var/log/httpd/error_log shows:

[Sat Apr 18 16:24:36 2009] [error] File::Temp version 0.18 required–this
is onl
y version 0.16 at /usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm line
14.\nBEGIN f
ailed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/MIME/Tools.pm
line
14.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8
/MIME/Entity
.pm line 233.\nBEGIN failed–compilation aborted at
/usr/lib/perl5/site_perl/5.8
.8/MIME/Entity.pm line 233.\nCompilation failed in require at
/opt/rt3/bin/…/li
b/RT/I18N.pm line 65.\nBEGIN failed–compilation aborted at
/opt/rt3/bin/…/lib/
RT/I18N.pm line 65.\nCompilation failed in require at
/opt/rt3/bin/…/lib/RT.pm
line 152.\nBEGIN failed–compilation aborted at /opt/rt3/bin/webmux.pl line
102.
\nCompilation failed in require at (eval 2) line 1.\n

[Sat Apr 18 16:24:36 2009] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl
for server itadmin.bigrocksports.com:0, exiting…

“yum list perl” shows:
Installed Packages

perl.i386 4:5.8.8-18.el5_3.1
installed

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com