Rt 3.8.1 home link on interface

Hi,

How do I change the home link on the interface to not point at 127.0.0.1 ?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy

Win New York holidays with Kellogg’s & Live Search
http://clk.atdmt.com/UKM/go/107571440/direct/01/

Web* options in the RT config.On Fri, Aug 22, 2008 at 4:17 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

How do I change the home link on the interface to not point at 127.0.0.1 ?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy

Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at 127.0.0.1 ?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.

Win New York holidays with Kellogg’s & Live Search
http://clk.atdmt.com/UKM/go/107571440/direct/01/

Look at webbaseurl setting.From: rt-users-bounces@lists.bestpractical.com rt-users-bounces@lists.bestpractical.com
To: Ruslan Zakirov ruz@bestpractical.com
Cc: rt mailing list rt-users@lists.bestpractical.com
Sent: Fri Aug 22 07:25:55 2008
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy

Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at 127.0.0.1 ?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.

Get fish-slapping on Messenger! Play Now http://clk.atdmt.com/UKM/go/101719805/direct/01/

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty value).

=cutOn Fri, Aug 22, 2008 at 4:25 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

On Fri, Aug 22, 2008 at 4:17 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

How do I change the home link on the interface to not point at 127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

Look at webbaseurl setting.

Don’t play with this variable in 3.8.1 unless you know what you’re
doing. WebDomain, WebPath and WebPort are all you need in most cases.

----- Original Message -----
From: rt-users-bounces@lists.bestpractical.com
rt-users-bounces@lists.bestpractical.com
To: Ruslan Zakirov ruz@bestpractical.com
Cc: rt mailing list rt-users@lists.bestpractical.com
Sent: Fri Aug 22 07:25:55 2008
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at 127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now
http://clk.atdmt.com/UKM/go/101719805/direct/01/


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

I retract my statement (sorry Andrew, didn’t mean to lead you in the wrong direction).From: ruslan.zakirov@gmail.com [mailto:ruslan.zakirov@gmail.com] On Behalf Of Ruslan Zakirov
Sent: Friday, August 22, 2008 8:47 AM
To: Helmuth Ramirez
Cc: andrew.fay@hotmail.co.uk; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Look at webbaseurl setting.

Don’t play with this variable in 3.8.1 unless you know what you’re
doing. WebDomain, WebPath and WebPort are all you need in most cases.

----- Original Message -----
From: rt-users-bounces@lists.bestpractical.com
rt-users-bounces@lists.bestpractical.com
To: Ruslan Zakirov ruz@bestpractical.com
Cc: rt mailing list rt-users@lists.bestpractical.com
Sent: Fri Aug 22 07:25:55 2008
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at 127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now
http://clk.atdmt.com/UKM/go/101719805/direct/01/


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

Hi,

No problem,

Maybe I have default set up wrong in apache ?

I dont mind if its only at 127.0.0.1 and not /rt as long as it works :wink:

Any ideas?

this is what I have ::

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
# ErrorLog /opt/rt3/var/log/apache2.error
# TransferLog /opt/rt3/var/log/apache2.access

PerlRequire "/opt/rt3/bin/webmux.pl"

<Location /NoAuth/images>
    SetHandler default
</Location>
<Location />
    SetHandler perl-script
    PerlResponseHandler RT::Mason
</Location>

Subject: RE: [rt-users] rt 3.8.1 home link on interface
Date: Fri, 22 Aug 2008 08:50:42 -0400
From: HelmuthRamirez@compupay.com
To: ruz@bestpractical.com
CC: andrew.fay@hotmail.co.uk; rt-users@lists.bestpractical.com

I retract my statement (sorry Andrew, didn’t mean to lead you in the wrong direction).

-----Original Message-----
From: ruslan.zakirov@gmail.com [mailto:ruslan.zakirov@gmail.com] On Behalf Of Ruslan Zakirov
Sent: Friday, August 22, 2008 8:47 AM
To: Helmuth Ramirez
Cc: andrew.fay@hotmail.co.uk; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Look at webbaseurl setting.

Don’t play with this variable in 3.8.1 unless you know what you’re
doing. WebDomain, WebPath and WebPort are all you need in most cases.

----- Original Message -----
From: rt-users-bounces@lists.bestpractical.com
rt-users-bounces@lists.bestpractical.com
To: Ruslan Zakirov ruz@bestpractical.com
Cc: rt mailing list rt-users@lists.bestpractical.com
Sent: Fri Aug 22 07:25:55 2008
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at 127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now
http://clk.atdmt.com/UKM/go/101719805/direct/01/


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.

Win a voice over part with Kung Fu Panda & Live Search and 100’s of Kung Fu Panda prizes to win with Live Search
http://clk.atdmt.com/UKM/go/107571439/direct/01/

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘/rt’ );

That’s all you need, as far as I can see. Domain is DOMAIN and is not
domain + path.On Fri, Aug 22, 2008 at 4:40 PM, Ruslan Zakirov ruz@bestpractical.com wrote:

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty value).

=cut

On Fri, Aug 22, 2008 at 4:25 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

On Fri, Aug 22, 2008 at 4:17 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

How do I change the home link on the interface to not point at 127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.

Best regards, Ruslan.

Hi

I have tried that and all that happens is when i log on to 127.0.0.1/rt it comes up with the login screen with no formatting… just text

I have noticed when I click links they are 127.0.0.1/search/simple.html etc and they work so possibly I should be working in the root directory but I have somehow set it to use /rt ? somewhere. I say this because if I try 127.0.0.1/rt/search/simple.html i get page not found

Sorry I am pretty new to this as last time I installed I used ubuntu synaptic package manager to install : )

Thanks,

Andy

Date: Fri, 22 Aug 2008 17:01:33 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘/rt’ );

That’s all you need, as far as I can see. Domain is DOMAIN and is not
domain + path.

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty value).

=cut

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at 127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.

Get Hotmail on your mobile from Vodafone
http://clk.atdmt.com/UKM/go/107571435/direct/01/

Also,

When i first hope RT the first page says no found…

if i click approvals which is

http://127.0.0.1/Approvals

then go back to home which is http://127.0.0.1/

I get RT at a glance up… otherwise i get It Works default apache page… so i am pretty convinced i should be working in the root directory but have no idea how to get rid of these default apache settings,

thanks,

AndyFrom: andrew.fay@hotmail.co.uk
To: ruz@bestpractical.com
Date: Fri, 22 Aug 2008 13:06:46 +0000
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi

I have tried that and all that happens is when i log on to 127.0.0.1/rt it comes up with the login screen with no formatting… just text

I have noticed when I click links they are 127.0.0.1/search/simple.html etc and they work so possibly I should be working in the root directory but I have somehow set it to use /rt ? somewhere. I say this because if I try 127.0.0.1/rt/search/simple.html i get page not found

Sorry I am pretty new to this as last time I installed I used ubuntu synaptic package manager to install : )

Thanks,

Andy

Date: Fri, 22 Aug 2008 17:01:33 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘/rt’ );

That’s all you need, as far as I can see. Domain is DOMAIN and is not
domain + path.

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty value).

=cut

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at 127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.

Find out how to make Messenger your very own TV! Try it Now!

Get Hotmail on your mobile from Vodafone
http://clk.atdmt.com/UKM/go/107571435/direct/01/

delete all the crap you have in your virtual host and leave something like:

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
# ServerSignature On

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
# ErrorLog /opt/rt3/var/log/apache2.error
# TransferLog /opt/rt3/var/log/apache2.access

PerlRequire "/opt/rt3/bin/webmux.pl"

<Location /NoAuth/images>
    SetHandler default
</Location>
<Location />
    SetHandler perl-script
    PerlResponseHandler RT::Mason
</Location>

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘’ );On Fri, Aug 22, 2008 at 5:15 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Also,

When i first hope RT the first page says no found…

if i click approvals which is

http://127.0.0.1/Approvals

then go back to home which is http://127.0.0.1/

I get RT at a glance up… otherwise i get It Works default apache page… so
i am pretty convinced i should be working in the root directory but have no
idea how to get rid of these default apache settings,

thanks,

Andy


From: andrew.fay@hotmail.co.uk
To: ruz@bestpractical.com
Date: Fri, 22 Aug 2008 13:06:46 +0000
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi

I have tried that and all that happens is when i log on to 127.0.0.1/rt it
comes up with the login screen with no formatting… just text

I have noticed when I click links they are 127.0.0.1/search/simple.html etc
and they work so possibly I should be working in the root directory but I
have somehow set it to use /rt ? somewhere. I say this because if I try
127.0.0.1/rt/search/simple.html i get page not found

Sorry I am pretty new to this as last time I installed I used ubuntu
synaptic package manager to install : )

Thanks,

Andy


Date: Fri, 22 Aug 2008 17:01:33 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘/rt’ );

That’s all you need, as far as I can see. Domain is DOMAIN and is not
domain + path.

On Fri, Aug 22, 2008 at 4:40 PM, Ruslan Zakirov ruz@bestpractical.com wrote:

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty value).

=cut

On Fri, Aug 22, 2008 at 4:25 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

On Fri, Aug 22, 2008 at 4:17 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

How do I change the home link on the interface to not point at
127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it
works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.


Find out how to make Messenger your very own TV! Try it Now!


Find out how to make Messenger your very own TV! Try it Now!

Best regards, Ruslan.

Thanks,

That worked!

Andy

Date: Fri, 22 Aug 2008 17:18:58 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

delete all the crap you have in your virtual host and leave something like:

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
# ServerSignature On

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
# ErrorLog /opt/rt3/var/log/apache2.error
# TransferLog /opt/rt3/var/log/apache2.access

PerlRequire "/opt/rt3/bin/webmux.pl"

<Location /NoAuth/images>
    SetHandler default
</Location>
<Location />
    SetHandler perl-script
    PerlResponseHandler RT::Mason
</Location>

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘’ );

Also,

When i first hope RT the first page says no found…

if i click approvals which is

http://127.0.0.1/Approvals

then go back to home which is http://127.0.0.1/

I get RT at a glance up… otherwise i get It Works default apache page… so
i am pretty convinced i should be working in the root directory but have no
idea how to get rid of these default apache settings,

thanks,

Andy


From: andrew.fay@hotmail.co.uk
To: ruz@bestpractical.com
Date: Fri, 22 Aug 2008 13:06:46 +0000
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi

I have tried that and all that happens is when i log on to 127.0.0.1/rt it
comes up with the login screen with no formatting… just text

I have noticed when I click links they are 127.0.0.1/search/simple.html etc
and they work so possibly I should be working in the root directory but I
have somehow set it to use /rt ? somewhere. I say this because if I try
127.0.0.1/rt/search/simple.html i get page not found

Sorry I am pretty new to this as last time I installed I used ubuntu
synaptic package manager to install : )

Thanks,

Andy


Date: Fri, 22 Aug 2008 17:01:33 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘/rt’ );

That’s all you need, as far as I can see. Domain is DOMAIN and is not
domain + path.

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty value).

=cut

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

Hi,

How do I change the home link on the interface to not point at
127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it
works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.


Find out how to make Messenger your very own TV! Try it Now!


Find out how to make Messenger your very own TV! Try it Now!


Best regards, Ruslan.

Get Hotmail on your mobile from Vodafone
http://clk.atdmt.com/UKM/go/107571435/direct/01/

Hi,

got rt 3.8.1 up and running with an upgraded DB that i restored and upgraded from 3.6.4

when i click through the links i can only get a couple of links through before they all start displaying blank pages,

Any ideas on this?

it happens if i view RT from the localhost or any other machine,

Thanks,

Andy

Win a voice over part with Kung Fu Panda & Live Search and 100’s of Kung Fu Panda prizes to win with Live Search
http://clk.atdmt.com/UKM/go/107571439/direct/01/

note that for other people localhost is also 127.0.0.1 and not
everything will work for them. You need some domain name that resolves
for them or use IP address in WebDomain option.On Fri, Aug 22, 2008 at 5:35 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Thanks,

That worked!

Andy


Date: Fri, 22 Aug 2008 17:18:58 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

delete all the crap you have in your virtual host and leave something
like:

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

ErrorLog /var/log/apache2/error.log

Possible values include: debug, info, notice, warn, error, crit,

alert, emerg.

LogLevel warn

CustomLog /var/log/apache2/access.log combined

ServerSignature On

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

optional apache logs for RT

ErrorLog /opt/rt3/var/log/apache2.error

TransferLog /opt/rt3/var/log/apache2.access

PerlRequire “/opt/rt3/bin/webmux.pl”

<Location /NoAuth/images>
SetHandler default


SetHandler perl-script
PerlResponseHandler RT::Mason

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘’ );

On Fri, Aug 22, 2008 at 5:15 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Also,

When i first hope RT the first page says no found…

if i click approvals which is

http://127.0.0.1/Approvals

then go back to home which is http://127.0.0.1/

I get RT at a glance up… otherwise i get It Works default apache page…
so
i am pretty convinced i should be working in the root directory but have
no
idea how to get rid of these default apache settings,

thanks,

Andy


From: andrew.fay@hotmail.co.uk
To: ruz@bestpractical.com
Date: Fri, 22 Aug 2008 13:06:46 +0000
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] rt 3.8.1 home link on interface

Hi

I have tried that and all that happens is when i log on to 127.0.0.1/rt
it
comes up with the login screen with no formatting… just text

I have noticed when I click links they are 127.0.0.1/search/simple.html
etc
and they work so possibly I should be working in the root directory but
I
have somehow set it to use /rt ? somewhere. I say this because if I try
127.0.0.1/rt/search/simple.html i get page not found

Sorry I am pretty new to this as last time I installed I used ubuntu
synaptic package manager to install : )

Thanks,

Andy


Date: Fri, 22 Aug 2008 17:01:33 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Set( $WebDomain, ‘localhost’ );
Set( $WebPath, ‘/rt’ );

That’s all you need, as far as I can see. Domain is DOMAIN and is not
domain + path.

On Fri, Aug 22, 2008 at 4:40 PM, Ruslan Zakirov ruz@bestpractical.com wrote:

=item C<$WebPath>

If you’re putting the web ui somewhere other than at the root of
your server, you should set C<$WebPath> to the path you’ll be
serving RT at.

C<$WebPath> requires a leading / but no trailing /.

In most cases, you should leave C<$WebPath> set to ‘’ (an empty
value).

=cut

On Fri, Aug 22, 2008 at 4:25 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

I have tried changing:

Set( $WebDomain, ‘localhost/rt’ );

No effect?

Thanks,

Andy


Date: Fri, 22 Aug 2008 16:18:57 +0400
From: ruz@bestpractical.com
To: andrew.fay@hotmail.co.uk
Subject: Re: [rt-users] rt 3.8.1 home link on interface
CC: rt-users@lists.bestpractical.com

Web* options in the RT config.

On Fri, Aug 22, 2008 at 4:17 PM, andrew fay andrew.fay@hotmail.co.uk wrote:

Hi,

How do I change the home link on the interface to not point at
127.0.0.1
?

my RT install is located at 127.0.0.1/rt

but 127.0.01 just goes to an apache default page that says : it
works

thanks in advance,

Andy


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Get fish-slapping on Messenger! Play Now


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.


Find out how to make Messenger your very own TV! Try it Now!


Find out how to make Messenger your very own TV! Try it Now!


Best regards, Ruslan.


Find out how to make Messenger your very own TV! Try it Now!

Best regards, Ruslan.

andrew fay wrote:

Hi,

got rt 3.8.1 up and running with an upgraded DB that i restored and
upgraded from 3.6.4

when i click through the links i can only get a couple of links through
before they all start displaying blank pages,

Any ideas on this?

it happens if i view RT from the localhost or any other machine,

Thanks,

Andy

Hi Andy,

if you’re using MySQL, then modify your RT database like this:

mysql> ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;

David

Hi,

When i use this command it says error database not selected, how do I select the RTDB database before i do this?

Thanks,

Andy

Date: Fri, 22 Aug 2008 17:31:31 +0200
From: david.svejda@netfriends.cz
To: andrew.fay@hotmail.co.uk
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] 3.8.1 issues, not displaying page

andrew fay wrote:

Hi,

got rt 3.8.1 up and running with an upgraded DB that i restored and
upgraded from 3.6.4

when i click through the links i can only get a couple of links through
before they all start displaying blank pages,

Any ideas on this?

it happens if i view RT from the localhost or any other machine,

Thanks,

Andy

Hi Andy,

if you’re using MySQL, then modify your RT database like this:

mysql> ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;

David

Win a voice over part with Kung Fu Panda & Live Search and 100’s of Kung Fu Panda prizes to win with Live Search
http://clk.atdmt.com/UKM/go/107571439/direct/01/

scratch that… got that monday morning feeling :wink:

use rtdb;From: andrew.fay@hotmail.co.uk
To: david.svejda@netfriends.cz
Date: Mon, 25 Aug 2008 08:04:29 +0000
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] 3.8.1 issues, not displaying page

Hi,

When i use this command it says error database not selected, how do I select the RTDB database before i do this?

Thanks,

Andy

Date: Fri, 22 Aug 2008 17:31:31 +0200
From: david.svejda@netfriends.cz
To: andrew.fay@hotmail.co.uk
CC: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] 3.8.1 issues, not displaying page

andrew fay wrote:

Hi,

got rt 3.8.1 up and running with an upgraded DB that i restored and
upgraded from 3.6.4

when i click through the links i can only get a couple of links through
before they all start displaying blank pages,

Any ideas on this?

it happens if i view RT from the localhost or any other machine,

Thanks,

Andy

Hi Andy,

if you’re using MySQL, then modify your RT database like this:

mysql> ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;

David

Get Hotmail on your mobile from Vodafone Try it Now!

Win New York holidays with Kellogg’s & Live Search
http://clk.atdmt.com/UKM/go/107571440/direct/01/

Hi,

So I installed a fresh copy of 3.8.1… copied the db over from 3.6.4 and upgraded,

Now the attachements are corrupted… any fix for this?

Thanks,

Andy

Make a mini you on Windows Live Messenger!
http://clk.atdmt.com/UKM/go/107571437/direct/01/

I had the same problem when I did a “direct upgrade” from 3.6.x to 3.8.1

It worked for me this way:

  • upgrade to 3.8.0
  • applying the mysql-4.0-41 update
  • upgrade from 3.8.0 to 3.8.1 …

Regards,
Tom

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of andrew
faySent: Monday, August 25, 2008 10:33 AM
To: rt mailing list
Subject: [rt-users] 3.6.4 -> 3.8.1 db corrupting attachments
Importance: High

Hi,

So I installed a fresh copy of 3.8.1.. copied the db over from

3.6.4 and upgraded,

Now the attachements are corrupted.. any fix for this?

Thanks,

Andy