RT 3.6.1 URL issues?

Hi all,

When clicking on a ticket that’s placed in my personal 10 highest priority
tickets that I own, it seems the URL doesn’t properly rewrite itself. It
tries to hit:

http://rt.foo.com/Ticket/Display.html?id=12

This results in a 404.

The correct URL would be:

http://rt.foo.com/rt/Ticket/Display.html?id=12

I don’t have any rewrite rules or redirects in my apache config. Here’s what
the VirtualHost excerpt looks like:

<VirtualHost *:80>
ServerName rt.foo.com
Alias /rt "/opt/rt3/share/html"
PerlModule Apache2::compat
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Thanks for any input!

  • Steve

From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Steve
Finkelstein
Sent: Thursday, 29 March 2007 11:31 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] RT 3.6.1 URL issues?

Hi all,

When clicking on a ticket that’s placed in my personal 10 highest
priority tickets that I own, it seems the URL doesn’t properly rewrite
itself. It tries to hit:

Foo.com

This results in a 404.

The correct URL would be:

Foo.com
http://rt.foo.com/rt/Ticket/Display.html?id=12

I would look at your RT configuration file first - RT_SiteConfig.pm -
and check your $WebPath variable.

HTH

I don’t have any rewrite rules or redirects in my apache config.
Here’s what the VirtualHost excerpt looks like:

<VirtualHost *:80>
ServerName rt.foo.com
Alias /rt “/opt/rt3/share/html”
PerlModule Apache2::compat
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Thanks for any input!

  • Steve