Rt 3.4.5 rpm yum install not working

Hi All,

I have a big problem that I just can’t work out. I’m running CentOS
4.4 (clean install). I first tried installing the latest rt3 tarball,
but some of the perl mods kept failing via CPAN. So I looked for a
RPM which I found instructions for on the bestpractical site and
followed and installed successfully.

I can login ok and everything comes up. Although when I click on
"Tools" I get the following

Can’t locate object method “new” via package
"RT::Action::CreateTickets" at /var/rt/html/Tools/Offline.html line
107.

Trace begun at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Exceptions.pm line 129
HTML::Mason::Exceptions::rethrow_exception(‘Can’t locate object
method “new” via package “RT::Action::CreateTickets” at
/var/rt/html/Tools/Offline.html line 107.^J’) called at
/var/rt/html/Tools/Offline.html line 107
HTML::Mason::Commands::ANON at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xb0608fc)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line
1256
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 1246
HTML::Mason::Request::comp(undef, undef, undef) called at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 915
HTML::Mason::Request::call_next(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /var/rt/html/autohandler line 215
HTML::Mason::Commands::ANON at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xaf4a724)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line
1251
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 1246
HTML::Mason::Request::comp(undef, undef, undef) called at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 412
HTML::Mason::Request::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm
line 168
HTML::Mason::Request::ApacheHandler::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm
line 826
HTML::Mason::ApacheHandler::handle_request(‘HTML::Mason::ApacheHandler=HASH(0xa5ba218)’,
‘Apache2::RequestRec=SCALAR(0xb002514)’) called at /usr/bin/webmux.pl
line 123
eval {…} at /usr/bin/webmux.pl line 123
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0xb002514)’) called at -e line 0
eval {…} at -e line 0

Does anyone know what I’m done wrong and how to fix it? All hat I can
think of is that when I started doing the install from tarball with
’make fixdeps’ it left something that the rpm didn’t like? Although
the ‘make fixdeps’ failed really early…

Can anyone help, it be much appreciated?

Matt

Matthew Simpson wrote:

Hi All,

I have a big problem that I just can’t work out. I’m running CentOS
4.4 (clean install). I first tried installing the latest rt3 tarball,
but some of the perl mods kept failing via CPAN. So I looked for a RPM
which I found instructions for on the bestpractical site and followed
and installed successfully.

I can login ok and everything comes up. Although when I click on
"Tools" I get the following

Can’t locate object method “new” via package
"RT::Action::CreateTickets" at /var/rt/html/Tools/Offline.html line 107.

Trace begun at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Exceptions.pm
line 129
HTML::Mason::Exceptions::rethrow_exception(‘Can’t locate object
method “new” via package “RT::Action::CreateTickets” at
/var/rt/html/Tools/Offline.html line 107.^J’) called at
/var/rt/html/Tools/Offline.html line 107
HTML::Mason::Commands::ANON at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xb0608fc)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 1256
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm
line 1246
HTML::Mason::Request::comp(undef, undef, undef) called at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 915
HTML::Mason::Request::call_next(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /var/rt/html/autohandler line 215
HTML::Mason::Commands::ANON at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xaf4a724)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 1251
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm
line 1246
HTML::Mason::Request::comp(undef, undef, undef) called at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm
line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm
line 412
HTML::Mason::Request::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm
line 168
HTML::Mason::Request::ApacheHandler::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm
line 826
HTML::Mason::ApacheHandler::handle_request(‘HTML::Mason::ApacheHandler=HASH(0xa5ba218)’,
‘Apache2::RequestRec=SCALAR(0xb002514)’) called at /usr/bin/webmux.pl
line 123
eval {…} at /usr/bin/webmux.pl line 123
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0xb002514)’) called at
-e line 0
eval {…} at -e line 0

Does anyone know what I’m done wrong and how to fix it? All hat I can
think of is that when I started doing the install from tarball with
’make fixdeps’ it left something that the rpm didn’t like? Although
the ‘make fixdeps’ failed really early…

Can anyone help, it be much appreciated?

Does ‘make fixdeps’ still fail if you run it?

Jason

Hi All,

I have a big problem that I just can’t work out. I’m running CentOS
4.4 (clean install). I first tried installing the latest rt3 tarball,
but some of the perl mods kept failing via CPAN. So I looked for a
RPM which I found instructions for on the bestpractical site and
followed and installed successfully.

I can login ok and everything comes up. Although when I click on
"Tools" I get the following

Can’t locate object method “new” via package
"RT::Action::CreateTickets" at /var/rt/html/Tools/Offline.html line
107.

Trace begun at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Exceptions.pm line 129
HTML::Mason::Exceptions::rethrow_exception(‘Can’t locate object
method “new” via package “RT::Action::CreateTickets” at
/var/rt/html/Tools/Offline.html line 107.^J’) called at
/var/rt/html/Tools/Offline.html line 107
HTML::Mason::Commands::ANON at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xb0608fc)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line
1256
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 1246
HTML::Mason::Request::comp(undef, undef, undef) called at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 915
HTML::Mason::Request::call_next(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /var/rt/html/autohandler line 215
HTML::Mason::Commands::ANON at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run(‘HTML::Mason::Component::FileBased=HASH(0xaf4a724)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line
1251
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 1246
HTML::Mason::Request::comp(undef, undef, undef) called at
/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 460
eval {…} at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/Request.pm line 412
HTML::Mason::Request::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm
line 168
HTML::Mason::Request::ApacheHandler::exec(‘HTML::Mason::Request::ApacheHandler=HASH(0xb0040f4)’)
called at /usr/lib/perl5/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm
line 826
HTML::Mason::ApacheHandler::handle_request(‘HTML::Mason::ApacheHandler=HASH(0xa5ba218)’,
‘Apache2::RequestRec=SCALAR(0xb002514)’) called at /usr/bin/webmux.pl
line 123
eval {…} at /usr/bin/webmux.pl line 123
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0xb002514)’) called at -e line 0
eval {…} at -e line 0

Does anyone know what I’m done wrong and how to fix it? All hat I can
think of is that when I started doing the install from tarball with
’make fixdeps’ it left something that the rpm didn’t like? Although
the ‘make fixdeps’ failed really early…

Can anyone help, it be much appreciated?

Matt