RT 3.4.5 Problems on custom fields in Query Builder

I’m having problems performing searches with Query Builder using Custom

When I run the search, no values are displayed for custom fields.

The query itself doesn’t looks right in Query Builder: when adding
mandatory custom fields in the Show Columns list, they get extra
characters, incremented evry time you add any other entry in the list.

This is an example:
CustomField: {T_Type (mandatory)} --> when added to the list, it first
shows up normally as "CustomField: {T_Type (mandatory)}"
but the next time I add anything to the list, that row will change into
—> "CustomField: {T_Type ( mandatory )}"
and the next insert again —> "CustomField: {T_Type
( mandatory )}"
and so on.

I also tried to fix the query with the “Advanced” feature, but, after
running the search, I get the same output in the Show Columns list of
Query Builder.

The custom fields are defined global for tickets in all queues.

(RT 3.4.5, MySQL 4.1.12)

Does anyone have an idea of what to do in order to get the right output
from the Query Builder?