RT-3.4.5 installation and perl problem

h,

I just downloaded and tried to install RT 3.4.5. was not really successful to get all the deps fixed. Then I tried perl -v, it says perl 5.8.5. which perl - /usr/bin/perl

however, when i did a make testdeps, on the top it shows perl version 5.8.3…found. I did not specify any option while compiling. It was just /configure.

Any idea what the problem is?

thanks in advance
abilash

h,

I just downloaded and tried to install RT 3.4.5. was not really successful to get all the deps fixed. Then I tried perl -v, it says perl 5.8.5. which perl - /usr/bin/perl

however, when i did a make testdeps, on the top it shows perl version 5.8.3…found. I did not specify any option while compiling. It was just /configure.

The dependency checker is looking for “At least” not “Exactly”. There’s
no problem.

Thanks Jesse. I somehow managed to force install few and got it live now.

I have a problem with my rt-mailgate. I get the following errors…

----- The following addresses had permanent fatal errors -----
"|/opt/rt3/bin/rt-mailgate --queue general --action correspond --url
http://xxxxxx"
(reason: Service unavailable)
(expanded from: general@xxxxxxxxxxxxxxxxxxx)

----- Transcript of session follows -----
553 5.3.0 header syntax error, line "X-name-MailScanner-Information: Please
contact the ISP for more information"
553 5.3.0 header syntax error, line "X-name-MailScanner: Found to be clean"
553 5.3.0 header syntax error, line "X-name-MailScanner-From:
user@xxxxxxxxxxxxxxx"
smrsh: “rt-mailgate” not available for sendmail programs (stat failed)
554 5.0.0 Service unavailable

I’m using MailScanner with sendmail.

Any idea if MailScanner is causing this problem? Also, is there a way to fix
it without having to uninstall MailScanner? I searched on the list and found
no suitable reply.

Thanks in advance for your help.

Abilash----- Original Message -----
From: “Jesse Vincent” jesse@bestpractical.com
To: “Abilash Praveen M” abilashpraveen82@hotmail.com
Cc: rt-users@lists.bestpractical.com
Sent: Friday, January 13, 2006 7:48 PM
Subject: Re: [rt-users] RT-3.4.5 installation and perl problem

On Fri, Jan 13, 2006 at 04:39:40PM +0530, Abilash Praveen M wrote:

h,

I just downloaded and tried to install RT 3.4.5. was not really
successful to get all the deps fixed. Then I tried perl -v, it says perl
5.8.5. which perl - /usr/bin/perl

however, when i did a make testdeps, on the top it shows perl version
5.8.3…found. I did not specify any option while compiling. It was just
/configure.

The dependency checker is looking for “At least” not “Exactly”. There’s
no problem.

Any idea what the problem is?

thanks in advance
abilash


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O’Reilly Media at
http://rtbook.bestpractical.com

WE’RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at
http://bestpractical.com/services/training.html