RT 3.4.2 and Transaction Custom Fields Problem

I’m having a problem with RT 3.4.2 and using Transaction Custom Fields.

We are trying to use RT to track our time on installations and support
requests. The first phase of this will be to have each person enter their
time worked, billable time, travel time and travel mileage per transaction
on a ticket. Having the fields appear on each transaction and editable by
each user is not a problem. The problem is that after the initial create
transaction (if done through the web interface) the only value that is
actually saved is the first Transaction Custom Field. Here is an example:

Create Transaction:
[RT Defined]
Worked: 0 {entered} / 0 {saved}
[Transaction Custom Field]
Billable Time: 15 {entered} / 15 {saved}
Travel Time: 20 {entered} / 20 {saved}
Travel Mileage: 15 {entered} / 15 {saved}

Transaction #2
[RT Defined]
Worked: 30 {entered} / 30 {saved}
[Transaction Custom Field]
Billable Time: 30 {entered} / 30 {saved}
Travel Time: 35 {entered} / 1 {saved}
Travel Mileage: 20 {entered} / 1 {saved}

Transaction #3
[RT Defined]
Worked: 25 {entered} / 25 {saved}
[Transaction Custom Field]
Billable Time: 15 {entered} / 15 {saved}
Travel Time: 20 {entered} / 1 {saved}
Travel Mileage: 15 {entered} / 1 {saved}

In the above example the value “25 {entered} / 25 {saved}” represents that
the value of 25 was typed into the field and RT saved the value of 25.

Anyone have any ideas why this is happening?


Mike Coakley
Managed Business
Voice - 973-252-0770 x2100
Fax - 973-252-1797
eFax - 425-790-6641