RT 3.4.0rc3

I’m somewhat ashamed to announce the release of RT 3.4.0rc3. This
release features a retraction of comming 1976, as well as new tests to
ensure that the particular errors caused by that issue never happen
again. (Primarily ticket watcher and custom field searching were
broken.)

Jesse

Hey Jesse,

RT 3.4.0rc3 ‘make testdeps’ says:

    DBIx::SearchBuilder 1.19...MISSING
            DBIx::SearchBuilder version 1.19 required--this is only

version 1.18 at (eval 55) line 2.

I have rc1 installed and am trying to upgrade. I used CPAN to install
the latest version, but it only has DBIx::SearchBuilder 1.18. Is CPAN
behind?

It just went up to cpan tonight. 1.18 will work reasonably well (it’s
only really key for the fix that rc4 fixes.

Jesse Vincent wrote:

I’m somewhat ashamed to announce the release of RT 3.4.0rc3. This
release features a retraction of comming 1976, as well as new tests to
ensure that the particular errors caused by that issue never happen
again. (Primarily ticket watcher and custom field searching were
broken.)

Hey Jesse,

RT 3.4.0rc3 ‘make testdeps’ says:

    DBIx::SearchBuilder 1.19...MISSING
            DBIx::SearchBuilder version 1.19 required--this is only

version 1.18 at (eval 55) line 2.

I have rc1 installed and am trying to upgrade. I used CPAN to install
the latest version, but it only has DBIx::SearchBuilder 1.18. Is CPAN
behind?

–[Lance]

Celebrate The Circle http://www.celebratethecircle.org/
Carolina Spirit Quest http://www.carolinaspiritquest.org/
My LiveJournal http://www.livejournal.com/users/labrown/
GPG Fingerprint: 409B A409 A38D 92BF 15D9 6EEE 9A82 F2AC 69AC 07B9
CACert.org Assurer

I was able to run “make upgrade” fine from rc1 to rc3. However my
DBIx::SearchBuilder is only 1.16 but it didn’t complain about the
version 1.19

My RT is running fine at 3.4.rc3From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Lance A.
Brown
Sent: Saturday, January 08, 2005 6:56 PM
To: Jesse Vincent
Cc: rt-users@lists.bestpractical.com; rt-devel@lists.bestpractical.com
Subject: [rt-users] Re: RT 3.4.0rc3

Jesse Vincent wrote:

I’m somewhat ashamed to announce the release of RT 3.4.0rc3. This
release features a retraction of comming 1976, as well as new tests to

ensure that the particular errors caused by that issue never happen
again. (Primarily ticket watcher and custom field searching were
broken.)

Hey Jesse,

RT 3.4.0rc3 ‘make testdeps’ says:

    DBIx::SearchBuilder 1.19...MISSING
            DBIx::SearchBuilder version 1.19 required--this is only

version 1.18 at (eval 55) line 2.

I have rc1 installed and am trying to upgrade. I used CPAN to install
the latest version, but it only has DBIx::SearchBuilder 1.18. Is CPAN
behind?

–[Lance]

Celebrate The Circle http://www.celebratethecircle.org/
Carolina Spirit Quest http://www.carolinaspiritquest.org/
My LiveJournal http://www.livejournal.com/users/labrown/
GPG Fingerprint: 409B A409 A38D 92BF 15D9 6EEE 9A82 F2AC 69AC 07B9
CACert.org Assurer _______________________________________________
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

CONFIDENTIALITY NOTICE: The information contained in this message and
or attachments is intended only for the person or entity to which it is
addressed and may contain confidential and/or privileged material. Any
review, retransmission, dissemination, copying, or other use of this
information by persons or entities other than the intended recipient is
prohibited. If you received this e-mail or its attachments in error,
please contact the sender and delete the material from any system and
destroy any copies.

I was able to run “make upgrade” fine from rc1 to rc3. However my
DBIx::SearchBuilder is only 1.16 but it didn’t complain about the
version 1.19

but running ‘make testdeps’ would have told you that you were missing a
dependency. And by “fine” you mean that you haven’t run into any issues
yet. Which is different from “there aren’t any known issues.”