Rt-3.0.0-rc3: configuration of mail gateway

Hello List,
I have now successfully installed rc3 on another host, where I try to
set up the mail gateway. I did the following, as stated in the
documentation

  1. link rt-mailgate to smrsh directory
  2. set up the following in /etc/aliases: (next line probably broken by
    mua, is one line really).
    rt3-test: “|/opt/rt3/bin/rt-mailgate --queue test --action correspond
    –url https://dock.hamburg.fcb.com/rt3/
  3. run newaliases
  4. send a message to the server.
  5. No ticket is created (this is with the global default scrips of a
    virgin rt3 installation).
    my maillog reveals the following to me:

Mar 19 16:29:43 tom sendmail[20513]: h2JFTgF20512:
to="|/opt/rt3/bin/rt-mailgate --queue test --action correspond --url
https://dock.hamburg.fcb.com/rt3/",
ctladdr=rt3-test@tom.fcb-wilkens.com (8/0), delay=00:00:01,
xdelay=00:00:01, mailer=prog, pri=30094, dsn=4.0.0, stat=Deferred: prog
mailer (/usr/sbin/smrsh) exited with EX_TEMPFAIL

To be honest, I know next to nothing about what that means. Any hints?

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

https is not implemented

just use http as url type

Thanks for the quick reply, but the http server is not for RT only. And
I want the normal users to access the rt interface via ssl (because of
the encryption).
Changing to http would imply I need to have the RT instance accessible
via http for normal users as well, no?
If not, how do I configure apache to allow https access for end users
and http access for the mail gateway only?
Pointers to docs are very welcome (I am new to SSL enabled web sites).
Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

Just a FYI, HTTPS is working just fine for me (2.1.75). You just need
to make sure all the relevant perl modules are installed for LWP to
connect via SSL. Also FWIW, that is not the error I got when I
first tried it, but again, I’m not using smrsh. You might want to
check your smrsh logs for more info.

-AaronOn Wed, Mar 19, 2003 at 04:06:11PM +0100, Harald Wagener wrote:

Am Mittwoch, 19.03.03 um 16:02 Uhr schrieb Gerald Fehringer:

https is not implemented

just use http as url type

Aaron Turner aturner@netscreen.com work: 408-543-4025
Sr. Security Engineer fax: 408-543-8006
NetScreen Technologies, Inc
All emails by me are PGP signed; a bad signature indicates a forgery.

Just a FYI, HTTPS is working just fine for me (2.1.75). You just need
to make sure all the relevant perl modules are installed for LWP to
connect via SSL.

Which modules do I need? Would You post a list for everyone’s
enlightenment?

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

Am Mittwoch, 19.03.03 um 16:02 Uhr schrieb Gerald Fehringer:

https is not implemented

I am using https here. It was mentioned it requires either of the following
modules:

IO::Socket::SSL or Net::SSL

    cheers
   - wash 

Odhiambo Washington, wash@wananchi.com . WANANCHI ONLINE LTD (Nairobi, KE) |
http://ns2.wananchi.com/~wash/ . 1ere Etage, Loita Hse, Loita St., |
GSM: (+254) 722 743 223 . # 10286, 00100 NAIROBI |
“Oh My God! They killed init! You Bastards!”
–from a /. post

Am Mittwoch, 19.03.03 um 16:02 Uhr schrieb Gerald Fehringer:

https is not implemented

I am using https here. It was mentioned it requires either of the
following
modules:

IO::Socket::SSL or Net::SSL

Thanks. I figured out Crypt::SSLeay works as well. Now I just need to
test it with the mail gateway.
I found the attached script on the net, which tests if ssl enabled LWP
works.

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

testssl.pl (663 Bytes)

Hello List,
I now have a fully working rt 3 instance using an ssl host. Thanks for
all Your help. This is on RedHat 7.2, with apache 1.3.23, perl 5.6.1,
fastcgi2.4.0, rt 3.0.0rc3, rtfm2 beta4, mysql 3.23. I would request
that a pointer to Crypt:SSLeay (which subsumes Net:SSL) will be part of
the installation instructions. On the other hand - it’s in the archives
now…

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

Am Mittwoch, 19.03.03 um 16:32 Uhr schrieb Aaron Turner:

Just a FYI, HTTPS is working just fine for me (2.1.75). You just need
to make sure all the relevant perl modules are installed for LWP to
connect via SSL.

Which modules do I need? Would You post a list for everyone’s
enlightenment?

this should do the trick if my memory serves:

perl -MCPAN -e ‘install Net::SSL’

Aaron Turner aturner@netscreen.com work: 408-543-4025
Sr. Security Engineer fax: 408-543-8006
NetScreen Technologies, Inc
All emails by me are PGP signed; a bad signature indicates a forgery.