Resolved-----Upgrading RT4.2.1-->4.4.2 error at startup


#1

Hello,

I have run

./configure
make testdep
make fixdeps
make testdeps
make upgrade
make upgrade-database

then I started the httpd after a few changes to the config. I got this error:

[error]: Can't locate CSS/Minifier/XS.pm in @INC (@INC contains: /opt/rt4/sbin/../local/lib /opt/rt4/sbin/../lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at /opt/rt4/sbin/../lib/RT/Squish/CSS.pm line 67.

I discovered that the permissions were read just for owner - root. So I changed the permissions and now I get this error:

[error]: Can't locate loadable object for module CSS::Minifier::XS in @INC (@INC contains: /opt/rt4/sbin/../local/lib /opt/rt4/sbin/../lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at /opt/rt4/sbin/../lib/RT/Squish/CSS.pm line 67.

I tried deleting CSS/Minifier/XS.pm and force reinstalling it with cpan and like this:

cpanm CSS::Minifier::XS --force
--> Working on CSS::Minifier::XS
Fetching http://www.cpan.org/authors/id/G/GT/GTERMARS/CSS-Minifier-XS-0.09.tar.gz ... OK
Configuring CSS-Minifier-XS-0.09 ... OK
Building and testing CSS-Minifier-XS-0.09 ... OK
Successfully reinstalled CSS-Minifier-XS-0.09
1 distribution installed

but is still get the error “can’t locate loadable object.” Googling that error I find suggestions that it can be cause by copying .pm files instead of installing them correctly but that is not the case. Any suggestions would be much appreciated.

Thanks,
Lois


#2

I found the problem. I don’t know why but when make fixdeps ran it made all of the CSS/Minifier directories and files only accessible by root. I don’t know why it would do that or where it is set to do that. But having fixed permissions on a lot of files and directories in the perl libraries I at least have a login screen.


#3

There is an option for configure to set the owner/group of the webserver
files. Fixdeps will do the correct thing if done.

Regards,

Joop


#4

Thanks! So if I use the permissions option in configure then make fixdeps will set the permissions correctly. Why would it not set them correctly to begin with?