RES: Error on startup -- new install

Hello There!!

I’m with the same problem here… I installed RT 3.4.0rc6 without problem (all dependencies its’s ok!) but when I started Apache this message error appears in error.log:

[Tue Jan 25 16:21:45 2005] [error] Can’t locate Apache/Constants.pm in @INC (@INC contains: /opt/rt3/local/lib /opt/rt3/lib /opt/perl/lib/site_perl/5.8.5/Apache2 /opt/perl/lib/5.8.5 /opt/perl/lib/site_perl/5.8.5 /opt/perl/lib/site_perl . /opt/apache/ /opt/apache/lib/perl) at /opt/perl/lib/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm line 13.\nBEGIN failed–compilation aborted at /opt/perl/lib/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm line 13.\nCompilation failed in require at /opt/rt3/lib/RT/Interface/Web/Handler.pm line 134.\nCompilation failed in require at (eval 2) line 1.\n

I wrote this lines in httpd.conf:

<VirtualHost :5000>
ServerName vento:5000
ServerAdmin email
DocumentRoot "/opt/rt3/share/html"
AddDefaultCharset UTF-8
PerlOptions +Parent
PerlModule Apache::compat
PerlModule Apache::DBI
PerlRequire "/opt/rt3/bin/webmux.pl"
ErrorLog logs/5000/error.log
CustomLog logs/5000/access.log common
RedirectMatch (.
)/$ http://vento:5000$1/index.html

SetHandler perl-script
PerlHandler RT::Mason

What’s happening???

Thank’s for regards!!!
Rodolfo Reis
Brazil.

-----Mensagem original-----De: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com]Em nome de John van
Oppen
Enviada em: terça-feira, 25 de janeiro de 2005 13:18
Para: rt-users@lists.bestpractical.com
Assunto: AW: [rt-users] Re: Error on startup – new install

This is the Apache config for the site I mentioned in the last email:

<VirtualHost 64.185.104.25>
ServerName rt.pocketinet.com
DocumentRoot /apps/rt3/share/html
AddDefaultCharset UTF-8

these four lines apply to Apache2+mod_perl2 only: {{{

PerlSetVar MasonArgsMethod CGI
PerlModule Apache2 Apache::compat
RewriteEngine On
RewriteRule ^(.*)/$ $1/index.html

}}}

PerlModule Apache::DBI
PerlRequire /apps/rt3/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason

Von: John van Oppen
Gesendet: Tuesday, January 25, 2005 7:01 AM
An: rt-users@lists.bestpractical.com
Betreff: RE: [rt-users] Re: Error on startup – new install

Ok… I had a few missing dependencies before (make testdeps finds more than the command listed in the howto for modperl2)… However, now I am totally stumped, anyone have any idea what I can do to get this one resolved?

John :slight_smile:

Starting httpd: [Tue Jan 25 07:58:20 2005] [error] Can’t locate /apps/rt3/bin/webmux.pl in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 4) line 1.\n
[Tue Jan 25 07:58:20 2005] [error] Can’t load Perl file: /apps/rt3/bin/webmux.pl for server rt.pocketinet.com:0, exiting…
[FAILED]
[root@rt mail]#

Von: brian mccabe [mailto:thealbs@yahoo.co.uk]
Gesendet: Tuesday, January 25, 2005 5:09 AM
An: rt-users@lists.bestpractical.com
Betreff: [rt-users] Re: Error on startup – new install

This may be related to the default SE-Linux settings
on FC3 installation? I had to set set it to “disabled”
(not the default) to get Apache to startup initially
after the RT install.

Message: 3
Date: Mon, 24 Jan 2005 18:36:58 -0800
From: “John van Oppen” john@vanoppen.com
Subject: [rt-users] Error on startup – new install
To: rt-users@lists.bestpractical.com
Message-ID:

A431146554A0EA4A8C8842D94311BA6DAF99@server-ww.home.vanoppen.com

Content-Type: text/plain; charset=“us-ascii”

Does anyone have an idea about this issue?

This is a new install on a fedora core 3 box,
utilizing the pre-build
apache 2x and modperl… All CPAN modules are
installed (I utilized
the fedora core 2 howto on the wiki).

I would love to figure out why this is not
working… I was originally
planning on upgrading our RT box and had this
problem when going from a
version a few back (3.0.11) to the current rev and
thought I might as
well start over, and add a new HD to our RT box.
(I have the SQL
running on a separate machine).

ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston, San Francisco, Austin, Sydney) Contact training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

I think you use Apache2+MP2, check next:

  1. your HTML::Mason should be 1.27 or greater
  2. you should have ‘PerlModule Apache2’ before ‘PerlRequire
    …/webmux.pl’ in your apache config.

Rodolfo de Moraes Reis wrote:

Hello There!!

I’m with the same problem here… I installed RT 3.4.0rc6 without problem (all dependencies its’s ok!) but when I started Apache this message error appears in error.log:

[Tue Jan 25 16:21:45 2005] [error] Can’t locate Apache/Constants.pm in @INC (@INC contains: /opt/rt3/local/lib /opt/rt3/lib /opt/perl/lib/site_perl/5.8.5/Apache2 /opt/perl/lib/5.8.5 /opt/perl/lib/site_perl/5.8.5 /opt/perl/lib/site_perl . /opt/apache/ /opt/apache/lib/perl) at /opt/perl/lib/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm line 13.\nBEGIN failed–compilation aborted at /opt/perl/lib/site_perl/5.8.5/HTML/Mason/ApacheHandler.pm line 13.\nCompilation failed in require at /opt/rt3/lib/RT/Interface/Web/Handler.pm line 134.\nCompilation failed in require at (eval 2) line 1.\n

I wrote this lines in httpd.conf:

<VirtualHost :5000>
ServerName vento:5000
ServerAdmin email
DocumentRoot "/opt/rt3/share/html"
AddDefaultCharset UTF-8
PerlOptions +Parent
PerlModule Apache::compat
PerlModule Apache::DBI
PerlRequire "/opt/rt3/bin/webmux.pl"
ErrorLog logs/5000/error.log
CustomLog logs/5000/access.log common
RedirectMatch (.
)/$ http://vento:5000$1/index.html

SetHandler perl-script
PerlHandler RT::Mason

What’s happening???

Thank’s for regards!!!
Rodolfo Reis
Brazil.

-----Mensagem original-----
De: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com]Em nome de John van
Oppen
Enviada em: ter�a-feira, 25 de janeiro de 2005 13:18
Para: rt-users@lists.bestpractical.com
Assunto: AW: [rt-users] Re: Error on startup – new install

This is the Apache config for the site I mentioned in the last email:

<VirtualHost 64.185.104.25>
ServerName rt.pocketinet.com
DocumentRoot /apps/rt3/share/html
AddDefaultCharset UTF-8

these four lines apply to Apache2+mod_perl2 only: {{{

PerlSetVar MasonArgsMethod CGI
PerlModule Apache2 Apache::compat
RewriteEngine On
RewriteRule ^(.*)/$ $1/index.html

}}}

PerlModule Apache::DBI
PerlRequire /apps/rt3/bin/webmux.pl

SetHandler perl-script PerlHandler RT::Mason

-----Urspr�ngliche Nachricht-----
Von: John van Oppen
Gesendet: Tuesday, January 25, 2005 7:01 AM
An: rt-users@lists.bestpractical.com
Betreff: RE: [rt-users] Re: Error on startup – new install

Ok… I had a few missing dependencies before (make testdeps finds more than the command listed in the howto for modperl2)… However, now I am totally stumped, anyone have any idea what I can do to get this one resolved?

John :slight_smile:

Starting httpd: [Tue Jan 25 07:58:20 2005] [error] Can’t locate /apps/rt3/bin/webmux.pl in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-lin
ux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 4) line 1.\n