Requesting to download file

hi,

After upgrading from RT 3.8.6 to 3.8.7
Everything works fine.

I upgrade CentOS using Yum and upgrade form 5.3 to 5.4
When starting Apache, it complains of old version of File::Temp and upgrade it to 0.22.

However, Apache starting fine, but when I browse to rt website, it popping up a download dialog box.

Any Ideas ???

Thanks
Shiv

Windows Live: Keep your friends up to date with what you do online.
http://www.microsoft.com/middleeast/windows/windowslive/see-it-in-action/social-network-basics.aspx?ocid=PID23461::T:WLMTAGL:ON:WL:en-xm:SI_SB_1:092010

hi,

After upgrading from RT 3.8.6 to 3.8.7
Everything works fine.

I upgrade CentOS using Yum and upgrade form 5.3 to 5.4
When starting Apache, it complains of old version of File::Temp and upgrade
it to 0.22.

However, Apache starting fine, but when I browse to rt website, it popping
up a download dialog box.

Any Ideas ???

Have you performed the upgrade of File::Temp?

Given that you’ve done an upgrade of CentOS it’s likely many things
have changed. Compare the Apache configuration to the one in your
backup from before the upgrade and see what settings have been
changed.

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

The old version of File:Temp was 0.16, I download and install 0.22

For apache, apache was upgrade during the yum to version 2.2.3-31
However the rpm will not change the config file.

I am not seeing any errors in the logs, that is what making it more difficult to trouble shoot.
Is there to turn on a debug mode in RT.

Shiv

Date: Sun, 20 Dec 2009 10:37:13 +0000
From: rob.macgregor@gmail.com
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] requesting to download file

hi,

After upgrading from RT 3.8.6 to 3.8.7
Everything works fine.

I upgrade CentOS using Yum and upgrade form 5.3 to 5.4
When starting Apache, it complains of old version of File::Temp and upgrade
it to 0.22.

However, Apache starting fine, but when I browse to rt website, it popping
up a download dialog box.

Any Ideas ???

Have you performed the upgrade of File::Temp?

Given that you’ve done an upgrade of CentOS it’s likely many things
have changed. Compare the Apache configuration to the one in your
backup from before the upgrade and see what settings have been
changed.


Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Windows Live Hotmail: Your friends can get your Facebook updates, right from Hotmail®.
http://www.microsoft.com/middleeast/windows/windowslive/see-it-in-action/social-network-basics.aspx?ocid=PID23461::T:WLMTAGL:ON:WL:en-xm:SI_SB_4:092009

Please don’t top post.On Sun, Dec 20, 2009 at 10:44, Shiv . shivase@live.com wrote:

The old version of File:Temp was 0.16, I download and install 0.22

For apache, apache was upgrade during the yum to version 2.2.3-31
However the rpm will not change the config file.

I am not seeing any errors in the logs, that is what making it more
difficult to trouble shoot.
Is there to turn on a debug mode in RT.

It isn’t an RT problem - it’s an Apache configuration problem. If
you’re being prompted to download a file (.php) then it suggests that
your configuration of Apache isn’t right.

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

Date: Sun, 20 Dec 2009 10:48:01 +0000
From: rob.macgregor@gmail.com
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] requesting to download file

Please don’t top post.

The old version of File:Temp was 0.16, I download and install 0.22

For apache, apache was upgrade during the yum to version 2.2.3-31
However the rpm will not change the config file.

I am not seeing any errors in the logs, that is what making it more
difficult to trouble shoot.
Is there to turn on a debug mode in RT.

It isn’t an RT problem - it’s an Apache configuration problem. If
you’re being prompted to download a file (.php) then it suggests that
your configuration of Apache isn’t right.


Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

apache config:

<VirtualHost 190.80.34.10:80>
ServerName rt.guyana.net.gy
ServerAdmin admin@guyana.net.gy

    DocumentRoot /opt/rt3/share/html
    AddDefaultCharset UTF-8
    PerlRequire /opt/rt3/bin/webmux.pl

    <Directory /opt/rt3/share/html>
            Order allow,deny
            Allow from all
            SetHandler perl-script
            PerlResponseHandler RT::Mason
    </Directory> </VirtualHost>


snip of Directory
ls -al /opt/rt3/share/html
total 92
drwxr-xr-x 9 root bin 4096 Dec 20 03:39 Admin

Windows Live: Keep your friends up to date with what you do online.
http://www.microsoft.com/middleeast/windows/windowslive/see-it-in-action/social-network-basics.aspx?ocid=PID23461::T:WLMTAGL:ON:WL:en-xm:SI_SB_1:092010

apache config:

<VirtualHost 190.80.34.10:80>
ServerName rt.guyana.net.gy
ServerAdmin admin@guyana.net.gy

    DocumentRoot /opt/rt3/share/html
    AddDefaultCharset UTF-8
    PerlRequire /opt/rt3/bin/webmux.pl

    <Directory /opt/rt3/share/html>
            Order allow,deny
            Allow from all
            SetHandler perl-script
            PerlResponseHandler RT::Mason
    </Directory> </VirtualHost>

And what about the PHP support?

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

thanks
get it fixed …

http://www.billpitz.com/howto/rt-unix-directory.html

was looking at the wrong stuff …
once you mentioned its not RT … start to look at Apache

Shiv

Date: Sun, 20 Dec 2009 10:48:01 +0000
From: rob.macgregor@gmail.com
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] requesting to download file

Please don’t top post.

The old version of File:Temp was 0.16, I download and install 0.22

For apache, apache was upgrade during the yum to version 2.2.3-31
However the rpm will not change the config file.

I am not seeing any errors in the logs, that is what making it more
difficult to trouble shoot.
Is there to turn on a debug mode in RT.

It isn’t an RT problem - it’s an Apache configuration problem. If
you’re being prompted to download a file (.php) then it suggests that
your configuration of Apache isn’t right.


Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Windows Live: Make it easier for your friends to see what you’re up to on Facebook.
http://www.microsoft.com/middleeast/windows/windowslive/see-it-in-action/social-network-basics.aspx?ocid=PID23461::T:WLMTAGL:ON:WL:en-xm:SI_SB_2:092009