Request for Approvals queue help

Hi,

I am having problems setting up Approvals. I have read the manual
referring to this and all of the applicable newsgroup postings and have
not been able to figure out why it is not working.

We are set up as follows:

RT 3.0.8
Perl 5.8.0 (please, I hope this is problem is not related to this?)
RHEL AS 3.0
Apache 2.048
fastcgi
MySQL 4.0.18

I created a queue (called testing_queue)

  • I added a “approval scrip” local to this queue as indicated in the doc:
    On Create
    CreateTickets
    TransactionCreate
    Template “ticket approval” (a local template to the queue testing_queue)

My template “ticket approval” looks like this:
===Create-Ticket
Depended-On-By:TOP
Queue:Approvals
Type:Approval
Content: Someone has created a ticket, you should review and approve,so
they can finish their work.
ENDOFCONTENT

Absolutely nothing happens. I checked the log files and there are no
errors that seem to pertain to this - but what I did notice is that the
"approval scrip" never runs. It is scrip #16 - I can see that all of the
other global scrips (on create, autoreply…etc.) have run and that I
receive all of the subsequent emails…

Any pointers to point me in a new direction to figure this out?

TIA!
Michelle

Michelle L. Murillo
Data Manager
LTER Network Office
UNM Biology Department Email: mmurillo@lternet.edu
MSC03 2020 WWW: http://www.lternet.edu
1 University of New Mexico Phone: (505) 277-2578
Albuquerque, NM 87131-0001 FAX: (505) 277-2541
"It isn’t enough to talk about peace. One must believe in it. And it
isn’t enough to believe in it. One must work at it."
Eleanor Roosevelt

Hi,

I am having problems setting up Approvals. I have read the manual
referring to this and all of the applicable newsgroup postings and have
not been able to figure out why it is not working.

We are set up as follows:

RT 3.0.8
Perl 5.8.0 (please, I hope this is problem is not related to this?)
RHEL AS 3.0
Apache 2.048
fastcgi
MySQL 4.0.18

http://wiki.bestpractical.com/index.cgi?FAQ
FAQ
When you want to ask a question
< snip >

  • If you are not running the most recent stable version of
    RT/RTFM/RTIR then upgrade before asking your question.

Andy Harrison

Michelle L. Murillo wrote:

Hi,

I am having problems setting up Approvals. I have read the manual
referring to this and all of the applicable newsgroup postings and have
not been able to figure out why it is not working.
Start from upgrade.
And then http://wiki.bestpractical.com/?Debug