Regarding Apache server failure

Dear All,

I’m trying to configure RT to communic http:ate with my LDAP, for which I
followed this link : https://metacpan.org/pod/RT::Authen::ExternalAuth .
After making the required changes, when I restarted my apache server it is
failing with following error :

root@devrt:/rt/etc# /etc/init.d/apache2 start

  • Starting web server apache2
    Segmentation fault (core dumped)
    Action ‘start’ failed.
    The Apache error log may have more information.
    …fail!

There is no important messages in log files:

root@devrt:/rt/etc# cat /var/log/apache2/error.log
[Tue Oct 06 15:13:41 2015] [info] Init: Seeding PRNG with 648 bytes of
entropy
[Tue Oct 06 15:13:41 2015] [info] Loading certificate & private key of
SSL-aware server
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_pphrase.c(470): unencrypted
RSA private key - pass phrase not required
[Tue Oct 06 15:13:41 2015] [info] Init: Initializing (virtual) servers for
SSL
[Tue Oct 06 15:13:41 2015] [info] Configuring server for SSL protocol
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(367): Creating new SSL
context (protocols: TLSv1, TLSv1.1, TLSv1.2)
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(541): Configuring
client authentication
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(1218): CA certificate:
/C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust External
CA Root
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(1218): CA certificate:
/C=US/O=Internet2/OU=InCommon/CN=InCommon Server CA
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(608): Configuring
permitted SSL ciphers [!aNULL:!eNULL:!EXP:HIGH:MEDIUM:!ADH:!MD5]
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(316): Configuring TLS
extension handling
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(739): Configuring RSA
server certificate
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(785): Configuring RSA
server private key
[Tue Oct 06 15:13:41 2015] [info] mod_ssl/2.2.22 compiled against Server:
Apache/2.2.22, Library: OpenSSL/1.0.1

I’ve found a thread which was about similar issue,
http://lists.bestpractical.com/pipermail/rt-users/2010-June/065038.html ,
but there is no replies to that.

Any help or pointers to this issue will be appreciated.

Thanks,
Bharath.

Dear All,

I’m trying to configure RT to communicate with my LDAP, for which I followed
this link : https://metacpan.org/pod/RT::Authen::ExternalAuth . After making
the required changes, when I restarted my apache server it is failing with
following error :

root@devrt:/rt/etc# /etc/init.d/apache2 start

  • Starting web server apache2
    Segmentation fault (core dumped)
    Action ‘start’ failed.
    The Apache error log may have more information.
    …fail!

There is no important messages in log files:

root@devrt:/rt/etc# cat /var/log/apache2/error.log
[Tue Oct 06 15:13:41 2015] [info] Init: Seeding PRNG with 648 bytes of
entropy
[Tue Oct 06 15:13:41 2015] [info] Loading certificate & private key of
SSL-aware server
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_pphrase.c(470): unencrypted
RSA private key - pass phrase not required
[Tue Oct 06 15:13:41 2015] [info] Init: Initializing (virtual) servers for
SSL
[Tue Oct 06 15:13:41 2015] [info] Configuring server for SSL protocol
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(367): Creating new SSL
context (protocols: TLSv1, TLSv1.1, TLSv1.2)
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(541): Configuring
client authentication
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(1218): CA certificate:
/C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust External CA
Root
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(1218): CA certificate:
/C=US/O=Internet2/OU=InCommon/CN=InCommon Server CA
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(608): Configuring
permitted SSL ciphers [!aNULL:!eNULL:!EXP:HIGH:MEDIUM:!ADH:!MD5]
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(316): Configuring TLS
extension handling
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(739): Configuring RSA
server certificate
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(785): Configuring RSA
server private key
[Tue Oct 06 15:13:41 2015] [info] mod_ssl/2.2.22 compiled against Server:
Apache/2.2.22, Library: OpenSSL/1.0.1

What distro are you using?

To see the most recently written to log files, try:

cd /var/log
ls -lrt

and

cd /var/log/apache2
ls -lrt

-m

Hi Matt,

Thanks for replying back, here are the details :

Distro :
root@devrt:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="12.04.3 LTS, Precise Pangolin"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu precise (12.04.3 LTS)"
VERSION_ID=“12.04”

cd /var/log
ls -lrt (I’m showing only latest)
-rw-r----- 1 syslog adm 124 Oct 8 09:58 kern.log
-rw-r----- 1 root adm 529 Oct 8 09:58 apport.log
-rw-r----- 1 syslog adm 3086 Oct 8 10:00 syslog
-rw-r----- 1 syslog adm 113879 Oct 8 10:00 auth.log

root@devrt:/var/log# cat kern.log
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14

root@devrt:/var/log# cat apport.log
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: called for pid 5529,
signal 11
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: executable:
/usr/lib/apache2/mpm-prefork/apache2 (command line “/usr/sbin/apache2 -k
start”)
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: is_closing_session(): no
DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: apport: report
/var/crash/_usr_lib_apache2_mpm-prefork_apache2.0.crash already exists and
unseen, doing nothing to avoid disk usage DoS

root@devrt:/var/log# cat syslog
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14
Oct 8 10:00:01 devrt CRON[5582]: (smmsp) CMD (test -x /etc/init.d/sendmail
&& /usr/share/sendmail/sendmail cron-msp)

cd /var/log/apache2
ls -lrt

last updated file under this directory is on oct 6th
rw-r–r-- 1 root root 0 Oct 6 15:33 error.log

Is there any way I can enable more debug messages through apache ?

Thanks,
Bharath.On Tue, Oct 6, 2015 at 4:16 PM, Matt Zagrabelny mzagrabe@d.umn.edu wrote:

On Tue, Oct 6, 2015 at 3:09 PM, bharath reddy vangoor.bharath@gmail.com wrote:

Dear All,

I’m trying to configure RT to communicate with my LDAP, for which I
followed
this link : https://metacpan.org/pod/RT::Authen::ExternalAuth . After
making
the required changes, when I restarted my apache server it is failing
with
following error :

root@devrt:/rt/etc# /etc/init.d/apache2 start

  • Starting web server apache2
    Segmentation fault (core dumped)
    Action ‘start’ failed.
    The Apache error log may have more information.
    …fail!

There is no important messages in log files:

root@devrt:/rt/etc# cat /var/log/apache2/error.log
[Tue Oct 06 15:13:41 2015] [info] Init: Seeding PRNG with 648 bytes of
entropy
[Tue Oct 06 15:13:41 2015] [info] Loading certificate & private key of
SSL-aware server
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_pphrase.c(470): unencrypted
RSA private key - pass phrase not required
[Tue Oct 06 15:13:41 2015] [info] Init: Initializing (virtual) servers
for
SSL
[Tue Oct 06 15:13:41 2015] [info] Configuring server for SSL protocol
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(367): Creating new
SSL
context (protocols: TLSv1, TLSv1.1, TLSv1.2)
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(541): Configuring
client authentication
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(1218): CA
certificate:
/C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust
External CA
Root
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(1218): CA
certificate:
/C=US/O=Internet2/OU=InCommon/CN=InCommon Server CA
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(608): Configuring
permitted SSL ciphers [!aNULL:!eNULL:!EXP:HIGH:MEDIUM:!ADH:!MD5]
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(316): Configuring
TLS
extension handling
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(739): Configuring
RSA
server certificate
[Tue Oct 06 15:13:41 2015] [debug] ssl_engine_init.c(785): Configuring
RSA
server private key
[Tue Oct 06 15:13:41 2015] [info] mod_ssl/2.2.22 compiled against Server:
Apache/2.2.22, Library: OpenSSL/1.0.1

What distro are you using?

To see the most recently written to log files, try:

cd /var/log
ls -lrt

and

cd /var/log/apache2
ls -lrt

-m

Hi Matt,

Thanks for replying back, here are the details :

Distro :
root@devrt:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="12.04.3 LTS, Precise Pangolin"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu precise (12.04.3 LTS)"
VERSION_ID=“12.04”

cd /var/log
ls -lrt (I’m showing only latest)
-rw-r----- 1 syslog adm 124 Oct 8 09:58 kern.log
-rw-r----- 1 root adm 529 Oct 8 09:58 apport.log
-rw-r----- 1 syslog adm 3086 Oct 8 10:00 syslog
-rw-r----- 1 syslog adm 113879 Oct 8 10:00 auth.log

root@devrt:/var/log# cat kern.log
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14

root@devrt:/var/log# cat apport.log
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: called for pid 5529,
signal 11
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: executable:
/usr/lib/apache2/mpm-prefork/apache2 (command line “/usr/sbin/apache2 -k
start”)
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: is_closing_session(): no
DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: apport: report
/var/crash/_usr_lib_apache2_mpm-prefork_apache2.0.crash already exists and
unseen, doing nothing to avoid disk usage DoS

root@devrt:/var/log# cat syslog
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14
Oct 8 10:00:01 devrt CRON[5582]: (smmsp) CMD (test -x /etc/init.d/sendmail
&& /usr/share/sendmail/sendmail cron-msp)

Apache is segfaulting. Perhaps you have some bad RAM or other hardware issues.

You could try to set up another system with the same configs as this one.

cd /var/log/apache2
ls -lrt

last updated file under this directory is on oct 6th
rw-r–r-- 1 root root 0 Oct 6 15:33 error.log

Is there any way I can enable more debug messages through apache ?

Not sure. Try google. :slight_smile:

-m

Matt,

I don’t think it is a problem with RAM or any hardware, because when I
revert my changes in RT_SiteConfig.pm (with out LDAPAuthentication) apache
starts with out any error.

Thanks,
Bharath.On Thu, Oct 8, 2015 at 10:54 AM, Matt Zagrabelny mzagrabe@d.umn.edu wrote:

On Thu, Oct 8, 2015 at 9:21 AM, bharath reddy vangoor.bharath@gmail.com wrote:

Hi Matt,

Thanks for replying back, here are the details :

Distro :
root@devrt:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="12.04.3 LTS, Precise Pangolin"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu precise (12.04.3 LTS)"
VERSION_ID=“12.04”

cd /var/log
ls -lrt (I’m showing only latest)
-rw-r----- 1 syslog adm 124 Oct 8 09:58 kern.log
-rw-r----- 1 root adm 529 Oct 8 09:58 apport.log
-rw-r----- 1 syslog adm 3086 Oct 8 10:00 syslog
-rw-r----- 1 syslog adm 113879 Oct 8 10:00 auth.log

root@devrt:/var/log# cat kern.log
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14

root@devrt:/var/log# cat apport.log
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: called for pid 5529,
signal 11
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: executable:
/usr/lib/apache2/mpm-prefork/apache2 (command line “/usr/sbin/apache2 -k
start”)
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: is_closing_session():
no
DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: apport: report
/var/crash/_usr_lib_apache2_mpm-prefork_apache2.0.crash already exists
and
unseen, doing nothing to avoid disk usage DoS

root@devrt:/var/log# cat syslog
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14
Oct 8 10:00:01 devrt CRON[5582]: (smmsp) CMD (test -x
/etc/init.d/sendmail
&& /usr/share/sendmail/sendmail cron-msp)

Apache is segfaulting. Perhaps you have some bad RAM or other hardware
issues.

You could try to set up another system with the same configs as this one.

cd /var/log/apache2
ls -lrt

last updated file under this directory is on oct 6th
rw-r–r-- 1 root root 0 Oct 6 15:33 error.log

Is there any way I can enable more debug messages through apache ?

Not sure. Try google. :slight_smile:

-m

Hi Bharath,

Were you able to get a solution to this? I just upgraded to Ubuntu 14.04
(from 11.04) and am experienced this same issue. Your post actually helped
me localize it to the external auth plugin.

I found that I was running and older version (0.20) of the plugin. When I
upgraded to version 0.25, the issue went away.

Thanks, and hope that helps you.

-MattOn Thu, Oct 8, 2015 at 11:48 AM, bharath reddy vangoor.bharath@gmail.com wrote:

Matt,

I don’t think it is a problem with RAM or any hardware, because when I
revert my changes in RT_SiteConfig.pm (with out LDAPAuthentication) apache
starts with out any error.

Thanks,
Bharath.

On Thu, Oct 8, 2015 at 10:54 AM, Matt Zagrabelny mzagrabe@d.umn.edu wrote:

On Thu, Oct 8, 2015 at 9:21 AM, bharath reddy vangoor.bharath@gmail.com wrote:

Hi Matt,

Thanks for replying back, here are the details :

Distro :
root@devrt:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="12.04.3 LTS, Precise Pangolin"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu precise (12.04.3 LTS)"
VERSION_ID=“12.04”

cd /var/log
ls -lrt (I’m showing only latest)
-rw-r----- 1 syslog adm 124 Oct 8 09:58 kern.log
-rw-r----- 1 root adm 529 Oct 8 09:58 apport.log
-rw-r----- 1 syslog adm 3086 Oct 8 10:00 syslog
-rw-r----- 1 syslog adm 113879 Oct 8 10:00 auth.log

root@devrt:/var/log# cat kern.log
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14

root@devrt:/var/log# cat apport.log
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: called for pid 5529,
signal 11
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: executable:
/usr/lib/apache2/mpm-prefork/apache2 (command line “/usr/sbin/apache2 -k
start”)
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015:
is_closing_session(): no
DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: apport: report
/var/crash/_usr_lib_apache2_mpm-prefork_apache2.0.crash already exists
and
unseen, doing nothing to avoid disk usage DoS

root@devrt:/var/log# cat syslog
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14
Oct 8 10:00:01 devrt CRON[5582]: (smmsp) CMD (test -x
/etc/init.d/sendmail
&& /usr/share/sendmail/sendmail cron-msp)

Apache is segfaulting. Perhaps you have some bad RAM or other hardware
issues.

You could try to set up another system with the same configs as this one.

cd /var/log/apache2
ls -lrt

last updated file under this directory is on oct 6th
rw-r–r-- 1 root root 0 Oct 6 15:33 error.log

Is there any way I can enable more debug messages through apache ?

Not sure. Try google. :slight_smile:

-m

Hi Matt,

Thanks for posting this, Yes I was able to get the solution. The issue in
my case was I missed one of the key plugin and Apache didn’t show me that
missing plugin in logs, later when I set the RT log then i was able to
found it.

Thanks,
Bharath.On Fri, Nov 13, 2015 at 3:38 PM, Matt Brennan brennanma@gmail.com wrote:

Hi Bharath,

Were you able to get a solution to this? I just upgraded to Ubuntu 14.04
(from 11.04) and am experienced this same issue. Your post actually helped
me localize it to the external auth plugin.

I found that I was running and older version (0.20) of the plugin. When
I upgraded to version 0.25, the issue went away.

Thanks, and hope that helps you.

-Matt

On Thu, Oct 8, 2015 at 11:48 AM, bharath reddy vangoor.bharath@gmail.com wrote:

Matt,

I don’t think it is a problem with RAM or any hardware, because when I
revert my changes in RT_SiteConfig.pm (with out LDAPAuthentication) apache
starts with out any error.

Thanks,
Bharath.

On Thu, Oct 8, 2015 at 10:54 AM, Matt Zagrabelny mzagrabe@d.umn.edu wrote:

On Thu, Oct 8, 2015 at 9:21 AM, bharath reddy vangoor.bharath@gmail.com wrote:

Hi Matt,

Thanks for replying back, here are the details :

Distro :
root@devrt:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="12.04.3 LTS, Precise Pangolin"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu precise (12.04.3 LTS)"
VERSION_ID=“12.04”

cd /var/log
ls -lrt (I’m showing only latest)
-rw-r----- 1 syslog adm 124 Oct 8 09:58 kern.log
-rw-r----- 1 root adm 529 Oct 8 09:58 apport.log
-rw-r----- 1 syslog adm 3086 Oct 8 10:00 syslog
-rw-r----- 1 syslog adm 113879 Oct 8 10:00 auth.log

root@devrt:/var/log# cat kern.log
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14

root@devrt:/var/log# cat apport.log
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: called for pid 5529,
signal 11
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: executable:
/usr/lib/apache2/mpm-prefork/apache2 (command line “/usr/sbin/apache2
-k
start”)
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015:
is_closing_session(): no
DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 5532) Thu Oct 8 09:58:11 2015: apport: report
/var/crash/_usr_lib_apache2_mpm-prefork_apache2.0.crash already exists
and
unseen, doing nothing to avoid disk usage DoS

root@devrt:/var/log# cat syslog
Oct 8 09:58:10 devrt kernel: [3001033.121438] /usr/sbin/apach[5529]:
segfault at b54d9f80 ip b54d9f80 sp bfc702dc error 14
Oct 8 10:00:01 devrt CRON[5582]: (smmsp) CMD (test -x
/etc/init.d/sendmail
&& /usr/share/sendmail/sendmail cron-msp)

Apache is segfaulting. Perhaps you have some bad RAM or other hardware
issues.

You could try to set up another system with the same configs as this one.

cd /var/log/apache2
ls -lrt

last updated file under this directory is on oct 6th
rw-r–r-- 1 root root 0 Oct 6 15:33 error.log

Is there any way I can enable more debug messages through apache ?

Not sure. Try google. :slight_smile:

-m