Redirection from HTTPS to HTTP

Hi all,

I’m using RT version 3.8.8-1 on a debian squeeze server.
I installed Apache 2.2.15-5 as webserver with RT’s apache2-modperl2.conf

This is the content of my virtual host file.

<VirtualHost *:443>
ServerAdmin webmaster@myserver.domain
ServerName myserver.domain
Include /etc/request-tracker3.8/apache2-modperl2.conf

I connect to RT by link https://myserver.domain/rt because I left /etc/request-tracker3.8/apache2-modperl2.conf unchanged.

The issue I face is that everytime I submit a form for changing a ticket’s status for example, I’m redirecting tohttp (http://myserver.domain/rt/… ) protocol so I cannot see the result of the operation.
I don’t know why.

Can you help me to fix this please ?
Thanks in advance.

Hello,

I searched deeply recently. It does not seem that RT (even the latest versions) is able to manage both protocols (HTTP and HTTPS)
simultaneously. I personally set up a reverse proxy server, as described here :

<http://www.gossamer-threads.com/lists/rt/users/72162?search_string=both http https;#72162>

Hope this can help

Robert GRASSO – System engineer

CEDRAT S.A.
15 Chemin de Malacher - Inovallée - 38246 MEYLAN cedex - FRANCE
Phone: +33 (0)4 76 90 50 45 - Fax: +33 (0)4 56 38 08 30
mailto:robert.grasso@cedrat.com - http://www.cedrat.com

<VirtualHost *:443>
ServerAdmin webmaster@myserver.domain
ServerName myserver.domain
Include /etc/request-tracker3.8/apache2-modperl2.conf

I connect to RT by link https://myserver.domain/rt because I left
/etc/request-tracker3.8/apache2-modperl2.conf unchanged.
The issue I face is that everytime I submit a form for changing a ticket’s status for example,
I’m redirecting to http (http://myserver.domain/rt/… ) protocol so I cannot see the
result of the operation.

You don’t talk about your RT configuration. Did you tell RT that it
should use port 443 or otherwise tell it that you’re running it under
https? Have a read through RT_Config.pm and look at the WebPort and
WebBaseURL options

-kevin