Re quest Tracker Doesn't work properly Web if Doesnt show all Elements

Hello Folks

I have some Problem with my RT Tracker installation

System: Ubununtu 10.04 LTS under VM

Request Tracker Version: 3.8.8 Tarball

Installation: Manual Readme.txt

I’ve configured Apache so far with these Settings for Virtualhost:

ip based virtual host

<VirtualHost 192.168.112.23>
ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /opt/rt3/var/log/apache2.error
TransferLog /opt/rt3/var/log/apache2.access

PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script
PerlResponseHandler RT::Mason

<Location /NoAuth/images>
SetHandler default

Is This Correct?

So far so good…

If i try to connect to my RT Site it comes this picture:

http://old.nabble.com/file/p30843030/rtpicture5.jpg

What am I doing wrong?

best regards rtjoe

View this message in context: http://old.nabble.com/Request-Tracker-Doesn't-work-properly--Web-if-Doesnt-show-all-Elements-tp30843030p30843030.html

Update: I tried to modify the settings with the apache2-modperl2.conf file
which is described


here

this is the modified file:

To use RT together with mod_perl2, available in the

libapache2-mod-perl2 package, include this file with:

Include /etc/request-tracker3.8/apache2-modperl2.conf

into your Apache configuration file, in a virtual host section.

You will need to enable the Apache modules: perl, actions, rewrite

The best place for this in the Debian Apache2 default situation is

near the end of the VirtualHost section in the file

/etc/apache2/sites-available/default.

You might want to enable this line

AddDefaultCharset UTF-8

PerlModule Apache2::RequestRec Apache2::compat
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
PerlSetVar MasonArgsMethod CGI

Normally a request for a directory will be rewritten to index.html

(or similar) by default if that file exists. For some reason this does

not happen with the handler being set to perl-script. We thus have to

do it ourselves using mod_rewrite.

RewriteEngine on

You might need to alter these two lines which refer to /rt to match

whatever base URL you are using for your rt3 site.

RewriteRule ^/rt$ /rt/
RewriteRule ^/rt/(.)$ /opt/rt3/share/html/$1
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(/opt/rt3/share/html/.
)/$ $1/index.html

We need this to prevent requests for images being sent through to

the RT::Mason handler.

<Directory /opt/rt3/share/html/NoAuth/images>
SetHandler default-handler

<Directory /opt/rt3/share/html/>
SetHandler perl-script
PerlHandler RT::Mason

Limit mail gateway access to localhost by default

<Location /rt/REST/1.0/NoAuth>
Order Allow,Deny
Allow from 127.0.0.1

But still the same Problem apperars…

best regards rtjoe

rtjoe wrote:

Hello Folks

I have some Problem with my RT Tracker installation

System: Ubununtu 10.04 LTS under VM

Request Tracker Version: 3.8.8 Tarball

Installation: Manual Readme.txt

I’ve configured Apache so far with these Settings for Virtualhost:

ip based virtual host

<VirtualHost 192.168.112.23>
ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /opt/rt3/var/log/apache2.error
TransferLog /opt/rt3/var/log/apache2.access

PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script
PerlResponseHandler RT::Mason

<Location /NoAuth/images>
SetHandler default

Is This Correct?

So far so good…

If i try to connect to my RT Site it comes this picture:

http://old.nabble.com/file/p30843030/rtpicture5.jpg

What am I doing wrong?

best regards rtjoe

View this message in context: http://old.nabble.com/Request-Tracker-Doesn't-work-properly--Web-if-Doesnt-show-all-Elements-tp30843030p30843971.html

Update 3:
I tried to integrate fastcgi with the following settings:

ip based virtual host

<VirtualHost 192.168.112.23>

ServerName rt.example.com

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /opt/rt3/var/log/apache2.error
TransferLog /opt/rt3/var/log/apache2.access

AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
<Directory “/opt/rt3”>
Options FollowSymLinks ExecCGI
AllowOverride None

and here is the apache error.log:

[Fri Feb 04 15:27:20 2011] [alert] (4)Interrupted system call: FastCGI:
read() from pipe failed (0)
[Fri Feb 04 15:27:20 2011] [alert] (4)Interrupted system call: FastCGI: the
PM is shutting down, Apache seems to have disappeared - bye
[Fri Feb 04 15:27:20 2011] [notice] FastCGI: process manager initialized
(pid 10999)
[Fri Feb 04 15:27:20 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11000)
[Fri Feb 04 15:27:20 2011] [notice] Apache/2.2.8 (Ubuntu) mod_fastcgi/2.4.6
mod_perl/2.0.3 Perl/v5.8.8 configured – resuming normal operations
[Fri Feb 04 15:27:21 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11057)
[Fri Feb 04 15:27:22 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11058)
[Fri Feb 04 15:27:23 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11060)
[Fri Feb 04 15:27:24 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11061)
[Fri Feb 04 15:27:52 2011] [notice] SIGUSR1 received. Doing graceful
restart
[Fri Feb 04 15:27:52 2011] [alert] (4)Interrupted system call: FastCGI:
read() from pipe failed (0)
[Fri Feb 04 15:27:52 2011] [alert] (4)Interrupted system call: FastCGI: the
PM is shutting down, Apache seems to have disappeared - bye
[Fri Feb 04 15:27:52 2011] [notice] FastCGI: process manager initialized
(pid 11100)
[Fri Feb 04 15:27:52 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11101)
[Fri Feb 04 15:27:52 2011] [notice] Apache/2.2.8 (Ubuntu) mod_fastcgi/2.4.6
mod_perl/2.0.3 Perl/v5.8.8 configured – resuming normal operations
[Fri Feb 04 15:27:53 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11158)
[Fri Feb 04 15:27:54 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11159)
[Fri Feb 04 15:27:55 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11161)
[Fri Feb 04 15:27:56 2011] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 11162)

But the behavior is still the same :sleep:

rtjoe wrote:

Hello Folks

I have some Problem with my RT Tracker installation

System: Ubununtu 10.04 LTS under VM

Request Tracker Version: 3.8.8 Tarball

Installation: Manual Readme.txt

I’ve configured Apache so far with these Settings for Virtualhost:

ip based virtual host

<VirtualHost 192.168.112.23>
ServerName rt.example.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /opt/rt3/var/log/apache2.error
TransferLog /opt/rt3/var/log/apache2.access

PerlRequire /opt/rt3/bin/webmux.pl

SetHandler perl-script
PerlResponseHandler RT::Mason

<Location /NoAuth/images>
SetHandler default

Is This Correct?

So far so good…

If i try to connect to my RT Site it comes this picture:

http://old.nabble.com/file/p30843030/rtpicture5.jpg

What am I doing wrong?

best regards rtjoe

View this message in context: http://old.nabble.com/Request-Tracker-Doesn't-work-properly--Web-if-Doesnt-show-all-Elements-tp30843030p30845086.html

Update 3:
I tried to integrate fastcgi with the following settings:

ip based virtual host

<VirtualHost 192.168.112.23>

ServerName rt.example.com

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /opt/rt3/var/log/apache2.error
TransferLog /opt/rt3/var/log/apache2.access

AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
<Directory “/opt/rt3”>
Options FollowSymLinks ExecCGI
AllowOverride None

Show us your RT_SiteConfig.pm.

If i try to connect to my RT Site it comes this picture:

http://old.nabble.com/file/p30843030/rtpicture5.jpg

You’re not getting the images or CSS. What are the CSS urls in the HTML
source? And the image url?

Thomas

Hello Thomas

RT_SiteConfig.pm:

Any configuration directives you include here will override

RT’s default configuration file, RT_Config.pm

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this comamnd:

perl -c /path/to/your/etc/RT_SiteConfig.pm

#Set( $rtname, ‘example.com’);
#Set(@Plugins,(qw(Extension::QuickDelete RT::FM)));
1;

#TIMEZONE . takes the timezone from linux installation.
my $zone = “UTC”;
$zone=’/bin/cat /etc/timezone’
if -f “/etc/timezone”;
chomp $zone;
Set($Timezone, $zone);

THE BASICS:

Set($rtname, ‘rtsdatabase’);
Set($Organization, ‘rt.example.com’);
Set($CorrespondAddress , ‘’);
Set($CommentAddress , ‘rt-comment@example.com’);

THE WEBSERVER:

Set($WebPath , “/”);
Set($WebBaseURL , “http://rt.example.com”);

THE DATABASE:

Set($DatabaseType, ‘mysql’);
Set($DatabaseHost, ‘localhost’);
Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘wibble’);
Set($DatabaseName, ‘rt3’);
Set($RTAddressRegexp ,
’^help(-comment)?@(help|admin).(example.org|ourother.domain.com)$’);

I think you mean this :

http://ipadresse/rt/index.html

Almost there!

http://www.bestpractical.com/images/unconfigured-rtlogo.jpg


You're almost there!

You haven't yet configured your webserver to run RT.

You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web
server to “run” the RT server which powers the web interface.

The next step is to edit your webserver’s configuration file to instruct it
to use
RT’s mod_perl, FastCGI or
SpeedyCGI handler.

If you need commercial support, please contact us at
sales@bestpractical.com.

greetings rtjoe

Thomas Sibley wrote:

Update 3:
I tried to integrate fastcgi with the following settings:

ip based virtual host

<VirtualHost 192.168.112.23>

ServerName rt.example.com

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /opt/rt3/var/log/apache2.error
TransferLog /opt/rt3/var/log/apache2.access

AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
<Directory “/opt/rt3”>
Options FollowSymLinks ExecCGI
AllowOverride None

Show us your RT_SiteConfig.pm.

If i try to connect to my RT Site it comes this picture:

http://old.nabble.com/file/p30843030/rtpicture5.jpg

You’re not getting the images or CSS. What are the CSS urls in the HTML
source? And the image url?

Thomas

View this message in context: http://old.nabble.com/Request-Tracker-Doesn't-work-properly--Web-if-Doesnt-show-all-Elements-tp30843030p30861283.html

is it the right file you’ve mentioned?

rtjoe wrote:

Hello Thomas

RT_SiteConfig.pm:

Any configuration directives you include here will override

RT’s default configuration file, RT_Config.pm

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this comamnd:

perl -c /path/to/your/etc/RT_SiteConfig.pm

#Set( $rtname, ‘example.com’);
#Set(@Plugins,(qw(Extension::QuickDelete RT::FM)));
1;

#TIMEZONE . takes the timezone from linux installation.
my $zone = “UTC”;
$zone=’/bin/cat /etc/timezone’
if -f “/etc/timezone”;
chomp $zone;
Set($Timezone, $zone);

THE BASICS:

Set($rtname, ‘rtsdatabase’);
Set($Organization, ‘rt.example.com’);
Set($CorrespondAddress , ‘’);
Set($CommentAddress , ‘rt-comment@example.com’);

THE WEBSERVER:

Set($WebPath , “/”);
Set($WebBaseURL , “http://rt.example.com”);

THE DATABASE:

Set($DatabaseType, ‘mysql’);
Set($DatabaseHost, ‘localhost’);
Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘wibble’);
Set($DatabaseName, ‘rt3’);
Set($RTAddressRegexp ,
’^help(-comment)?@(help|admin).(example.org|ourother.domain.com)$’);

I think you mean this :

http://ipadresse/rt/index.html

Almost there!

http://www.bestpractical.com/images/unconfigured-rtlogo.jpg


You're almost there!

You haven't yet configured your webserver to run RT.

You appear to have installed RT’s web interface correctly, but haven’t yet
configured your web
server to “run” the RT server which powers the web interface.

The next step is to edit your webserver’s configuration file to instruct
it to use
RT’s mod_perl, FastCGI or
SpeedyCGI handler.

If you need commercial support, please contact us at
sales@bestpractical.com.

greetings rtjoe

Thomas Sibley wrote:

Update 3:
I tried to integrate fastcgi with the following settings:

ip based virtual host

<VirtualHost 192.168.112.23>

ServerName rt.example.com

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

# optional apache logs for RT
ErrorLog /opt/rt3/var/log/apache2.error
TransferLog /opt/rt3/var/log/apache2.access

AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
<Directory “/opt/rt3”>
Options FollowSymLinks ExecCGI
AllowOverride None

Show us your RT_SiteConfig.pm.

If i try to connect to my RT Site it comes this picture:

http://old.nabble.com/file/p30843030/rtpicture5.jpg

You’re not getting the images or CSS. What are the CSS urls in the HTML
source? And the image url?

Thomas

View this message in context: http://old.nabble.com/Request-Tracker-Doesn't-work-properly--Web-if-Doesnt-show-all-Elements-tp30843030p30863672.html

THE WEBSERVER:

Set($WebPath , “/”);
Set($WebBaseURL , “http://rt.example.com”);

You should replace the two lines above with just:

Set($WebDomain, "rt.example.com");

Read perldoc etc/RT_Config.pm to find out why.

THE DATABASE:

Set($DatabaseType, ‘mysql’);
Set($DatabaseHost, ‘localhost’);
Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘wibble’);

You might want to change your db password now if that’s the actual
password above.

I think you mean this :

http://ipadresse/rt/index.html

That’s not the file I meant. I meant viewing the source from your
browser on the page in this screenshot:

If i try to connect to my RT Site it comes this picture:

http://old.nabble.com/file/p30843030/rtpicture5.jpg

You’re not getting the images or CSS. What are the CSS urls in the HTML
source? And the image url?

Thomas

But fix the config and restart Apache first.

Thomas

Thnx for help Thomas

But i’ve decided to make this in an alternative way with aliases … and
it works :slight_smile:

but thanks anyway

grettings rtjoe

View this message in context: http://old.nabble.com/Request-Tracker-Doesn't-work-properly--Web-if-Doesnt-show-all-Elements-tp30843030p30873323.html