Re quest Tracker 3.8.2 - Integration with Active Directory (Windows 2003)

I have installed, RT 3.8.2, on a RHEL5, and i have had problems to integrate
RT with Active Directory. I hope that someone had a solution to my problem,
there is my configuration.

Set( @Plugins, qw(RT::Authen::ExternalAuth) );
Set($rtname, ‘somemachine.domain.pt’);
Set($Organization, ‘My organization’);

Set($CorrespondAddress , ‘someemail@domain.pt’);
Set($CommentAddress , ‘rt-comment@localdomain.com’);

Set($Timezone , ‘US/Pacific’); # obviously choose what suits you

THE DATABASE:

Set($DatabaseType, ‘mysql’); # e.g. Pg or mysql

These are the settings we used above when creating the RT database,

you MUST set these to what you chose in the section above.

Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘password’);
Set($DatabaseName , ‘rtdb’);

THE WEBSERVER:

Set($WebPath , “”);
Set($WebBaseURL , “http://somemachine:80”);

1;

My RT-Authen-ExternalAuth, RT_SiteConfig.pm

Set($ExternalAuthPriority, [‘My_LDAP’]);
Set($ExternalInfoPriority, [‘My_LDAP’]);
Set($ExternalServiceUsesSSLorTLS, 0);
Set($AutoCreateNonExternalUsers, 1);
Set(ExternalAuthPriority,[‘My_LDAP’,‘My_MySQL’,‘My_Oracle’,‘SecondaryLDAP’,‘Other-DB’]);
Set($ExternalSettings, {
‘My_LDAP’ => { ## GENERIC SECTION
’type’
=> ‘ldap’,
‘auth’
=> 1,
‘info’
=> 1,
‘server’
=> ‘server.domain.pt’,
‘user’
=> ‘CN=Exchange
User,OU=INSTITUCIONAIS,OU=User_APP,OU=xpto,DC=domain,DC=pt’,
‘pass’
=> ‘xxxxxx’,
‘base’
=> ‘dc=domain,dc=pt’,
‘filter’
=> ‘(objectClass=Person)’,
‘d_filter’
=> ‘(userAccountControl:1.2.840.113556.1.4.803:=2)’,
‘tls’
=> 0,
‘ssl_version’
=> 3,
‘net_ldap_args’
=> [ version => 3 ],
#‘group’
=> ‘IEP-DSI’,
# What is the
attribute for the group object that determines membership?
#‘group_attr’
=> ‘GROUP_ATTR’,
‘attr_match_list’
=> [ ‘Name’,

‘EmailAddress’,

‘RealName’

#‘WorkPhone’,

#‘Address2’

],
# The mapping of RT
attributes on to LDAP attributes
’attr_map’
=> { ‘Name’ => ‘sAMAccountName’,

‘EmailAddress’ => ‘mail’,

‘RealName’ => ‘cn’

}
}
}
);

1;

when I try to logon, i have these error on the logs.
server “/opt/rt3/bin/mason_handler.fcgi” stderr: [Mon Feb 23 10:39:07 2009]
[debug]: Autohandler called ExternalAuth. Response: (0, ExternalAuthPriority
not defined, please check your configuration file.)
(/opt/rt3/local/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Auth:26),
referer: http://somemachine/
[Mon Feb 23 10:39:07 2009] [error] [client 10.2.200.155] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" stderr: [Mon Feb 23 10:39:07 2009]
[error]: FAILED LOGIN for login@domain.pt from 10.2.200.155
(/opt/rt3/share/html/autohandler:268), referer: http://somemachine/
View this message in context: http://www.nabble.com/Request-Tracker-3.8.2---Integration-with-Active-Directory-(Windows-2003)-tp22159677p22159677.html

Mtabanez wrote:

I have installed, RT 3.8.2, on a RHEL5, and i have had problems to integrate
RT with Active Directory. I hope that someone had a solution to my problem,
there is my configuration.

The example RT_SiteConfig.pm provided with ExternalAuth is not where you
define the settings, it is just an example of the settings. You need to
put them in your normal RT_SiteConfig.pm file.

Copy & Paste will do.

Read the README.
Kind Regards,

Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com