Question on rt and transports and sgid and what not

I am sort of lost here, it does not seem to work… I have
tried to install rt2 here, it just has a pipe in my
/etc/aliases, so it should work, I thought. I use Exim here,
FreeBSD…

–>
pipe to |/opt/rt2/bin/rt-mailgate --queue general --action correspond
generated by rt@carmel.net.tiscali.com
Child process of address_pipe transport returned 255 (could mean shell command ended by signal 127 (unrecognized signal number)) from command:
/opt/rt2/bin/rt-mailgate

The following text was generated during the delivery attempt:

------ pipe to |/opt/rt2/bin/rt-mailgate --queue general --action correspond
generated by rt@carmel.net.tiscali.com ------

Can’t do setuid
<–

So… what has to be setuid to what? Any ideas? Hints welcome.

Thanks,
Alexander

Alexander Koch alexander.koch@tiscali.com / ako4-ripe
Network Engineer, Tiscali S.p.A., International IP Network Operations
Phone +49 6103 916 480, Fax +49 6103 916 464, http://www.tiscali.com/
Robert-Bosch-Strasse 32, D-63303 Dreieich, Germany

Alexander Koch wrote:

Can’t do setuid

chmod u+s /usr/bin/suidperl

Just in case anyone else is trying to setup RT2 on a Slackware linux distro, I thought I’d share the little factoid that Slackware’s bundled perl package doesn’t do suidperl, even though the suidperl binary is included and, well, setuid. :slight_smile: If someone brighter than me knows if there’s a runtime option to enable this, please share!

In the meantime, removing the Slackware perl package and building a fresh install from source, and choosing “Kernel can’t do setuid scripts safely” and “Let perl emulate setuid scripts” from the configuration script seemed to do the trick for me.

As far as I can tell, this is the case for all semi-current Slackware versions (3.0 and up)… Hope this saves someone else some skull-beating.

-Steve.

Steve Nolan
Vancouver Island Regional Library
Systems Support Services
(250) 758-4697 x 217