Query builder losing the query

Hi,

I seem to recalled seeing this before, but I couldn’t find it in my
history. So I apologise if this has been over.

I am running RT 3.2.2

I notice, when you build a search, then click on a ticket, then go back
to the Query Builder, the query is gone.

Now, firstly I’m unclear if this is a problem, or if this is how rt3 is
meant to work (it doesn’t work like this is rt2). And

Secondly, if it is an issue, is there a fix floating around for it?

Cheers.

Regards

Matthew Watson

Netspace Online Systems

(03) 98110010

Hi,

I seem to recalled seeing this before, but I couldn’t find it in my
history. So I apologise if this has been over.

I am running RT 3.2.2

Try the 3.2.3 prerelease?

This is a followup on issues I was having with Query Builder losing the
query, After a lot of testing and playing around, turned out it wasn’t
just the query that was vanishing, but the entire session wasn’t being
relocated/saved correctly.

After a lot of playing around, it seems the sessions where getting
truncated when being retrieved from the database when using
Apache::Session::Oracle

In SearchBuilder/Handle/Oracle.pm

$self->dbh->{LongTruncOk}=1;
$self->dbh->{LongReadLen}= 8000;

Seems the session is getting larger than this, which of course gives
problems when the session is retrieved.

Also, Apache::Session::Oracle seems to want you to set this in its
arguments, even if it is already set on the database handle.

So, locally I’ve changed
SearchBuilder/Handle/Oracle.pm to

$self->dbh->{LongReadLen}= 10485760

And in ~rt/local/html/Elements/SetupSessionCookie

I have added

Commit => 0,
LongReadLen => 10485760

To the session setups.

Hope this helps anyone having these issues :slight_smile:

Regards,
Matt.

-----Original Message-----
From: Jesse Vincent [mailto:jesse@bestpractical.com]
Sent: Wednesday, January 05, 2005 11:56 AM
To: Matthew Watson
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Query builder losing the query

Hi,

I seem to recalled seeing this before, but I couldn’t find it in my
history. So I apologise if this has been over.

I am running RT 3.2.2

Try the 3.2.3 prerelease?

I notice, when you build a search, then click on a ticket, then go
back

to the Query Builder, the query is gone.

Now, firstly I’m unclear if this is a problem, or if this is how rt3
is

meant to work (it doesn’t work like this is rt2). And

Secondly, if it is an issue, is there a fix floating around for it?

Cheers.

Regards

Matthew Watson

Netspace Online Systems

(03) 98110010


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed. Please notify the sender
immediately by email if you have received this email by mistake and delete this email
from your system. Please note that any views or opinions presented in this email are solely
those of the author and do not necessarily represent those of the organisation.
Finally, the recipient should check this email and any attachments for the presence of
viruses. The organisation accepts no liability for any damage caused by any virus
transmitted by this email.

This is a followup on issues I was having with Query Builder losing the
query, After a lot of testing and playing around, turned out it wasn’t
just the query that was vanishing, but the entire session wasn’t being
relocated/saved correctly.

After a lot of playing around, it seems the sessions where getting
truncated when being retrieved from the database when using
Apache::Session::Oracle

In SearchBuilder/Handle/Oracle.pm

$self->dbh->{LongTruncOk}=1;
$self->dbh->{LongReadLen}= 8000;

Seems the session is getting larger than this, which of course gives
problems when the session is retrieved.

Also, Apache::Session::Oracle seems to want you to set this in its
arguments, even if it is already set on the database handle.

So, locally I’ve changed
SearchBuilder/Handle/Oracle.pm to

$self->dbh->{LongReadLen}= 10485760

So. I see code in RT::Handle that takes care of this. Can you verify
that this code isn’t being taken advantage of?

So, locally I’ve changed
SearchBuilder/Handle/Oracle.pm to

$self->dbh->{LongReadLen}= 10485760

So. I see code in RT::Handle that takes care of this. Can you verify
that this code isn’t being taken advantage of?

Arh. Right you are there.

And in ~rt/local/html/Elements/SetupSessionCookie

I have added

Commit => 0,
LongReadLen => 10485760

To the session setups.

But it doesn’t fix this problem. I’m sure most sessions don’t get
anywhere near this big (I’m throwing a lot of debugging into in there at
the moment, as I’ve got LogSQLStatements turned on

Regards,
Matt.

This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed. Please notify the sender
immediately by email if you have received this email by mistake and delete this email
from your system. Please note that any views or opinions presented in this email are solely
those of the author and do not necessarily represent those of the organisation.
Finally, the recipient should check this email and any attachments for the presence of
viruses. The organisation accepts no liability for any damage caused by any virus
transmitted by this email.

So, locally I’ve changed
SearchBuilder/Handle/Oracle.pm to

$self->dbh->{LongReadLen}= 10485760

So. I see code in RT::Handle that takes care of this. Can you verify
that this code isn’t being taken advantage of?

Arh. Right you are there.

And in ~rt/local/html/Elements/SetupSessionCookie

I have added

Commit => 0,
LongReadLen => 10485760

To the session setups.

But it doesn’t fix this problem. I’m sure most sessions don’t get
anywhere near this big (I’m throwing a lot of debugging into in there at
the moment, as I’ve got LogSQLStatements turned on

So. What if you change SetupSessionCookie, but not SB::Handle::Oracle?

But it doesn’t fix this problem. I’m sure most sessions don’t get
anywhere near this big (I’m throwing a lot of debugging into in
there at

the moment, as I’ve got LogSQLStatements turned on

So. What if you change SetupSessionCookie, but not SB::Handle::Oracle?

Well, now that we have established that SB::Hanlde::Oracle is doing the
right thing, as long as SetupSessionCookie is passing in the LongReadLen
argument when setting up the session it should be ok, even with out
doing it, its most likely a problem that very few people will hit, it
was only biting me due to having LogSQLStatements on and looking at a
queue with 1000+ open tickets (hence, lots of statements to log).

Regards,
Matt.

This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed. Please notify the sender
immediately by email if you have received this email by mistake and delete this email
from your system. Please note that any views or opinions presented in this email are solely
those of the author and do not necessarily represent those of the organisation.
Finally, the recipient should check this email and any attachments for the presence of
viruses. The organisation accepts no liability for any damage caused by any virus
transmitted by this email.