Problems with RT 4.4.3 on Ubuntu 14.04 server with apache; won't appear in browser


#1

Hey, I’m pretty unfamiliar with ubuntu (and Linux) and I have yet to really start playing around RT. A week ago, I followed a tutorial online and downloaded Request Tracker 4.4.3 onto my server with few problems. I was able to open it up on a web browser with no problems: everything worked. A little later, I was asked to place VestaCP, a control panel software, onto the server, and this required me to delete a few things to make room for it, including Request Tracker. I removed the nginx software that came with it and reconfigured the server to work with apache, like it had before. Apache opens up in a browser, no problem. The VestaCP control panel has worked perfectly fine ever since I downloaded it, but when I tried to re-download and set up Request Tracker, it wouldn’t appear in the browser. In fact, it said “Not Found The requested URL /rt/ was not found on this server.”. I’ve tried a few things, like changing RT to other ports or re-downloading it altogether, but I consistently get the same message. I don’t know exactly what you’ll need to know what’s wrong, but let me know. I’ll take whatever I can get at this point. Thanks!


#2

Have you configured Apache to point to where you’ve installed RT? Sounds like you might need to ensure that you have a ScriptAlias or similar pointing at where RT is on the server and have the right modules loaded into Apache. There’s loads of ways of configuring this, depending on how you want your server to work and what URLs RT will get. There’s some useful information on manually configuring Apache in the RT documentation.