Problems with RT 3.8.2 - Apache

Hello,

I completely started over with a fresh installation of RT using the latest version 3.8.2. Following the README file that is packed with the new installation, I’m stuck at the Apache configuration. I added the lines for Apache 2.x.x:

ServerName your.rt.server.hostname



DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8



# optional apache logs for RT

# ErrorLog /opt/rt3/var/log/apache2.error

# TransferLog /opt/rt3/var/log/apache2.access



PerlRequire "/opt/rt3/bin/webmux.pl"



<Location /NoAuth/images>

    SetHandler default

</Location>

<Location />

    SetHandler perl-script

    PerlResponseHandler RT::Mason

</Location>

Here is my rt3.conf file settings:

Alias /rt3 “/usr/share/rt3/html”

PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

<VirtualHost 172.16.5.163>
ServerName clehbrtsrv01.broadvox.local

    DocumentRoot /opt/rt3/share/html
    AddDefaultCharset UTF-8

    # optional apache logs for RT
    # ErrorLog /opt/rt3/var/log/apache.error
    # TransferLog /opt/rt3/var/log/apache.error

    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl
    <Location /NoAuth/images>
            SetHandler default
    </Location>
    <Location />
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>

When I restart Apache and MySql, I tried accessing the page http://clehbrtsrv01.broadvox.local/ (no /rt3). I get an “Internal Server Error” due to a misconfiguration. Here is my error_log file for Apache:

[Mon May 18 15:12:12 2009] [notice] caught SIGTERM, shutting down
[Mon May 18 15:16:16 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon May 18 15:16:19 2009] [notice] Digest: generating secret for digest authentication …
[Mon May 18 15:16:19 2009] [notice] Digest: done
[Mon May 18 15:16:21 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:11 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:14 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:18:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n

Eric Chatham
MIS Department
Phone: (216) 373-4683
Fax: (216) 373-4669
echatham@broadvox.net
[cid:image001.gif@01C9D7CC.691A95E0]

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

doublecheck the configuration of your database to make sure the rt_user
and rt_pass actually exist and permit login…looks like thats where its
failing

make sure mysqld is running too.On Mon, 18 May 2009, Eric Chatham wrote:

Date: Mon, 18 May 2009 15:27:31 -0400
From: Eric Chatham echatham@broadvox.net
To: RT Users RT-Users@lists.bestpractical.com
Subject: [rt-users] Problems with RT 3.8.2 - Apache

Hello,

I completely started over with a fresh installation of RT using the latest version 3.8.2. Following the README file that is packed with the new installation, I’m stuck at the Apache configuration. I added the lines for Apache 2.x.x:

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

optional apache logs for RT

ErrorLog /opt/rt3/var/log/apache2.error

TransferLog /opt/rt3/var/log/apache2.access

PerlRequire “/opt/rt3/bin/webmux.pl”

<Location /NoAuth/images>

   SetHandler default
   SetHandler perl-script

   PerlResponseHandler RT::Mason

Here is my rt3.conf file settings:

Alias /rt3 “/usr/share/rt3/html”

PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

<VirtualHost 172.16.5.163>
ServerName clehbrtsrv01.broadvox.local

   DocumentRoot /opt/rt3/share/html
   AddDefaultCharset UTF-8

   # optional apache logs for RT
   # ErrorLog /opt/rt3/var/log/apache.error
   # TransferLog /opt/rt3/var/log/apache.error

   PerlModule Apache::DBI
   PerlRequire /opt/rt3/bin/webmux.pl
   <Location /NoAuth/images>
           SetHandler default
   </Location>
   <Location />
           SetHandler perl-script
           PerlHandler RT::Mason
   </Location>

When I restart Apache and MySql, I tried accessing the page http://clehbrtsrv01.broadvox.local/ (no /rt3). I get an “Internal Server Error” due to a misconfiguration. Here is my error_log file for Apache:

[Mon May 18 15:12:12 2009] [notice] caught SIGTERM, shutting down
[Mon May 18 15:16:16 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon May 18 15:16:19 2009] [notice] Digest: generating secret for digest authentication …
[Mon May 18 15:16:19 2009] [notice] Digest: done
[Mon May 18 15:16:21 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:11 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:14 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:18:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n

Eric Chatham
MIS Department
Phone: (216) 373-4683
Fax: (216) 373-4669
echatham@broadvox.net
[cid:image001.gif@01C9D7CC.691A95E0]


CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

On Monday, May 18, 2009 15:55, Nimbius Wrote:

doublecheck the configuration of your database to make sure the rt_user
and rt_pass actually exist and permit login…looks like thats where its
failing

rt_user is the user, and rt_pass is the password. I’m still having a problem. :confused:

mysql> use mysql
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> UPDATE user SET Password=PASSWORD(‘rt_pass’) WHERE user=‘rt_user’;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0

mysql> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.01 sec)

mysql> quit
Bye

make sure mysqld is running too.

chkconfig mysqld onOn Mon, 18 May 2009, Eric Chatham wrote:

Date: Mon, 18 May 2009 15:27:31 -0400
From: Eric Chatham echatham@broadvox.net
To: RT Users RT-Users@lists.bestpractical.com
Subject: [rt-users] Problems with RT 3.8.2 - Apache

Hello,

I completely started over with a fresh installation of RT using the latest version 3.8.2. Following the README file that is packed with the new installation, I’m stuck at the Apache configuration. I added the lines for Apache 2.x.x:

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

optional apache logs for RT

ErrorLog /opt/rt3/var/log/apache2.error

TransferLog /opt/rt3/var/log/apache2.access

PerlRequire “/opt/rt3/bin/webmux.pl”

<Location /NoAuth/images>

   SetHandler default
   SetHandler perl-script

   PerlResponseHandler RT::Mason

Here is my rt3.conf file settings:

Alias /rt3 “/usr/share/rt3/html”

PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

<VirtualHost 172.16.5.163>
ServerName clehbrtsrv01.broadvox.local

   DocumentRoot /opt/rt3/share/html
   AddDefaultCharset UTF-8

   # optional apache logs for RT
   # ErrorLog /opt/rt3/var/log/apache.error
   # TransferLog /opt/rt3/var/log/apache.error

   PerlModule Apache::DBI
   PerlRequire /opt/rt3/bin/webmux.pl
   <Location /NoAuth/images>
           SetHandler default
   </Location>
   <Location />
           SetHandler perl-script
           PerlHandler RT::Mason
   </Location>

When I restart Apache and MySql, I tried accessing the page http://clehbrtsrv01.broadvox.local/ (no /rt3). I get an “Internal Server Error” due to a misconfiguration. Here is my error_log file for Apache:

[Mon May 18 15:12:12 2009] [notice] caught SIGTERM, shutting down
[Mon May 18 15:16:16 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon May 18 15:16:19 2009] [notice] Digest: generating secret for digest authentication …
[Mon May 18 15:16:19 2009] [notice] Digest: done
[Mon May 18 15:16:21 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:11 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:14 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:18:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n

Eric Chatham
MIS Department
Phone: (216) 373-4683
Fax: (216) 373-4669
echatham@broadvox.net
[cid:image001.gif@01C9D7CC.691A95E0]


CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

Hello!

make:

  1. grep DatabaseUser /opt/rt3/etc/RT_SiteConfig.pm
  2. grep DatabasePassword /opt/rt3/etc/RT_SiteConfig.pm
  3. grep DatabaseRTHost /opt/rt3/etc/RT_SiteConfig.pm

and then

mysql -u result_from_2 -presult_from_2 -h result_from3

I’m quite sure that this is your problem.
The apache config looked okay (I’m not sure with
the redirect)

regards!

svenOn Mo, 2009-05-18 at 16:32 -0400, Eric Chatham wrote:

On Monday, May 18, 2009 15:55, Nimbius Wrote:

doublecheck the configuration of your database to make sure the rt_user
and rt_pass actually exist and permit login…looks like thats where its
failing

rt_user is the user, and rt_pass is the password. I’m still having a problem. :confused:

mysql> use mysql
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> UPDATE user SET Password=PASSWORD(‘rt_pass’) WHERE user=‘rt_user’;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0

mysql> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.01 sec)

mysql> quit
Bye

make sure mysqld is running too.

chkconfig mysqld on

On Mon, 18 May 2009, Eric Chatham wrote:

Date: Mon, 18 May 2009 15:27:31 -0400
From: Eric Chatham echatham@broadvox.net
To: RT Users RT-Users@lists.bestpractical.com
Subject: [rt-users] Problems with RT 3.8.2 - Apache

Hello,

I completely started over with a fresh installation of RT using the latest version 3.8.2. Following the README file that is packed with the new installation, I’m stuck at the Apache configuration. I added the lines for Apache 2.x.x:

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

optional apache logs for RT

ErrorLog /opt/rt3/var/log/apache2.error

TransferLog /opt/rt3/var/log/apache2.access

PerlRequire “/opt/rt3/bin/webmux.pl”

<Location /NoAuth/images>

   SetHandler default
   SetHandler perl-script

   PerlResponseHandler RT::Mason

Here is my rt3.conf file settings:

Alias /rt3 “/usr/share/rt3/html”

PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

<VirtualHost 172.16.5.163>
ServerName clehbrtsrv01.broadvox.local

   DocumentRoot /opt/rt3/share/html
   AddDefaultCharset UTF-8

   # optional apache logs for RT
   # ErrorLog /opt/rt3/var/log/apache.error
   # TransferLog /opt/rt3/var/log/apache.error

   PerlModule Apache::DBI
   PerlRequire /opt/rt3/bin/webmux.pl
   <Location /NoAuth/images>
           SetHandler default
   </Location>
   <Location />
           SetHandler perl-script
           PerlHandler RT::Mason
   </Location>

When I restart Apache and MySql, I tried accessing the page http://clehbrtsrv01.broadvox.local/ (no /rt3). I get an “Internal Server Error” due to a misconfiguration. Here is my error_log file for Apache:

[Mon May 18 15:12:12 2009] [notice] caught SIGTERM, shutting down
[Mon May 18 15:16:16 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon May 18 15:16:19 2009] [notice] Digest: generating secret for digest authentication …
[Mon May 18 15:16:19 2009] [notice] Digest: done
[Mon May 18 15:16:21 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:11 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:14 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:18:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n

Eric Chatham
MIS Department
Phone: (216) 373-4683
Fax: (216) 373-4669
echatham@broadvox.net
[cid:image001.gif@01C9D7CC.691A95E0]


CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Eric Chatham wrote:

On Monday, May 18, 2009 15:55, Nimbius Wrote:

doublecheck the configuration of your database to make sure the rt_user
and rt_pass actually exist and permit login…looks like thats where its
failing

rt_user is the user, and rt_pass is the password. I’m still having a problem. :confused:

mysql> use mysql
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> UPDATE user SET Password=PASSWORD(‘rt_pass’) WHERE user=‘rt_user’;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0

mysql> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.01 sec)

mysql> quit
Bye

Have you granted access to this user access on the database?

mysql> GRANT ALL ON rt_db.* TO rt_user@localhost;

mysql> FLUSH PRIVILEGES;

Atenciosamente,

Arthur Furlan
arthur@mpsinf.com.br

Arthur Furlan wrote:

Eric Chatham wrote:

On Monday, May 18, 2009 15:55, Nimbius Wrote:

doublecheck the configuration of your database to make sure the rt_user
and rt_pass actually exist and permit login…looks like thats where its
failing
rt_user is the user, and rt_pass is the password. I’m still having a problem. :confused:

mysql> use mysql
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> UPDATE user SET Password=PASSWORD(‘rt_pass’) WHERE user=‘rt_user’;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0

mysql> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.01 sec)

mysql> quit
Bye

Have you granted access to this user access on the database?

mysql> GRANT ALL ON rt_db.* TO rt_user@localhost;

mysql> FLUSH PRIVILEGES;

Sidenote: GRANT automatically flushes privileges.

Regards
Racke

LinuXia Systems => http://www.linuxia.de/
Expert Interchange Consulting and System Administration
ICDEVGROUP => http://www.icdevgroup.org/
Interchange Development Team

On Tuesday, May 19, 2009 07:22, Sven Wrote:

make:

  1. grep DatabaseUser /opt/rt3/etc/RT_SiteConfig.pm
  2. grep DatabasePassword /opt/rt3/etc/RT_SiteConfig.pm
  3. grep DatabaseRTHost /opt/rt3/etc/RT_SiteConfig.pm

and then

mysql -u result_from_2 -presult_from_2 -h result_from3

I’m quite sure that this is your problem.
The apache config looked okay (I’m not sure with
the redirect)

Thank you all for your assistance. I tried everyone’s suggestions. I appreciate this. The problem is still persisting though. I made sure that rt_user was added to my RT_SiteConfig.pm file and I even “hashed out” the redirect in my Apache config (that Sven pointed out; I was thinking that may’ve been a problem). I granted all permissions to the rt3 database for rt_user. I’m using the default username/password in RT_Config.pm. I am no longer getting the DBI error in my error_log. Now, it appears to be something else.

APACHE ERROR_LOG:

[Tue May 19 11:55:55 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server clehbrtsrv01.broadvox.local:0, exiting…
[Tue May 19 11:57:53 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue May 19 11:57:55 2009] [notice] Digest: generating secret for digest authentication …
[Tue May 19 11:57:55 2009] [notice] Digest: done
[Tue May 19 11:57:56 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
[Tue May 19 11:58:16 2009] [error] [client 172.16.3.38] Sys::Syslog version 0.16 required–this is only version 0.13 at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nBEGIN failed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nCompilation failed in require at /opt/rt3/bin/…/lib/RT.pm line 340.\n
[Tue May 19 11:58:22 2009] [error] [client 172.16.3.38] Sys::Syslog version 0.16 required–this is only version 0.13 at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nBEGIN failed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nCompilation failed in require at /opt/rt3/bin/…/lib/RT.pm line 340.\n
[Tue May 19 11:59:20 2009] [notice] caught SIGTERM, shutting down
[Tue May 19 11:59:23 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue May 19 11:59:26 2009] [notice] Digest: generating secret for digest authentication …
[Tue May 19 11:59:26 2009] [notice] Digest: done
[Tue May 19 11:59:26 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
[Tue May 19 11:59:28 2009] [error] [client 172.16.3.38] Sys::Syslog version 0.16 required–this is only version 0.13 at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nBEGIN failed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nCompilation failed in require at /opt/rt3/bin/…/lib/RT.pm line 340.\n
[Tue May 19 11:59:32 2009] [error] [client 172.16.3.38] Sys::Syslog version 0.16 required–this is only version 0.13 at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nBEGIN failed–compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Log/Dispatch/Syslog.pm line 13.\nCompilation failed in require at /opt/rt3/bin/…/lib/RT.pm line 340.\n

svenOn Mo, 2009-05-18 at 16:32 -0400, Eric Chatham wrote:

On Monday, May 18, 2009 15:55, Nimbius Wrote:

doublecheck the configuration of your database to make sure the rt_user
and rt_pass actually exist and permit login…looks like thats where its
failing

rt_user is the user, and rt_pass is the password. I’m still having a problem. :confused:

mysql> use mysql
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> UPDATE user SET Password=PASSWORD(‘rt_pass’) WHERE user=‘rt_user’;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0

mysql> FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.01 sec)

mysql> quit
Bye

make sure mysqld is running too.

chkconfig mysqld on

On Mon, 18 May 2009, Eric Chatham wrote:

Date: Mon, 18 May 2009 15:27:31 -0400
From: Eric Chatham echatham@broadvox.net
To: RT Users RT-Users@lists.bestpractical.com
Subject: [rt-users] Problems with RT 3.8.2 - Apache

Hello,

I completely started over with a fresh installation of RT using the latest version 3.8.2. Following the README file that is packed with the new installation, I’m stuck at the Apache configuration. I added the lines for Apache 2.x.x:

ServerName your.rt.server.hostname

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

optional apache logs for RT

ErrorLog /opt/rt3/var/log/apache2.error

TransferLog /opt/rt3/var/log/apache2.access

PerlRequire “/opt/rt3/bin/webmux.pl”

<Location /NoAuth/images>

   SetHandler default
   SetHandler perl-script

   PerlResponseHandler RT::Mason

Here is my rt3.conf file settings:

Alias /rt3 “/usr/share/rt3/html”

PerlRequire /usr/sbin/webmux.pl

<Directory “/usr/share/rt3/html”>
AllowOverride All
Options ExecCGI FollowSymLinks

RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

<VirtualHost 172.16.5.163>
ServerName clehbrtsrv01.broadvox.local

   DocumentRoot /opt/rt3/share/html
   AddDefaultCharset UTF-8

   # optional apache logs for RT
   # ErrorLog /opt/rt3/var/log/apache.error
   # TransferLog /opt/rt3/var/log/apache.error

   PerlModule Apache::DBI
   PerlRequire /opt/rt3/bin/webmux.pl
   <Location /NoAuth/images>
           SetHandler default
   </Location>
   <Location />
           SetHandler perl-script
           PerlHandler RT::Mason
   </Location>

When I restart Apache and MySql, I tried accessing the page http://clehbrtsrv01.broadvox.local/ (no /rt3). I get an “Internal Server Error” due to a misconfiguration. Here is my error_log file for Apache:

[Mon May 18 15:12:12 2009] [notice] caught SIGTERM, shutting down
[Mon May 18 15:16:16 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon May 18 15:16:19 2009] [notice] Digest: generating secret for digest authentication …
[Mon May 18 15:16:19 2009] [notice] Digest: done
[Mon May 18 15:16:21 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:11 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:14 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:17:16 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n
DBI connect(‘dbname=rt3;host=localhost’,‘rt_user’,…) failed: Access denied for user ‘rt_user’@‘localhost’ (using password: YES) at /usr/lib/perl5/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 106
[Mon May 18 15:18:15 2009] [error] [client 172.16.3.38] Connect Failed Access denied for user ‘rt_user’@‘localhost’ (using password: YES)\n at /opt/rt3/bin/…/lib/RT.pm line 204\n

Eric Chatham
MIS Department
Phone: (216) 373-4683
Fax: (216) 373-4669
echatham@broadvox.net
[cid:image001.gif@01C9D7CC.691A95E0]


CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

nimbius@sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

On Tuesday, May 19, 2009 07:22, Sven Wrote:

make:

  1. grep DatabaseUser /opt/rt3/etc/RT_SiteConfig.pm
  2. grep DatabasePassword /opt/rt3/etc/RT_SiteConfig.pm
  3. grep DatabaseRTHost /opt/rt3/etc/RT_SiteConfig.pm

and then

mysql -u result_from_2 -presult_from_2 -h result_from3

I’m quite sure that this is your problem.
The apache config looked okay (I’m not sure with
the redirect)

Thank you all for your assistance. I tried everyone’s suggestions. I
appreciate this. The problem is still persisting though. I made sure that
rt_user was added to my RT_SiteConfig.pm file and I even “hashed out” the
redirect in my Apache config (that Sven pointed out; I was thinking that
may’ve been a problem). I granted all permissions to the rt3 database for
rt_user. I’m using the default username/password in RT_Config.pm. I am no
longer getting the DBI error in my error_log. Now, it appears to be
something else.

perl -MCPAN -e “force install Sys::Syslog”

Restart Apache and post the next errors:-)

At your prompting, it took me just about 30 minutes to have rt-3.8.3rc1
running!! I love the web2 interface option.

Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223


“Clothes make the man. Naked people have little or no influence on
society.”
– Mark Twain

On Tuesday, May 19, 2009 12:14, Odhiambo ワシントン wrote,

Thank you all for your assistance. I tried everyone’s suggestions. I appreciate this. The problem is still persisting though. I made sure that rt_user was added to my RT_SiteConfig.pm file and I even “hashed out” the redirect in my Apache config (that Sven pointed out; I was thinking that may’ve been a problem). I granted all permissions to the rt3 database for rt_user. I’m using the default username/password in RT_Config.pm. I am no longer getting the DBI error in my error_log. Now, it appears to be something else.

perl -MCPAN -e “force install Sys::Syslog”

Restart Apache and post the next errors:-)

At your prompting, it took me just about 30 minutes to have rt-3.8.3rc1 running!! I love the web2 interface option.

Thank you that worked.

Eric

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.