Problems with RT 1.0.2 on Solaris 2.5.1


#1

Hi, I’m having a bit of trouble with getting email sent to Request Tracker
to go into it’s queue.

I’m running Request Tracker 1.0.2 on a Sun Ultra 5:
(SunOS www-ecs 5.5.1 Generic_103640-27 sun4u sparc SUNW,Ultra-5_10)

I’m using MySQL 3.22.32 (precompiled for Solaris 2.5.1), Perl 5.6.0,
sendmail 8.9.3, and apache 1.3.12. MySQL is running locally on the system.

I have a queue called “new” that is setup to accept requests from non-members.
I have things configured so that people can send requests to request-tracker@
and it goes to the rt account, which has a .forward in it to run procmail.
The .procmailrc filters out any email generated by system monitoring scripts and
sends those to a queue called “system”. All the other stuff goes to new.

Here’s the relevant part of the .procmailrc:

:0:

  • ^.*
    |/local/solaris_2.5.1/rt1.0.2/bin/rt-mailgate new correspond

So, here’s what I get in the logs from procmail:

procmail: Executing “/local/solaris_2.5.1/rt1.0.2/bin/rt-mailgate,new,correspond”

Mysql->connect failed: Can’t connect to local MySQL server through socket
’/tmp/mysql.sock’ (2) at /local/solaris_2.5.1/rt1.0.2/lib/rt/database.pm line 24

[connectdb] Database connect failed: Can’t connect to local MySQL
server through socket ‘/tmp/mysql.sock’ (2)

Compilation failed in require at
/local/solaris_2.5.1/rt1.0.2/lib/rt/database/manipulate.pm line 5.

Compilation failed in require at
/local/solaris_2.5.1/rt1.0.2/bin/rtmux.pl line 64.

procmail: [13806] Tue Aug 22 08:23:01 2000

procmail: Program failure (255) of
"/local/solaris_2.5.1/rt1.0.2/bin/rt-mailgate"

I have verified that the MySQL permissions are setup properly by running a
small perl script from the command line and connecting to the local MySQL server
as the user rt, password rtpass, database rt.

Also when I attempt to create a new request through the web interface, it bombs
out and the following shows up in the Apache error_log:

Could not send mail :frowning:

Tried to launch this command: /usr/lib/sendmail -t
[Tue Aug 22 08:39:24 2000] [error] [client 17.205.32.182] Premature end of
script headers: /local/solaris_2.5.1/rt1.0.2/bin/cgi/webrt.cgi

Yes, /usr/lib/sendmail does exist.

But, RT is able to create the request in the database.

I tried changing the Mprog setting in /etc/mail/sendmail.cf to be smrsh
(the sendmail restricted shell) instead of /bin/sh, but that didn’t make a
difference.

I’m running out of things to try to make this thing work. Any help would be
greatly appreciated.

-Grant Miller grant@pico.apple.com

Unix Systems Admin, Engineering Compute Services
unix-support@pico.apple.com, http://www-ecs.apple.com


#2

Is MySQL running?

Check this and the file in /tmp called mysql.sock

root@www-ecs:solaris_2.5.1/mysql3.22.32/bin #291> ./mysqladmin status
Uptime: 83619 Threads: 1 Questions: 9860 Slow queries: 0 Opens: 43
Flush tables: 1 Open tables: 9
root@www-ecs:solaris_2.5.1/mysql3.22.32/bin #292> ./mysqladmin processlist
| Id | User | Host | db | Command | Time | State | Info |
| 1208 | root | localhost | | Query | 0 | | show processlist |

root@www-ecs:~ #283> ls -l /tmp/mysql*
p--------- 1 root other 0 Aug 21 09:54 /tmp/mysql.sock

-Grant Miller grant@pico.apple.com x42917

Unix Systems Admin, Engineering Compute Services
unix-support@pico.apple.com, http://www-ecs.apple.com
ECS Hotline: x44747


#3

I know these are basic questions, but just to make sure,

what does the localhost entry in /etc/hosts look like?

It’s a Sun, what does the nsswitch.conf look like?

–clark


#4

I know these are basic questions, but just to make sure,

what does the localhost entry in /etc/hosts look like?

It’s a Sun, what does the nsswitch.conf look like?

From /etc/hosts:

127.0.0.1 localhost loghost

/etc/nsswitch.conf:

passwd: files nis
group: files nis

consult /etc “files” only if nis is down.

hosts: nis [NOTFOUND=return] files
networks: nis [NOTFOUND=return] files
protocols: nis [NOTFOUND=return] files
rpc: nis [NOTFOUND=return] files
ethers: nis [NOTFOUND=return] files
netmasks: nis [NOTFOUND=return] files
bootparams: nis [NOTFOUND=return] files
publickey: nis [NOTFOUND=return] files

netgroup: nis

automount: files nis
aliases: files nis

for efficient getservbyname() avoid nis

services: files nis
sendmailvars: files

-Grant Miller grant@pico.apple.com x42917

Unix Systems Admin, Engineering Compute Services
unix-support@pico.apple.com, http://www-ecs.apple.com
ECS Hotline: x44747


#5

On Tue, Aug 22, 2000 at 09:25:36AM -0700, Grant Miller emailed:

I know these are basic questions, but just to make sure,

what does the localhost entry in /etc/hosts look like?

It’s a Sun, what does the nsswitch.conf look like?

From /etc/hosts:

127.0.0.1 localhost loghost

that looks fine.

consult /etc “files” only if nis is down.

hosts: nis [NOTFOUND=return] files

I would change this line to
hosts: files dns nis
or
hosts: files nis

depending on your network setup. Are you really using NIS
or NIS+ to maintain a host file?

–clark


#6

p--------- 1 root other 0 Aug 21 09:54 /tmp/mysql.sock

Um, the permissions on that look whacked…

ls -al mysql.sock
srwxrwxrwx 1 root root 0 Aug 21 19:38 mysql.sock

Jesse
jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91
As I sit here alone looking at green text on a laptop in a mostly bare room listening
to loud music wearing all black, I realize that that it is much less cool in real life :slight_smile:
–Richard Tibbets