Problems with debian

Hi,

I’ve just had 2 debian systems running unstable barf on me.

crm-dev:~# /etc/init.d/apache start
Configuration syntax error detected. Not reloading.

Syntax error on line 10 of /etc/request-tracker3/apache-modperl.conf:
Can’t load module DBI, dynamic loading not available in this perl.
(You may need to build a new perl executable which either supports
dynamic loading or has the DBI module statically linked into it.)
at /usr/lib/perl5/DBI.pm line 252
BEGIN failed–compilation aborted at /usr/lib/perl5/DBI.pm line 252.
Compilation failed in require at /usr/share/perl5/Apache/DBI.pm line 7.
BEGIN failed–compilation aborted at /usr/share/perl5/Apache/DBI.pm line
7.
Compilation failed in require at (eval 13) line 3.

crm-dev:~#

AFAICT It wasn’t the result of a recent upgrade either - it seems the
problem only recently appeared…FWIW upgrading hasn’t fixed it.

am I the only one to see this?

help!

jamie

http://www.google.ru/search?q="dynamic+loading+not+available+in+this+perl"+Debian

After each upgrade which touch perl don’t forget to restart apache.

Jamie Baddeley wrote:

Looks like it might be worse than simply restarting it.

AFAICT the current workaround is recompiling apache and mod-perl. Yuk.

So it looks like request-tracker3 for debian unstable is broken. (bug
248730)

I’d be really pleased to discover another workaround, as I am not keen
on doing a build from source.

Failing that, looks like I’ll have to close the store. :frowning:

jamieOn Mon, 2004-05-24 at 12:13, Ruslan U. Zakirov wrote:

"dynamic loading not available in this perl" Debian - Google Suche

After each upgrade which touch perl don’t forget to restart apache.

Jamie Baddeley wrote:

Hi,

I’ve just had 2 debian systems running unstable barf on me.

crm-dev:~# /etc/init.d/apache start
Configuration syntax error detected. Not reloading.

Syntax error on line 10 of /etc/request-tracker3/apache-modperl.conf:
Can’t load module DBI, dynamic loading not available in this perl.
(You may need to build a new perl executable which either supports
dynamic loading or has the DBI module statically linked into it.)
at /usr/lib/perl5/DBI.pm line 252
BEGIN failed–compilation aborted at /usr/lib/perl5/DBI.pm line 252.
Compilation failed in require at /usr/share/perl5/Apache/DBI.pm line 7.
BEGIN failed–compilation aborted at /usr/share/perl5/Apache/DBI.pm line
7.
Compilation failed in require at (eval 13) line 3.

crm-dev:~#

AFAICT It wasn’t the result of a recent upgrade either - it seems the
problem only recently appeared…FWIW upgrading hasn’t fixed it.

am I the only one to see this?

help!

jamie

The unstable package is broken, something has changed in the new perl
5.8.4-2 package. After downgrading several other packages to, it works
for me. Here is a list of these packages:

apache-common_1.3.29.0.2-4_i386.deb
apache-perl_1.3.29.0.2-4_i386.deb
libapache-dbi-perl_0.92-0.1_all.deb
libapache-mod-perl_1.29.0.2-4_i386.deb
libapache-request-perl_1.1-0.1_i386.deb
libapache-session-perl_1.54-2_all.deb
libcache-cache-perl_1.02-2_all.deb
libclass-returnvalue-perl_0.40-1_all.deb
libdbd-pg-perl_1.32-1_i386.deb
libdbi-perl_1.41-1_i386.deb
libdbix-searchbuilder-perl_0.97-2_all.deb
libexception-class-perl_1.16-1_all.deb
libfreezethaw-perl_0.43-2_all.deb
libhtml-mason-perl_1.26-1_all.deb
libhtml-parser-perl_3.36-1_i386.deb
liblocale-maketext-fuzzy-perl_0.02-1_all.deb
liblocale-maketext-lexicon-perl_0.38-1_all.deb
liblog-dispatch-perl_2.07-1_all.deb
libmailtools-perl_1.62-1_all.deb
libmime-perl_5.411-3_all.deb
libmldbm-perl_2.01-1_all.deb
libparams-validate-perl_0.69-1_i386.deb
libperl5.8_5.8.3-3_i386.deb
libregexp-common-perl_2.113-1_all.deb
libterm-readkey-perl_2.21-1.3_i386.deb
libtest-inline-perl_0.15-1_all.deb
libtext-autoformat-perl_1.12-2_all.deb
libtext-quoted-perl_1.5-1_all.deb
libtext-template-perl_1.42-3_all.deb
libtext-wrapper-perl_1.000-2_all.deb
libtime-modules-perl_2003.1126-1_all.deb
perl-base_5.8.3-3_i386.deb
perl-modules_5.8.3-3_all.deb
perl_5.8.3-3_i386.deb

Greetings,
Stefan

Jamie Baddeley wrote:

Looks like it might be worse than simply restarting it.

AFAICT the current workaround is recompiling apache and mod-perl. Yuk.

So it looks like request-tracker3 for debian unstable is broken. (bug
248730)

I’d be really pleased to discover another workaround, as I am not keen
on doing a build from source.

Failing that, looks like I’ll have to close the store. :frowning:

jamie

"dynamic loading not available in this perl" Debian - Google Suche

After each upgrade which touch perl don’t forget to restart apache.

Jamie Baddeley wrote:

Hi,

I’ve just had 2 debian systems running unstable barf on me.

crm-dev:~# /etc/init.d/apache start
Configuration syntax error detected. Not reloading.

Syntax error on line 10 of /etc/request-tracker3/apache-modperl.conf:
Can’t load module DBI, dynamic loading not available in this perl.
(You may need to build a new perl executable which either supports
dynamic loading or has the DBI module statically linked into it.)
at /usr/lib/perl5/DBI.pm line 252
BEGIN failed–compilation aborted at /usr/lib/perl5/DBI.pm line 252.
Compilation failed in require at /usr/share/perl5/Apache/DBI.pm line 7.
BEGIN failed–compilation aborted at /usr/share/perl5/Apache/DBI.pm line
7.
Compilation failed in require at (eval 13) line 3.

crm-dev:~#

AFAICT It wasn’t the result of a recent upgrade either - it seems the
problem only recently appeared…FWIW upgrading hasn’t fixed it.

am I the only one to see this?

help!

jamie

Mit freundlichen Gr��en / Kind Regards
/
. / ^ _ \ .
|| (o)(o) |/|
.OOOo–oo–oOOO.__
| |
| Stefan Fischer |
| IT-Consulting |
| |
| Mobil…: +49 163 8027222 |
| B�ro…: +49 89 36055848 |
| Fax…: +49 89 36055846 |
| e-mail…: stefan@van-boxmer.de |
|================================|
| Who is General Failure and why |
| is he reading my hard disk? |
|_______________Oooo.___________|
.oooO ( )
( ) ) /
\ ( (
/
_)

Hi,

I’ve just had 2 debian systems running unstable barf on me.

crm-dev:~# /etc/init.d/apache start
Configuration syntax error detected. Not reloading.

Syntax error on line 10 of /etc/request-tracker3/apache-modperl.conf:
Can’t load module DBI, dynamic loading not available in this perl.

Hi there,

The problem is that the apache mod_perl module needs recompiling. The
2nd version of the perl 5.8.4 package introduced an incompatibility
between it and mod_perl. Sadly the mod_perl maintainer is being
extremely slow at fixing this problem, see bug #248730 which is 11
days old now:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=248730

I don’t like pointing out the obvious but this is why there is testing
and unstable, although really annoying (this bug caught me as well)
this sort of thing has to be expected on Debian unstable. A
willingness to rebuild packages occasionally and deal with nasty bugs
is really a requirement. I certainly would never run anything
mission-critical on a Debian unstable machine. The versions in testing
do not have these problems and as such it is a much safer bet.

Stephen Quinney

signature.asc (189 Bytes)

Stefan Fischer wrote:

The unstable package is broken, something has changed in the new perl
5.8.4-2 package. After downgrading several other packages to, it works
for me. Here is a list of these packages:

Thanks for the list. If anybody could tell us when the package is broken
no more, that would be wonderful.

Thanks in advance
–bronto

PS: BTW, I am using the RT package in Debian Testing