Problems with 4.0.5: printing some pages; emailing dashboards

Hi List

After moving from v4.0.4 to 4.0.5 (Linux server, windows browser) we
noticed the following 2 new issues:

When printing certain pages, nothing will be shown below the H1 title.
This was seen both with Firefox and IE We see the issue with “Query
Builder”, “Modify the user xxx”, “Modify the content of dashboard …”,
“Modify the subscription to dashboard …”, and search results which
include a chart. There does not seem to be any problem printing
dashboards and chart-free search results.

When emailing dashboards, our Lotus Notes email client is a bit upset
with the JavaScript. and issues obnoxious warnings (“jQuery is not
defined”). Long dashboards are truncated when displayed. Even if a
short dashboard is displayed correctly we cannot forward it from Lotus
Notes. Also, the dashboard lost its color. Our other mailers are plain
text, and don’t seem to mind.

To be sure, these are not major issues, but are enough of a nuisance that
we may need to revert to v4.0.4.

Thanks for any suggestions, or let me know if you need more details.
Jim Berry

After moving from v4.0.4 to 4.0.5 (Linux server, windows browser) we noticed the following 2
new issues:

When printing certain pages, nothing will be shown below the H1 title. This was seen both
with Firefox and IE We see the issue with “Query Builder”, “Modify the user xxx”, “Modify
the content of dashboard …”, “Modify the subscription to dashboard …”, and search results
which include a chart. There does not seem to be any problem printing dashboards and
chart-free search results.

There were some large changes with print.css in 4.0.5, you should
double check that you don’t have css modifications that are
interfering.

When emailing dashboards, our Lotus Notes email client is a bit upset with the JavaScript.
and issues obnoxious warnings (“jQuery is not defined”). Long dashboards are truncated when
displayed. Even if a short dashboard is displayed correctly we cannot forward it from Lotus
Notes. Also, the dashboard lost its color. Our other mailers are plain text, and don’t seem
to mind.

To be sure, these are not major issues, but are enough of a nuisance that we may need to
revert to v4.0.4.

I believe that JS in dashboards error has actually been around for the
whole 4.0 series, I’m surprised that Lotus only now started
complaining.

Does it hate the Framebusting JS or a different chunk. I’d be curious
to know if 4.0/suppress-dashboard-javascript fixes it or if things
like the tabs JS are causing problems.

-kevin