Problems Starting RT 3.0.1

Hi, i tried to start rt3.0.1 with fastcgi under my apache with following
configuration:

httpd.conf:

LoadModule fastcgi_module libexec/mod_fastcgi.so

AddModule mod_fastcgi.c

FastCgiWrapper /usr/local/apache/bin/suexec

FastCgiIpcDir /var/lib/httpd

ServerName rt.my-server.com

DocumentRoot /opt/rt3/share/html

AddDefaultCharset UTF-8

FastCgiServer /opt/rt3/bin/mason_handler.fcgi

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

Error_log says:

[Fri May 2 17:01:23 2003] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" has failed to remain running for 30 secon

ds given 3 attempts, its restart interval has been backed off to 600 seconds

[Fri May 2 17:01:23 2003] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (uid 509, gid 103) restarted (pid 9521)

[Fri May 2 17:01:23 2003] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 9521) terminated by calling exit wit

h status ‘114’

[Fri May 2 17:01:23 2003] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" has failed to remain running for 30 secon

ds given 3 attempts, its restart interval has been backed off to 600 seconds

Can anyone please help? Thank you very much

Manuel Bernardy

Update to rt 3.0.2pre5. This will help.

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

Hi, i tried to start rt3.0.1 with fastcgi under my apache with following
configuration:

RT 3.0.1’s fastcgi support was broken due to a tainting bug.
RT 3.0.2pre5 is the current pre-release of rt 3.0.2 and is strongly
recommended instead of 3.0.1. You can pick it up from
fsck.com/pub/rt/devel/

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Hi, ok, i just updated to 3.0.2pre5 but now I get an Error 500 and the
apache error log says:

[Fri May 2 17:41:09 2003] [notice] Apache/1.3.27 Ben-SSL/1.48 (Unix)
mod_fastcgi/2.4.0 PHP/4.3.1 configured – resuming norm al operations [Fri
May 2 17:41:09 2003] [notice] suEXEC mechanism enabled (wrapper:
/usr/local/apache/bin/suexec) [Fri May 2 17:41:09 2003] [notice] Accept
mutex: sysvsem (Default: sysvsem) [Fri May 2 17:41:14 2003] [warn] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” (uid 509, gid 103) restarted (pid
16013) [Fri May 2 17:41:14 2003] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 16013) terminated by calling exit wi
th status ‘114’ [Fri May 2 17:50:18 2003] [error] [client 62.67.209.108]
FastCGI: comm with server “/opt/rt3/bin/mason_handler.fcgi” aborted
: idle timeout (30 sec)
[Fri May 2 17:50:18 2003] [error] [client 62.67.209.108] FastCGI:
incomplete headers (0 bytes) received from server “/opt/rt
3/bin/mason_handler.fcgi”

What to do now?

Thank you again!
ManuelVon: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com] Im
Auftrag von Jesse Vincent
Gesendet: Freitag, 2. Mai 2003 17:23
An: Manuel Bernardy
Cc: rt-users@fsck.com
Betreff: Re: [rt-users] Problems Starting RT 3.0.1

Hi, i tried to start rt3.0.1 with fastcgi under my apache with
following
configuration:

RT 3.0.1’s fastcgi support was broken due to a tainting bug.
RT 3.0.2pre5 is the current pre-release of rt 3.0.2 and is strongly
recommended instead of 3.0.1. You can pick it up from
fsck.com/pub/rt/devel/

http://www.bestpractical.com/rt – Trouble Ticketing. Free.
rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

When rt’s fastcig server fails to start, the best thing to do is often
to try running it by hand and see what it complains about. Perhaps you
haven’t satestfied all its dependencies?

-jOn Fri, May 02, 2003 at 05:51:58PM +0200, Manuel Bernardy wrote:

Hi, ok, i just updated to 3.0.2pre5 but now I get an Error 500 and the
apache error log says:

[Fri May 2 17:41:09 2003] [notice] Apache/1.3.27 Ben-SSL/1.48 (Unix)
mod_fastcgi/2.4.0 PHP/4.3.1 configured – resuming norm al operations [Fri
May 2 17:41:09 2003] [notice] suEXEC mechanism enabled (wrapper:
/usr/local/apache/bin/suexec) [Fri May 2 17:41:09 2003] [notice] Accept
mutex: sysvsem (Default: sysvsem) [Fri May 2 17:41:14 2003] [warn] FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” (uid 509, gid 103) restarted (pid
16013) [Fri May 2 17:41:14 2003] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 16013) terminated by calling exit wi
th status ‘114’ [Fri May 2 17:50:18 2003] [error] [client 62.67.209.108]
FastCGI: comm with server “/opt/rt3/bin/mason_handler.fcgi” aborted
: idle timeout (30 sec)
[Fri May 2 17:50:18 2003] [error] [client 62.67.209.108] FastCGI:
incomplete headers (0 bytes) received from server “/opt/rt
3/bin/mason_handler.fcgi”

What to do now?

Thank you again!
Manuel

-----Urspr�ngliche Nachricht-----
Von: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com] Im
Auftrag von Jesse Vincent
Gesendet: Freitag, 2. Mai 2003 17:23
An: Manuel Bernardy
Cc: rt-users@fsck.com
Betreff: Re: [rt-users] Problems Starting RT 3.0.1

On Fri, May 02, 2003 at 05:04:10PM +0200, Manuel Bernardy wrote:

Hi, i tried to start rt3.0.1 with fastcgi under my apache with
following
configuration:

RT 3.0.1’s fastcgi support was broken due to a tainting bug.
RT 3.0.2pre5 is the current pre-release of rt 3.0.2 and is strongly
recommended instead of 3.0.1. You can pick it up from
fsck.com/pub/rt/devel/


http://www.bestpractical.com/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

When i run it by hand (./mason_handler.fcgi) i get an html output which
looks quite ok!

I think its my httpd.conf where the error is:

LoadModule fastcgi_module libexec/mod_fastcgi.so
AddModule mod_fastcgi.c
FastCgiWrapper /usr/local/apache/bin/suexec
FastCgiIpcDir /var/lib/httpd

ServerName rt.my-server.com DocumentRoot /opt/rt3/share/html AddDefaultCharset UTF-8 FastCgiServer /opt/rt3/bin/mason_handler.fcgi Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/ ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

Any suggestions?

ManuelVon: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com] Im
Auftrag von Jesse Vincent
Gesendet: Freitag, 2. Mai 2003 17:58
An: Manuel Bernardy
Cc: rt-users@fsck.com
Betreff: Re: [rt-users] Problems Starting RT 3.0.1

When rt’s fastcig server fails to start, the best thing to do is often
to try running it by hand and see what it complains about. Perhaps you
haven’t satestfied all its dependencies?

-j

Hi, ok, i just updated to 3.0.2pre5 but now I get an Error 500 and the
apache error log says:

[Fri May 2 17:41:09 2003] [notice] Apache/1.3.27 Ben-SSL/1.48 (Unix)
mod_fastcgi/2.4.0 PHP/4.3.1 configured – resuming norm al operations [Fri
May 2 17:41:09 2003] [notice] suEXEC mechanism enabled (wrapper:
/usr/local/apache/bin/suexec) [Fri May 2 17:41:09 2003] [notice] Accept
mutex: sysvsem (Default: sysvsem) [Fri May 2 17:41:14 2003] [warn]
FastCGI:
server “/opt/rt3/bin/mason_handler.fcgi” (uid 509, gid 103) restarted (pid
16013) [Fri May 2 17:41:14 2003] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 16013) terminated by calling exit
wi
th status ‘114’ [Fri May 2 17:50:18 2003] [error] [client 62.67.209.108]
FastCGI: comm with server “/opt/rt3/bin/mason_handler.fcgi” aborted
: idle timeout (30 sec)
[Fri May 2 17:50:18 2003] [error] [client 62.67.209.108] FastCGI:
incomplete headers (0 bytes) received from server “/opt/rt
3/bin/mason_handler.fcgi”

What to do now?

Thank you again!
Manuel

-----Ursprüngliche Nachricht-----
Von: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
Im
Auftrag von Jesse Vincent
Gesendet: Freitag, 2. Mai 2003 17:23
An: Manuel Bernardy
Cc: rt-users@fsck.com
Betreff: Re: [rt-users] Problems Starting RT 3.0.1

Hi, i tried to start rt3.0.1 with fastcgi under my apache with
following
configuration:

RT 3.0.1’s fastcgi support was broken due to a tainting bug.
RT 3.0.2pre5 is the current pre-release of rt 3.0.2 and is strongly
recommended instead of 3.0.1. You can pick it up from
fsck.com/pub/rt/devel/


http://www.bestpractical.com/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm