Problems since upgrading to RT 3.8.x

I have 3.8.1 installed, but we have had several problems that started since going to 3.8.0.

  1. Randomly logging users out of RT. One example is when a user clicks on “## highest priority tickets I own”. It brings up the top tickets, but when they click on one, it takes them back to the login screen. When they log back in, it takes them into the ticket they clicked on before they logged out.

  2. One two occasions, RT has just crashed with an internal server error when trying to navigate to the URL. I restarted httpd and mysqld and it still did not come up. Everything worked fine after I rebooted. I don’t see anything in the logs to indicate the reason.

  3. Old code to show complete ticket history in a template no longer works, as detailed in previous post.

If anyone could lead me in the right direction on fixing any of these, I would appreciate it.

Thanks,
Shannon

I have 3.8.1 installed, but we have had several problems that
started since going to 3.8.0.

  1. Randomly logging users out of RT. One example is when a user
    clicks on “## highest priority tickets I own”. It brings up the
    top tickets, but when they click on one, it takes them back to the
    login screen. When they log back in, it takes them into the ticket
    they clicked on before they logged out.

I also found that, on my test-install.
However, clearing mason-cache and local browser cache seems to have
cured it.

RT seems to cache very aggressively and that can lead to some strange
effects.

Rainer

Did the url change when you upgraded ?------Original Message------
From: Shannon Adams
Sender: rt-users-bounces@lists.bestpractical.com
To: rt-users@lists.bestpractical.com
Sent: Aug 26, 2008 11:41
Subject: [rt-users] Problems since upgrading to RT 3.8.x

I have 3.8.1 installed, but we have had several problems that started since going to 3.8.0.

  1. Randomly logging users out of RT. One example is when a user clicks on “## highest priority tickets I own”. It brings up the top tickets, but when they click on one, it takes them back to the login screen. When they log back in, it takes them into the ticket they clicked on before they logged out.

  2. One two occasions, RT has just crashed with an internal server error when trying to navigate to the URL. I restarted httpd and mysqld and it still did not come up. Everything worked fine after I rebooted. I don’t see anything in the logs to indicate the reason.

  3. Old code to show complete ticket history in a template no longer works, as detailed in previous post.

If anyone could lead me in the right direction on fixing any of these, I would appreciate it.

Thanks,
Shannon

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

No, the URL is the same.

Shannon----- Original Message ----
From: "chaim.rieger@gmail.com" chaim.rieger@gmail.com
To: Shannon Adams shannon_adams68@yahoo.com; rt-users-bounces@lists.bestpractical.com; rt-users@lists.bestpractical.com
Sent: Tuesday, August 26, 2008 2:54:03 PM
Subject: Re: [rt-users] Problems since upgrading to RT 3.8.x

Did the url change when you upgraded ?

------Original Message------
From: Shannon Adams
Sender: rt-users-bounces@lists.bestpractical.com
To: rt-users@lists.bestpractical.com
Sent: Aug 26, 2008 11:41
Subject: [rt-users] Problems since upgrading to RT 3.8.x

I have 3.8.1 installed, but we have had several problems that started since going to 3.8.0.

  1. Randomly logging users out of RT. One example is when a user clicks on “## highest priority tickets I own”. It brings up the top tickets, but when they click on one, it takes them back to the login screen. When they log back in, it takes them into the ticket they clicked on before they logged out.

  2. One two occasions, RT has just crashed with an internal server error when trying to navigate to the URL. I restarted httpd and mysqld and it still did not come up. Everything worked fine after I rebooted. I don’t see anything in the logs to indicate the reason.

  3. Old code to show complete ticket history in a template no longer works, as detailed in previous post.

If anyone could lead me in the right direction on fixing any of these, I would appreciate it.

Thanks,
Shannon

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I also have discovered this… Am testing out this new version on a
system loaded with Fedora Core 6.
Would get sent back to login screen if I try to build a search query.
Then found if I click on either tickets I own or unowned tickets and
select one of the tickets displayed, it throws me to the login screen.