Problems on RT-Authen-ExternalAuth

Guys

This errror is appearing after i log into rt

Can’t call method “as_string” on an undefined value at
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm
line 398, line 50

If you can give some ligth…

Regards,

Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

Eliezer E Ch�vez wrote:

Guys

This errror is appearing after i log into rt

Can’t call method “as_string” on an undefined value at
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm
line 398, line 50

You are almost certainly missing some configuration directives.

Check that you have a filter, d_filter, base, attr_map and
attr_match_list for your LDAP source. Also valid values for
ExternalAuthPriority and ExternalInfoPriority.

Kind Regards,

Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com

[as10g@aspccs11 /opt/rt/etc]$ cat RT_SiteConfig.pm

Any configuration directives you include here will override

RT’s default configuration file, RT_Config.pm

To include a directive here, just copy the equivalent statement

from RT_Config.pm and change the value. We’ve included a single

sample value below.

This file is actually a perl module, so you can include valid

perl code, as well.

The converse is also true, if this file isn’t valid perl, you’re

going to run into trouble. To check your SiteConfig file, use

this comamnd:

perl -c /path/to/your/etc/RT_SiteConfig.pm

Set($rtname , ‘movilnet.com.ve’);
Set($Organization , ‘movilnet.com.ve’);
Set($OwnerEmail , ‘as10g’);
Set($RTAddressRegexp , ‘^rt@movilnet.com.ve$’);
Set($CorrespondAddress , ‘rt@movilnet.com.ve’);
Set($CommentAddress , ‘rt@movilnet.com.ve’);
#Set($CanonicalizeEmailAddressMatch , ‘rt.movilnet.com.ve$’);
Set($CanonicalizeEmailAddressReplace , ‘movilnet.com.ve’);
Set($WebDomain , ‘localhost’ );
Set($WebPort , 443);# + ($< * 7274) % 32766 +
($< && 1024));
Set($WebPath , “”);
Set($WebBaseURL , ‘https://’ .
RT->Config->Get(‘WebDomain’) . ‘:’ . RT->Config->Get(‘WebPort’));
Set($WebURL , RT->Config->Get(‘WebBaseURL’)
. RT->Config->Get(‘WebPath’) . “/”);
Set($WebImagesURL , RT->Config->Get(‘WebPath’) .
"/NoAuth/images");
Set($WebSecureCookies , ‘1’);
Set($LogoURL , $Config->Get(‘WebImagesURL’) .
"/bplogo.gif");
Set($Timezone , ‘America/Caracas’);
Set($DatabaseType , ‘Oracle’);
Set(@Plugins , qw(RT::FM));
#Set(@Plugins , (qw(Extension::QuickDelete)));
#Set($DevelMode , ‘1’);
Set($LogToFile , ‘debug’);
Set($LogDir , ‘/logs/rt’);
Set($LogToFileNamed , “rt.log”);

Set( @Plugins, qw(RT::Authen::ExternalAuth) );

Set($WebExternalAuth , ‘1’);
Set($WebFallbackToInternalAuth , ‘1’);
Set($WebExternalGecos , undef);
Set($WebExternalAuto , ‘1’);

Set($ExternalAuthPriority, [ ‘My_LDAP’
]
);
Set($ExternalInfoPriority, [ ‘My_LDAP’
]
);
Set($ExternalServiceUsesSSLorTLS, 0);
Set($AutoCreateNonExternalUsers, 0);
Set($ExternalSettings, { # AN EXAMPLE LDAP SERVICE
’My_LDAP’ => { ## GENERIC SECTION
# The type of
service (db/ldap/cookie)
‘type’
=> ‘ldap’,
# The server
hosting the service
’server’
=> ‘161.196.64.3’,
SERVICE-SPECIFIC SECTION
# If you can
bind to your LDAP server anonymously you should
# remove the
user and pass config lines, otherwise specify them here:
# The username
RT should use to connect to the LDAP server
’user’
=> ‘CANTV\gepror’,
# The password
RT should use to connect to the LDAP server
’pass’
=> ‘Capital02’,
# The LDAP search base
’base’
=> ‘DC=cantv,DC=com,DC=ve’,
# ALL FILTERS
MUST BE VALID LDAP FILTERS ENCASED IN PARENTHESES!
# YOU MUST
SPECIFY A filter AND A d_filter!!
# The filter
to use to match RT-Users
’filter’
=> ‘(objectClass=Person)’,
# A catch-all
example filter: ‘(objectClass=*)’
# The filter
that will only match disabled users
’d_filter’
=> ‘(userAccountControl:1.2.840.113556.1.4.1781)’,
# A catch-none
example d_filter: ‘(objectClass=FooBarBaz)’
# Should we
try to use TLS to encrypt connections?
‘tls’
=> 0,
# SSL Version
to provide to Net::SSLeay if using SSL
’ssl_version’
=> 3,
# What other
args should I pass to Net::LDAP->new($host,@args)?

‘net_ldap_args’ => [ version => 3 ],
# Does
authentication depend on group membership? What group name?
#‘group’
=> ‘GROUP_NAME’,
# What is the
attribute for the group object that determines membership?
#‘group_attr’
=> ‘GROUP_ATTR’,
## RT
ATTRIBUTE MATCHING SECTION
# The list of
RT attributes that uniquely identify a user
# This example
shows what you can specify… I recommend reducing this
# to just the
Name and EmailAddress to save encountering problems later.

‘attr_match_list’ => [ ‘Name’,

                 'EmailAddress'

             ],
                                                    # The mapping

of RT attributes on to LDAP attributes
’attr_map’
=> { ‘Name’ => ‘sAMAccountName’,

                 'EmailAddress' => 'mail'

             }
                                                }
                            }

);
1;

Eliezer E Chávez wrote:

Guys

This errror is appearing after i log into rt

Can’t call method “as_string” on an undefined value at
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm
line 398, line 50

You are almost certainly missing some configuration directives.

Check that you have a filter, d_filter, base, attr_map and
attr_match_list for your LDAP source. Also valid values for
ExternalAuthPriority and ExternalInfoPriority.


Kind Regards,


Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com


Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

External Authentication Configuration

Set(@Plugins , qw(RT::Authen::ExternalAuth) );
Set($WebExternalAuth , ‘1’);
Set($WebFallbackToInternalAuth , ‘1’);
Set($WebExternalGecos , undef);
Set($WebExternalAuto , ‘1’);
Set($ExternalAuthPriority , [ ‘My_LDAP’ ] );
Set($ExternalInfoPriority , [ ‘My_LDAP’ ] );
Set($ExternalServiceUsesSSLorTLS , 0);
Set($AutoCreateNonExternalUsers , 0);
Set($ExternalSettings , {
‘My_LDAP’ => {
‘type’
=> ‘ldap’,
‘server’
=> ‘161.196.64.3’,
‘user’
=> ‘CANTV\gepror’,
‘pass’
=> ‘Capital02’,
‘base’
=> ‘DC=cantv,DC=com,DC=ve’,
‘filter’
=> ‘(objectClass=person)’,
‘d_filter’
=> ‘(userAccountControl:1.2.840.113556.1.4.1781)’,
‘tls’ => 0,
‘ssl_version’ => 3,
‘net_ldap_args’
=> [ version => 3 ],
‘group’ => ‘’,
‘group_attr’ => ‘’,
‘attr_match_list’
=> [ ‘Name’,

  'EmailAddress'],
                                            'attr_map'

=> { ‘Name’ => ‘sAMAccountName’,

  'EmailAddress' => 'mail' }
                                                  }
                                    });

Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

Sorry…

This is my RT-Authen-ExternalAuth configuration in RT_SiteConfig.pm, i
just wondering if you take a look and tell me if something is wrong…

regards!

External Authentication Configuration

Set(@Plugins , qw(RT::Authen::ExternalAuth) );
Set($WebExternalAuth , ‘1’);
Set($WebFallbackToInternalAuth , ‘1’);
Set($WebExternalGecos , undef);
Set($WebExternalAuto , ‘1’);
Set($ExternalAuthPriority , [ ‘My_LDAP’ ] );
Set($ExternalInfoPriority , [ ‘My_LDAP’ ] );
Set($ExternalServiceUsesSSLorTLS , 0);
Set($AutoCreateNonExternalUsers , 0);
Set($ExternalSettings , {
‘My_LDAP’ => {
‘type’
=> ‘ldap’,
‘server’
=> ‘161.196.64.3’,
‘user’
=> ‘CANTV\gepror’,
‘pass’
=> ‘Capital02’,
‘base’
=> ‘DC=cantv,DC=com,DC=ve’,
‘filter’
=> ‘(objectClass=person)’,
‘d_filter’
=> ‘(userAccountControl:1.2.840.113556.1.4.1781)’,
‘tls’ => 0,
‘ssl_version’ => 3,
‘net_ldap_args’
=> [ version => 3 ],
‘group’ => ‘’,
‘group_attr’ => ‘’,
‘attr_match_list’
=> [ ‘Name’,

 'EmailAddress'],
                                           'attr_map'

=> { ‘Name’ => ‘sAMAccountName’,

 'EmailAddress' => 'mail' }
                                                 }
                                   });


Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

http://www.bumeran.com.ve/cv/eliezer-chavez

Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

Eliezer E Ch�vez wrote:

Sorry…

This is my RT-Authen-ExternalAuth configuration in RT_SiteConfig.pm, i
just wondering if you take a look and tell me if something is wrong…

Delete the above.

Set($WebExternalAuth , ‘1’);
Set($WebFallbackToInternalAuth , ‘1’);
Set($WebExternalGecos , undef);
Set($WebExternalAuto , ‘1’);

Delete or comment out:

                                           'ssl_version'           =>  3,

Delete or comment out:

                                           'group'                 =>  '',
                                           'group_attr'            =>  '',

Other than that, without knowing the problem and seeing debug logs I
can’t help you further.
Kind Regards,

Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com

Mike Peachey wrote:

Delete the above.

I meant below.
Kind Regards,

Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com

Mike:

This is the debug log…

[Tue Mar 10 00:24:18 2009] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC
contains: /opt/rt/bin/…/local/lib
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib /opt/rt/bin/…/lib
/opt/perl/lib/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/5.10.0
/opt/perl/lib/site_perl/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/site_perl/5.10.0 . /opt/apache/httpd) at
/opt/rt/bin/…/lib/RT/Config.pm line 311, line 323.
(/opt/rt/bin/…/lib/RT/Config.pm:312)
[Tue Mar 10 00:24:18 2009] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt/var/data/gpg). PGP support has been disabled
(/opt/rt/bin/…/lib/RT/Config.pm:339)
[Tue Mar 10 00:24:19 2009] [debug]: Reloading RT::User to work around
a bug in RT-3.8.0 and RT-3.8.1
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Auth:14)
[Tue Mar 10 00:24:19 2009] [debug]: Attempting to use external auth
service: My_LDAP
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:64)
[Tue Mar 10 00:24:19 2009] [debug]: SSO Failed and no user to test
with. Nexting (/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:92)
[Tue Mar 10 00:24:19 2009] [debug]: Autohandler called ExternalAuth.
Response: (0, No User)
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Auth:26)
[Tue Mar 10 00:24:23 2009] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC
contains: /opt/rt/bin/…/local/lib
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib /opt/rt/bin/…/lib
/opt/perl/lib/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/5.10.0
/opt/perl/lib/site_perl/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/site_perl/5.10.0 . /opt/apache/httpd) at
/opt/rt/bin/…/lib/RT/Config.pm line 311, line 323.
(/opt/rt/bin/…/lib/RT/Config.pm:312)
[Tue Mar 10 00:24:23 2009] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt/var/data/gpg). PGP support has been disabled
(/opt/rt/bin/…/lib/RT/Config.pm:339)
[Tue Mar 10 00:24:23 2009] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC
contains: /opt/rt/bin/…/local/lib
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib /opt/rt/bin/…/lib
/opt/perl/lib/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/5.10.0
/opt/perl/lib/site_perl/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/site_perl/5.10.0 . /opt/apache/httpd) at
/opt/rt/bin/…/lib/RT/Config.pm line 311, line 323.
(/opt/rt/bin/…/lib/RT/Config.pm:312)
[Tue Mar 10 00:24:23 2009] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt/var/data/gpg). PGP support has been disabled
(/opt/rt/bin/…/lib/RT/Config.pm:339)
[Tue Mar 10 00:24:23 2009] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC
contains: /opt/rt/bin/…/local/lib
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib /opt/rt/bin/…/lib
/opt/perl/lib/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/5.10.0
/opt/perl/lib/site_perl/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/site_perl/5.10.0 . /opt/apache/httpd) at
/opt/rt/bin/…/lib/RT/Config.pm line 311, line 323.
(/opt/rt/bin/…/lib/RT/Config.pm:312)
[Tue Mar 10 00:24:23 2009] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt/var/data/gpg). PGP support has been disabled
(/opt/rt/bin/…/lib/RT/Config.pm:339)
[Tue Mar 10 00:24:37 2009] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC
contains: /opt/rt/bin/…/local/lib
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib /opt/rt/bin/…/lib
/opt/perl/lib/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/5.10.0
/opt/perl/lib/site_perl/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/site_perl/5.10.0 . /opt/apache/httpd) at
/opt/rt/bin/…/lib/RT/Config.pm line 311, line 323.
(/opt/rt/bin/…/lib/RT/Config.pm:312)
[Tue Mar 10 00:24:37 2009] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt/var/data/gpg). PGP support has been disabled
(/opt/rt/bin/…/lib/RT/Config.pm:339)
[Tue Mar 10 00:24:37 2009] [debug]: Reloading RT::User to work around
a bug in RT-3.8.0 and RT-3.8.1
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Auth:14)
[Tue Mar 10 00:24:38 2009] [debug]: Attempting to use external auth
service: My_LDAP
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:64)
[Tue Mar 10 00:24:38 2009] [debug]: Calling UserExists with $username
(ynogue) and $service (My_LDAP)
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:105)
[Tue Mar 10 00:24:38 2009] [debug]: UserExists params:
username: ynogue , service: My_LDAP
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:274)
[Tue Mar 10 00:24:38 2009] [debug]: LDAP Search === Base:
dc=cantv,dc=com,dc=ve == Filter:
(&(objectClass=person)(sAMAccountName=ynogue)) == Attrs:
mail,sAMAccountName
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:304)
[Tue Mar 10 00:24:38 2009] [debug]: Password validation required for
service - Executing…
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:155)
[Tue Mar 10 00:24:38 2009] [debug]: Trying external auth service:
My_LDAP (/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:16)
[Tue Mar 10 00:24:38 2009] [debug]: LDAP Search === Base:
dc=cantv,dc=com,dc=ve == Filter:
(&(sAMAccountName=ynogue)(objectClass=person)) == Attrs: dn
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:43)
[Tue Mar 10 00:24:38 2009] [debug]: Found LDAP DN: CN=Noguera
Yuruadi,OU=Usuarios,OU=Avanzados,OU=Movilnet
Users,OU=DATA,DC=cantv,DC=com,DC=ve
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:75)
[Tue Mar 10 00:24:38 2009] [info]:
RT::Authen::ExternalAuth::LDAP::GetAuth External Auth OK ( My_LDAP ):
ynogue (/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:139)
[Tue Mar 10 00:24:38 2009] [debug]: LDAP password validation result: 1
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:334)
[Tue Mar 10 00:24:38 2009] [debug]: Password Validation Check Result:
1 (/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:159)
[Tue Mar 10 00:24:38 2009] [debug]: Authentication successful. Now
updating user information and attempting login.
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:179)
[Tue Mar 10 00:24:38 2009] [debug]: UserExists params:
username: ynogue , service: My_LDAP
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:274)
[Tue Mar 10 00:24:38 2009] [debug]: LDAP Search === Base:
dc=cantv,dc=com,dc=ve == Filter:
(&(objectClass=person)(sAMAccountName=ynogue)) == Attrs:
mail,sAMAccountName
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:304)
[Tue Mar 10 00:24:38 2009] [debug]: UserExists params:
username: ynogue , service: My_LDAP
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:274)
[Tue Mar 10 00:24:38 2009] [debug]: LDAP Search === Base:
dc=cantv,dc=com,dc=ve == Filter:
(&(objectClass=person)(sAMAccountName=ynogue)) == Attrs:
mail,sAMAccountName
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:304)
[Tue Mar 10 00:24:44 2009] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC
contains: /opt/rt/bin/…/local/lib
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib /opt/rt/bin/…/lib
/opt/perl/lib/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/5.10.0
/opt/perl/lib/site_perl/5.10.0/sun4-solaris-thread-multi-64-ld
/opt/perl/lib/site_perl/5.10.0 . /opt/apache/httpd) at
/opt/rt/bin/…/lib/RT/Config.pm line 311, line 323.
(/opt/rt/bin/…/lib/RT/Config.pm:312)
[Tue Mar 10 00:24:44 2009] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt/var/data/gpg). PGP support has been disabled
(/opt/rt/bin/…/lib/RT/Config.pm:339)
[Tue Mar 10 00:24:44 2009] [debug]: Reloading RT::User to work around
a bug in RT-3.8.0 and RT-3.8.1
(/opt/rt/local/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Auth:14)

I put the RT_SiteConfig.pm as you told me

And the message still is:

Can’t call method “as_string” on an undefined value at
/opt/rt/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm
line 398, line 514.

THNX FOR THE HELP MATE!!! :slight_smile:

Regards,

Mike Peachey wrote:

Delete the above.

I meant below.

Kind Regards,


Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com


Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

Eliezer E Ch�vez wrote:

Mike:

This is the debug log…

Disable GraphViz and PGP.

Your d_filter appears to be invalid, an “=” would be required somewhere.

Kind Regards,

Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com

You hit the JACKPOT mike

Thanks!!!

Just another thing, how i disable GraphViz and PGP???

Regards!

Eliezer E Chávez wrote:

Mike:

This is the debug log…

Disable GraphViz and PGP.

Your d_filter appears to be invalid, an “=” would be required somewhere.


Kind Regards,


Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com


Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

On Tue, 10 Mar 2009 10:20:51 -0430, "Eliezer E Chávez"
eliezer.chavez@gmail.com said:

Just another thing, how i disable GraphViz and PGP???

To disable PGP, put this in RT_SiteConfig.pm:
Set( %GnuPG, Enable => 0);

I believe GraphViz to be a build-time option, ./configure
–without-graphviz