Problems making rt

Im getting the following errors when attmpeting to install RT.

[root@huachuca rt-2-0-11]# make dropdb
/usr/bin/perl tools/initdb ‘Pg ’ ‘/usr/local/pgsql’ ‘localhost’
’’ 'postgres ’ ‘rt2’ drop
Database creation parameters:

DB_TYPE = Pg
DB_HOME = /usr/local/pgsql
DB_HOST = localhost
DB_DBA = postgres
DB_DBA_PASSWORD =
DB_DATABASE = rt2
Now dropping the RT2 database.
Enter the Pg password for postgres :
About to drop Pg database rt2.
WARNING: This will erase all data in rt2.
If you have an existing RT 2.x installation, this will destroy all your
data.

Proceed [y/N]:y

Dropping Pg database rt2.
can’t parse data source: dbi:Pg : at
/usr/lib/perl5/site_perl/5.6.0/DBIx/DataSource.pm line 70, line 2.
make: *** [dropdb] Error 255

Any suggestions?
Any thoughts would be apprecaited.

Below is some maybe pertinent info

Regards
Jason Tan

Version info of some of the perl mods I suspect may be associated with the
problem.

DBI-1.201
DBD-Pg-1.01
DBI-1.201.tar.gz
DBIx-DataSource-0.02
DBIx-SearchBuilder-0.48

All of the perl mods were isntalled as per their readmes afaik.

root@huachuca rt-2-0-11]# perl -V
Summary of my perl5 (revision 5.0 version 6 subversion 0) configuration:
Platform:
osname=linux, osvers=2.2.5-22smp, archname=i386-linux
uname=‘linux porky.devel.redhat.com 2.2.5-22smp #1 smp wed jun 2
09:11:51 edt 1999 i686 unknown ‘
config_args=’-des -Doptimize=-O2 -march=i386 -mcpu=i686 -Dcc=gcc
-Dcccdlflags=-fPIC -Dinstallprefix=/usr -Dprefix=/usr
-Darchname=i386-linux -Dd_dosuid -Dd_semctl_semun -Di_db -Di_ndbm -Di_gdbm
-Di_shadow -Di_syslog -Dman3ext=3pm -Uuselargefiles’
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef
usemultiplicity=undef
useperlio=undef d_sfio=undef uselargefiles=undef
use64bitint=undef use64bitall=undef uselongdouble=undef usesocks=undef
Compiler:
cc=‘gcc’, optimize=’-O2 -march=i386 -mcpu=i686’, gccversion=2.96
20000731 (experimental)
cppflags=’-fno-strict-aliasing’
ccflags =’-fno-strict-aliasing’
stdchar=‘char’, d_stdstdio=define, usevfork=false
intsize=4, longsize=4, ptrsize=4, doublesize=8
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype=‘long’, ivsize=4, nvtype=‘double’, nvsize=8, Off_t=‘off_t’,
lseeksize=4
alignbytes=4, usemymalloc=n, prototype=define
Linker and Libraries:
ld=‘gcc’, ldflags =’ -L/usr/local/lib’
libpth=/usr/local/lib /lib /usr/lib
libs=-lnsl -ldl -lm -lc -lcrypt
libc=/lib/libc-2.1.92.so, so=so, useshrplib=false, libperl=libperl.a
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=’-rdynamic’
cccdlflags=’-fPIC’, lddlflags=’-shared -L/usr/local/lib’

Characteristics of this binary (from libperl):
Compile-time options:
Built under linux
Compiled at Aug 7 2000 10:59:51
@INC:
/usr/lib/perl5/5.6.0/i386-linux
/usr/lib/perl5/5.6.0
/usr/lib/perl5/site_perl/5.6.0/i386-linux
/usr/lib/perl5/site_perl/5.6.0
/usr/lib/perl5/site_perl
.
[root@huachuca rt-2-0-11]#

Jason Tan jason@rebel.net.au
"Democracy is two wolves and a lamb voting on what to have for lunch.
Liberty is a well-armed lamb contesting the vote."
~Benjamin Franklin, 1759

Jason Tan wrote:

/usr/bin/perl tools/initdb 'Pg ’ ‘/usr/local/pgsql’ ‘localhost’

Check your Makefile for stray tabs after the string “Pg”?

Your brilliance outshines even my darkest RayBans.

I ddint think of anything so prosiac as theat.

Thanks you.

Still ahve other problems, but iM over that hump at least.

Thanks very much for your timely and useful reply.

jasonOn Thu, 31 Jan 2002, Phil Homewood wrote:

Jason Tan wrote:

/usr/bin/perl tools/initdb 'Pg ’ ‘/usr/local/pgsql’ ‘localhost’

Check your Makefile for stray tabs after the string “Pg”?


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Jason Tan jason@rebel.net.au
"Democracy is two wolves and a lamb voting on what to have for lunch.
Liberty is a well-armed lamb contesting the vote."
~Benjamin Franklin, 1759