Problems installing RT 3.4.3

Trying to install on a fresh Fedora Core 4 machine. First problem was
pod2test (the fix was covered in other emails to the list).

Got past that, “make fixdeps” runs clean.

Did a make install.

Edited RT_SiteConfig.pm

Here’s where I noticed the first issue, at the end of “make install” it
tells me that I must configure a database password in RT_SiteConfig.pm.
However, I specified a password when I ran the configure script, and the
password I specified has already been put into RT_Config.pm. This isn’t
a major thing, but it’s a bit confusing, and probably has some bearing
on the more significant issue outlined below.

Now I run “make initialize-database” and it outputs the following:

[root@rtsupport rt-3.4.3]# make initialize-database

/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password

In order to create or update your RT database,Use of uninitialized value
in concatenation (.) or string at //opt/rt3/sbin/rt-setup-database line
282.

this script needs to connect to your mysql instance on as root.

Please specify that user’s database password below. If the user has no
database

password, just press return.

Password:

Now creating a database for RT.

Creating mysql database rt3.

Now populating database schema.

Creating database schema.

Done setting up database schema.

Now inserting database ACLs

Done setting up database ACLs.

Now inserting RT core system objects

[Thu Aug 11 19:57:00 2005] [crit]: Connect Failed Access denied for user
’rt_user’@‘localhost’ (using password: YES)

at //opt/rt3/sbin/rt-setup-database line 384

(/opt/rt3/lib/RT.pm:295)

make: *** [initialize-database] Error 255

So, two issues here, the first is the un-initialized value, not a big
deal, but.

The other problem is more serious, and I can’t quite figure out what it
is. Somewhere in one of the files it says that there’s no need to
create a user in the database, that the script will do it, but it seems
that it hasn’t done it yet, since I don’t see the rt-user created in
mysql at the end of the script, even though it seems to be trying to use
it.

Kelly F. Hickel
Senior Software Architect
MQSoftware, Inc
952.345.8677
kfh@mqsoftware.com