Problems getting going

Hi there all

A very happy user of RT1 here. However, whilst
trying to build RT2 (2-0-11) I seem to have
problems getting the Apache server (with
mod_perl compiled in). Here’s what I get when
trying to start it…

fife# ./apachectl start
[Fri Feb 1 19:34:03 2002] [error]
Can’t locate object method “TIEHASH”
via package “Apache::Table” at
/usr/local/lib/perl5/site_perl/5.005/HTML/Mason/ApacheHandler.pm
line 365.
BEGIN failed–compilation aborted at
/usr/local/rt2/bin/webmux.pl line 20.

Syntax error on line 1006 of
/usr/local/pkgs/apache_1.3.22-mod_perl/conf/httpd.conf:
Can’t locate object method "TIEHASH"
via package “Apache::Table” at
/usr/local/lib/perl5/site_perl/5.005/HTML/Mason/ApacheHandler.pm
line 365.
BEGIN failed–compilation aborted at
/usr/local/rt2/bin/webmux.pl line 20.

./apachectl start: httpd could not be started
fife#1.26

A friend of mine reckons there is a version incompat
between mod_perl and mason. However, this is a brand,
new build (on a new test machine). All the packages
are the latest release (no betas).

I’ve checked all the perl modules are installed
for RT2 and for Mason. Any ideas anyone?

btw, Mason is version 1.04, Apache 1.3.22, mod_perl
is version 1.26 running on FreeBSD 4-STABLE, perl is
5.005_03

cheers
Ak

I hit that one, too. I had to rebuild mod_perl to turn on the Tables API.

My notes:

[jxh@nd ~/build]$ cat HowIBuiltApache
#! /bin/sh

jxh Thu Sep 13 22:49:13 PDT 2001

./configure --prefix=/usr/local/apache --enable-module=so
–with-perl=/usr/bin/perl
make
#Later, CPAN appended mod-perl during the installation of Apache::Registry,
#and it rebuilt httpd.

2002-Jan-12 jxh

Still later, Rt (which uses RT::Mason) complained about not finding

Apache::Table. A google search revealed that mod_perl must be built with:

perl Makefile.PL PERL_TABLE_API=1 (among other possibilities)

to get the Table API to enable. Did this, by hand, in

~/.cpan/build/mod-perl-1.26,

after “make clean”; then did “make”, all as root.

Fails “make test”. Figure out why.

Hmm. I evidently got it to work, but didn’t update my notes. Shame on me.–On Friday, February 01, 2002 10:57:35 PM +0000 Andy andy@tecc.co.uk wrote:

Hi there all

A very happy user of RT1 here. However, whilst
trying to build RT2 (2-0-11) I seem to have
problems getting the Apache server (with
mod_perl compiled in). Here’s what I get when
trying to start it…

fife# ./apachectl start
[Fri Feb 1 19:34:03 2002] [error]
Can’t locate object method “TIEHASH”
via package “Apache::Table” at
/usr/local/lib/perl5/site_perl/5.005/HTML/Mason/ApacheHandler.pm
line 365.
BEGIN failed–compilation aborted at
/usr/local/rt2/bin/webmux.pl line 20.

Syntax error on line 1006 of
/usr/local/pkgs/apache_1.3.22-mod_perl/conf/httpd.conf:
Can’t locate object method "TIEHASH"
via package “Apache::Table” at
/usr/local/lib/perl5/site_perl/5.005/HTML/Mason/ApacheHandler.pm
line 365.
BEGIN failed–compilation aborted at
/usr/local/rt2/bin/webmux.pl line 20.

./apachectl start: httpd could not be started
fife#1.26

A friend of mine reckons there is a version incompat
between mod_perl and mason. However, this is a brand,
new build (on a new test machine). All the packages
are the latest release (no betas).

I’ve checked all the perl modules are installed
for RT2 and for Mason. Any ideas anyone?

btw, Mason is version 1.04, Apache 1.3.22, mod_perl
is version 1.26 running on FreeBSD 4-STABLE, perl is
5.005_03

cheers
Ak


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

With thanks to Jim, it worked fine.
Apache starts. However, I am now at
the RT User/login on the browser.
So, who exactly do I login as on
a brand new install? I’ve tried looking
in the rt2.Users table db, none of them
work, I’ve tried my Unix login, doesnt
work. Nothing in the manual, install docs
or in the mail archieves (as yet).

So, to get going with RT2, what is the
default initial install user admin acct?

AkFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Jim Hickstein
Sent: 02 February 2002 00:39
To: Andy
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] Problems getting going…

I hit that one, too. I had to rebuild mod_perl to turn on the Tables API.

My notes:

[jxh@nd ~/build]$ cat HowIBuiltApache
#! /bin/sh

jxh Thu Sep 13 22:49:13 PDT 2001

./configure --prefix=/usr/local/apache --enable-module=so
–with-perl=/usr/bin/perl
make
#Later, CPAN appended mod-perl during the installation of Apache::Registry,
#and it rebuilt httpd.

2002-Jan-12 jxh

Still later, Rt (which uses RT::Mason) complained about not finding

Apache::Table. A google search revealed that mod_perl must be built with:

perl Makefile.PL PERL_TABLE_API=1 (among other possibilities)

to get the Table API to enable. Did this, by hand, in

~/.cpan/build/mod-perl-1.26,

after “make clean”; then did “make”, all as root.

Fails “make test”. Figure out why.

Hmm. I evidently got it to work, but didn’t update my notes. Shame on me.

http://fsck.com/rtfm/article.html?id=2#9

Says to change the root password, which is the default login… :slight_smile:

Greg Smythe
SysAdmin
Intellstat Communications
WA State ResidentFrom: Andy [mailto:andy@tecc.co.uk]
Sent: Friday, February 01, 2002 8:02 PM
To: Jim Hickstein
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Problems getting going…

With thanks to Jim, it worked fine.
Apache starts. However, I am now at
the RT User/login on the browser.
So, who exactly do I login as on
a brand new install? I’ve tried looking
in the rt2.Users table db, none of them
work, I’ve tried my Unix login, doesnt
work. Nothing in the manual, install docs
or in the mail archieves (as yet).

So, to get going with RT2, what is the
default initial install user admin acct?

Ak

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Jim Hickstein
Sent: 02 February 2002 00:39
To: Andy
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] Problems getting going…

I hit that one, too. I had to rebuild mod_perl to turn on the Tables API.

My notes:

[jxh@nd ~/build]$ cat HowIBuiltApache
#! /bin/sh

jxh Thu Sep 13 22:49:13 PDT 2001

./configure --prefix=/usr/local/apache --enable-module=so
–with-perl=/usr/bin/perl
make
#Later, CPAN appended mod-perl during the installation of Apache::Registry,
#and it rebuilt httpd.

2002-Jan-12 jxh

Still later, Rt (which uses RT::Mason) complained about not finding

Apache::Table. A google search revealed that mod_perl must be built with:

perl Makefile.PL PERL_TABLE_API=1 (among other possibilities)

to get the Table API to enable. Did this, by hand, in

~/.cpan/build/mod-perl-1.26,

after “make clean”; then did “make”, all as root.

Fails “make test”. Figure out why.

Hmm. I evidently got it to work, but didn’t update my notes. Shame on me.

Thx v much. Excellent help list.

cheers
AkFrom: Greg Smythe [mailto:gregs@intellstat.com]
Sent: 02 February 2002 04:16
To: ‘Andy’; Jim Hickstein
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Problems getting going…

http://fsck.com/rtfm/article.html?id=2#9

Says to change the root password, which is the default login… :slight_smile:

Greg Smythe
SysAdmin
Intellstat Communications
WA State Resident

From: Andy [mailto:andy@tecc.co.uk]
Sent: Friday, February 01, 2002 8:02 PM
To: Jim Hickstein
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Problems getting going…

With thanks to Jim, it worked fine.
Apache starts. However, I am now at
the RT User/login on the browser.
So, who exactly do I login as on
a brand new install? I’ve tried looking
in the rt2.Users table db, none of them
work, I’ve tried my Unix login, doesnt
work. Nothing in the manual, install docs
or in the mail archieves (as yet).

So, to get going with RT2, what is the
default initial install user admin acct?

Ak

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Jim Hickstein
Sent: 02 February 2002 00:39
To: Andy
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] Problems getting going…

I hit that one, too. I had to rebuild mod_perl to turn on the Tables API.

My notes:

[jxh@nd ~/build]$ cat HowIBuiltApache
#! /bin/sh

jxh Thu Sep 13 22:49:13 PDT 2001

./configure --prefix=/usr/local/apache --enable-module=so
–with-perl=/usr/bin/perl
make
#Later, CPAN appended mod-perl during the installation of Apache::Registry,
#and it rebuilt httpd.

2002-Jan-12 jxh

Still later, Rt (which uses RT::Mason) complained about not finding

Apache::Table. A google search revealed that mod_perl must be built with:

perl Makefile.PL PERL_TABLE_API=1 (among other possibilities)

to get the Table API to enable. Did this, by hand, in

~/.cpan/build/mod-perl-1.26,

after “make clean”; then did “make”, all as root.

Fails “make test”. Figure out why.

Hmm. I evidently got it to work, but didn’t update my notes. Shame on me.