Problem


#1

I have sucessfully setup RT previously with Slackware but now I’m trying to
set it up on a Redhat v7 system. I am getting an error from sendmail on mail
coming into the ‘rt’ alias. Here is what I’m getting back in the mail logs.

Nov 14 13:49:42 vqlinux sendmail[1504]: eAELngY01504:
from=tomk@vqlinux.vqorthocare.com, size=327, class=0, nrcpts=1,
msgid=Pine.LNX.4.21.0011141349060.1502-100000@vqlinux.vqorthocare.com,
proto=ESMTP, relay=tomk@localhost

Nov 14 13:49:42 vqlinux smrsh: uid 8: attempt to use rt-mailgate VQ
correspond

Nov 14 13:49:42 vqlinux sendmail[1505]: eAELngY01504:
to=|"/opt/rt/bin/rt-mailgate VQ correspond",
ctladdr=rt@vqlinux.vqorthocare.com (8/0), delay=00:00:00, xdelay=00:00:00,
mailer=prog, pri=30042, dsn=5.0.0, stat=Service unavailable

Nov 14 13:49:42 vqlinux sendmail[1505]: eAELngY01504: eAELngY01505: DSN:
Service unavailable

Nov 14 13:49:42 vqlinux sendmail[1505]: eAELngY01505:
to=tomk@vqlinux.vqorthocare.com, delay=00:00:00, xdelay=00:00:00,
mailer=local, pri=30142, dsn=2.0.0, stat=Sent

Thanks for any help.

Tom Klump
tomk@vqorthocare.com


#2

I have sucessfully setup RT previously with Slackware but now I’m trying to
set it up on a Redhat v7 system. I am getting an error from sendmail on mail
coming into the ‘rt’ alias. Here is what I’m getting back in the mail logs.

Nov 14 13:49:42 vqlinux sendmail[1504]: eAELngY01504:
from=tomk@vqlinux.vqorthocare.com, size=327, class=0, nrcpts=1,
msgid=Pine.LNX.4.21.0011141349060.1502-100000@vqlinux.vqorthocare.com,
proto=ESMTP, relay=tomk@localhost

Nov 14 13:49:42 vqlinux smrsh: uid 8: attempt to use rt-mailgate VQ
correspond

Nov 14 13:49:42 vqlinux sendmail[1505]: eAELngY01504:
to=|"/opt/rt/bin/rt-mailgate VQ correspond",
ctladdr=rt@vqlinux.vqorthocare.com (8/0), delay=00:00:00, xdelay=00:00:00,
mailer=prog, pri=30042, dsn=5.0.0, stat=Service unavailable

Nov 14 13:49:42 vqlinux sendmail[1505]: eAELngY01504: eAELngY01505: DSN:
Service unavailable

Nov 14 13:49:42 vqlinux sendmail[1505]: eAELngY01505:
to=tomk@vqlinux.vqorthocare.com, delay=00:00:00, xdelay=00:00:00,
mailer=local, pri=30142, dsn=2.0.0, stat=Sent

 Q5.1 from the FAQ might be relevant:

 http://www.fsck.com/projects/rt/docs/FAQ.html

Q5.1 Sendmail won’t let me run rt-mailgate

If you get an error like the following:
----- The following addresses had permanent fatal errors -----
|"/usr/local/rt/bin/rt-mailgate general action"
(expanded from: rt-action@mustang.hiwaay.net)

----- Transcript of session follows -----
sh: rt-mailgate not available for sendmail programs
554 |"/usr/local/rt/bin/rt-mailgate general action"… Service unavailable

then, the following information from Jesse should help:
Sendmail has a program called smrsh. smrsh restricts what binaries can
be run from sendmail aliases. I think it keeps the programs in
/etc/smrsh on redhat6. add a symlink from
/usr/local/rt/bin/rt-mailgate to /etc/smrsh/rt-mailgate and things
should work better.

–Joe

D. Joe Anderson, Ph.D Computing Support for Botany, ZG, & BBMB.
botsupport@iastate.edu | zgsupport@iastate.edu | bbsupport@iastate.edu
1210 MBB, ISU, Ames, IA 5001 http://molebio.iastate.edu/support
bcbsupport@iastate.eduhttp://www.bcb.iastate.edu/bcblab


#3

Here’s my problem…

When I make any change to a record, or add a new one, mail to my own address
goes fine. However, mail to another user of RT is killed by sendmail. The
error message given by sendmail is, “Data format error”. This results in me
getting the email message, and the other user getting nothing. I’ve tried
changing the user to a new email address, and removing and adding back the
user. Neither of these made any difference.

If needed, I can get the whole message from my logs.

Any ideas would be appreciated.

Thanks!

Russ Johnson
Stargate Online

telnet://telnet.dimstar.net
http://www.dimstar.net
ICQ: 3739685:Airneil