Problem with timezones

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I’ve searched through the mailing-list archives, searched google, etc
and not found anyone with this problem.

Basically, it looks like RT is displaying dates and times based on the
system timezone, and the $Timezone setting in the config is ignored. My
system timezone is set to ‘US/Pacific’ but I want RT to display
timezones for ‘US/Arizona’. I’ve tried setting the $Timezone variable
to ‘US/Arizona’, ‘America/Phoenix’, ‘US/Mountain’ and even 'US/Eastern’
but the dates are still displayed in ‘US/Pacific’ timezone no matter
what I try. After every change I’ve done a full stop/start of apache.
I even tried setting the timezone in the User table. None of it seems
to make a difference. Grepping through the source for Timezone yields a
function in RT::Date called LocalTimezone, but that function isn’t
called by anything else.

Am I missing something? Or is RT not paying attention to the $Timezone
setting?

Thanks,
Nate


:wq
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEKZQjRMRYK1K/wKQRAkB6AJoD7mOuCNb9LTA8Esc25wu2t10kGACgkN9n
Hm+hNBAeXDiK8rctdytX9PI=
=DBPo
-----END PGP SIGNATURE-----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I’ve searched through the mailing-list archives, searched google, etc
and not found anyone with this problem.

Basically, it looks like RT is displaying dates and times based on the
system timezone, and the $Timezone setting in the config is ignored. My
system timezone is set to ‘US/Pacific’ but I want RT to display
timezones for ‘US/Arizona’. I’ve tried setting the $Timezone variable
to ‘US/Arizona’, ‘America/Phoenix’, ‘US/Mountain’ and even 'US/Eastern’
but the dates are still displayed in ‘US/Pacific’ timezone no matter
what I try. After every change I’ve done a full stop/start of apache.
I even tried setting the timezone in the User table. None of it seems
to make a difference. Grepping through the source for Timezone yields a
function in RT::Date called LocalTimezone, but that function isn’t
called by anything else.

Am I missing something? Or is RT not paying attention to the $Timezone
setting?
Yep, you’re right and RT is using system’s timezone settings. You can
set timezone with TZ environment variable when you start your server.
There is work has been done in RT-3.7, but this branch is not marked
as stable yet. You could try to backport changes.

Thanks,
Nate


:wq
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEKZQjRMRYK1K/wKQRAkB6AJoD7mOuCNb9LTA8Esc25wu2t10kGACgkN9n
Hm+hNBAeXDiK8rctdytX9PI=
=DBPo
-----END PGP SIGNATURE-----


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Best regards, Ruslan.

Ruslan Zakirov wrote:>On 3/28/06, nate nate@seekio.com wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I’ve searched through the mailing-list archives, searched google, etc
and not found anyone with this problem.

Basically, it looks like RT is displaying dates and times based on the
system timezone, and the $Timezone setting in the config is ignored. My
system timezone is set to ‘US/Pacific’ but I want RT to display
timezones for ‘US/Arizona’. I’ve tried setting the $Timezone variable
to ‘US/Arizona’, ‘America/Phoenix’, ‘US/Mountain’ and even 'US/Eastern’
but the dates are still displayed in ‘US/Pacific’ timezone no matter
what I try. After every change I’ve done a full stop/start of apache.
I even tried setting the timezone in the User table. None of it seems
to make a difference. Grepping through the source for Timezone yields a
function in RT::Date called LocalTimezone, but that function isn’t
called by anything else.

Am I missing something? Or is RT not paying attention to the $Timezone
setting?

Yep, you’re right and RT is using system’s timezone settings. You can
set timezone with TZ environment variable when you start your server.
There is work has been done in RT-3.7, but this branch is not marked
as stable yet. You could try to backport changes.

Thanks,
Nate


:wq
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEKZQjRMRYK1K/wKQRAkB6AJoD7mOuCNb9LTA8Esc25wu2t10kGACgkN9n
Hm+hNBAeXDiK8rctdytX9PI=
=DBPo
-----END PGP SIGNATURE-----


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Version 3.6.0pre:
Also, it appears that when $LogToFileNamed is set in RT_SiteConfig.pm,
the RT log uses gmtime within brackets. Should this be changed to use
localtime instead (in lib/RT.pm )

Thanks

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thanks, setting the TZ variable in the apache config has fixed it for
now. Does the work on the 3.7 branch include using the per-user
timezone setting? It’s not that critical, but it would be nice for
remote users =)

Thanks,
Nate

Ruslan Zakirov wrote:

I’ve searched through the mailing-list archives, searched google, etc
and not found anyone with this problem.

Basically, it looks like RT is displaying dates and times based on the
system timezone, and the $Timezone setting in the config is ignored. My
system timezone is set to ‘US/Pacific’ but I want RT to display
timezones for ‘US/Arizona’. I’ve tried setting the $Timezone variable
to ‘US/Arizona’, ‘America/Phoenix’, ‘US/Mountain’ and even 'US/Eastern’
but the dates are still displayed in ‘US/Pacific’ timezone no matter
what I try. After every change I’ve done a full stop/start of apache.
I even tried setting the timezone in the User table. None of it seems
to make a difference. Grepping through the source for Timezone yields a
function in RT::Date called LocalTimezone, but that function isn’t
called by anything else.

Am I missing something? Or is RT not paying attention to the $Timezone
setting?

Yep, you’re right and RT is using system’s timezone settings. You can
set timezone with TZ environment variable when you start your server.
There is work has been done in RT-3.7, but this branch is not marked
as stable yet. You could try to backport changes.

Thanks,
Nate


:wq
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:


Best regards, Ruslan.


:wq
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFELXRNRMRYK1K/wKQRAuYRAJ4s+UG2mbsxxp7y7hDEHVNDcAT2xACghtBI
ZQGz4ggq8/HojI/ha5q+ylg=
=emya
-----END PGP SIGNATURE-----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thanks, setting the TZ variable in the apache config has fixed it for
now. Does the work on the 3.7 branch include using the per-user
timezone setting? It’s not that critical, but it would be nice for
remote users =)

Yes. :slight_smile: