Problem with rt


#1

Hi,
I’ve set up RT verdion 1.0.7 correctly, i can access to the web
interface, but if i send an e-mail to rt@mydomain
sendemail tells me:

"Return-Path: <MAILER-DAEMON@YAST_ASK>Date: Mon, 7 May 2001 11:03:14 +0200
To: root@homer.pizzarotti.it
Subject: Returned mail: see transcript for details
Auto-Submitted: auto-generated (failure)

[Part #1: Type: text/plain, Encoding: 7bit, Size: 433]

The original message was received at Mon, 7 May 2001 11:03:14 +0200
from root@localhost

----- The following addresses had permanent fatal errors -----
| /opt/rt/bin/rt-mailgate ced correspond
(reason: 127)
(expanded from: rt)

----- Transcript of session follows -----
sh: /opt/rt/bin/rt-mailgate.ced.correspond: No such file or directory
554 5.3.0 | /opt/rt/bin/rt-mailgate ced correspond… unknown mailer
error 127"

I’ve also set the right alias in /etc/aliases (i’ve set: rt:
/opt/bin/rt/mailgate ced correspond )

I’m using Suse Linux 7.1 with kernel 2.4.0

The output of perl -VSummary of my perl5 (revision 5.0 version 6
subversion 0) configuration:
Platform:
osname=linux, osvers=2.4.0, archname=i586-linux
uname=‘linux manson 2.4.0 #1 wed aug 2 20:22:26 gmt 2000 i686
unknown ‘
config_args=’-ds -e -Dprefix=/usr -Di_db -Di_dbm -Di_ndbm -Di_gdbm’
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef
usemultiplicity=unde
f
useperlio=undef d_sfio=undef uselargefiles=define
use64bitint=undef use64bitall=undef uselongdouble=undef
usesocks=undef
Compiler:
cc=‘cc’, optimize=’-O2 -pipe’, gccversion=2.95.2 19991024 (release)
cppflags=’-fno-strict-aliasing -I/usr/local/include’
ccflags =’-fno-strict-aliasing -I/usr/local/include
-D_LARGEFILE_SOURCE -D_F
ILE_OFFSET_BITS=64’
stdchar=‘char’, d_stdstdio=define, usevfork=false
intsize=4, longsize=4, ptrsize=4, doublesize=8
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype=‘long’, ivsize=4, nvtype=‘double’, nvsize=8, Off_t=‘off_t’,
lseeksize
=8
alignbytes=4, usemymalloc=n, prototype=define
Linker and Libraries:
ld=‘cc’, ldflags =’ -L/usr/local/lib’
libpth=/usr/local/lib /lib /usr/lib
libs=-lnsl -ldl -lm -lc -lcrypt
libc=, so=so, useshrplib=false, libperl=libperl.a
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=’-rdynamic’
cccdlflags=’-fpic’, lddlflags=’-shared -L/usr/local/lib’

Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under linux
Compiled at Jan 19 2001 05:42:10
@INC:
/usr/lib/perl5/5.6.0/i586-linux
/usr/lib/perl5/5.6.0
/usr/lib/perl5/site_perl/5.6.0/i586-linux
/usr/lib/perl5/site_perl/5.6.0
/usr/lib/perl5/site_perl
.
"

I’m running Apache 1.3.17

Please let me know.
Thanx a lot,

	Davide Carnevali
  • The electrons of this E-mail are 100% recycled +

#2

I’ll bet you need quotes around the statement…On Mon, May 07, 2001 at 11:19:57AM +0200, Davide Carnevali wrote:

Hi,
I’ve set up RT verdion 1.0.7 correctly, i can access to the web
interface, but if i send an e-mail to rt@mydomain
sendemail tells me:

"Return-Path: <MAILER-DAEMON@YAST_ASK>
Date: Mon, 7 May 2001 11:03:14 +0200
To: root@homer.pizzarotti.it
Subject: Returned mail: see transcript for details
Auto-Submitted: auto-generated (failure)

[Part #1: Type: text/plain, Encoding: 7bit, Size: 433]

The original message was received at Mon, 7 May 2001 11:03:14 +0200
from root@localhost

----- The following addresses had permanent fatal errors -----
| /opt/rt/bin/rt-mailgate ced correspond
(reason: 127)
(expanded from: rt)

----- Transcript of session follows -----
sh: /opt/rt/bin/rt-mailgate.ced.correspond: No such file or directory
554 5.3.0 | /opt/rt/bin/rt-mailgate ced correspond… unknown mailer
error 127"

I’ve also set the right alias in /etc/aliases (i’ve set: rt:
/opt/bin/rt/mailgate ced correspond )

I’m using Suse Linux 7.1 with kernel 2.4.0

The output of perl -VSummary of my perl5 (revision 5.0 version 6
subversion 0) configuration:
Platform:
osname=linux, osvers=2.4.0, archname=i586-linux
uname=‘linux manson 2.4.0 #1 wed aug 2 20:22:26 gmt 2000 i686
unknown ‘
config_args=’-ds -e -Dprefix=/usr -Di_db -Di_dbm -Di_ndbm -Di_gdbm’
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef
usemultiplicity=unde
f
useperlio=undef d_sfio=undef uselargefiles=define
use64bitint=undef use64bitall=undef uselongdouble=undef
usesocks=undef
Compiler:
cc=‘cc’, optimize=’-O2 -pipe’, gccversion=2.95.2 19991024 (release)
cppflags=’-fno-strict-aliasing -I/usr/local/include’
ccflags =’-fno-strict-aliasing -I/usr/local/include
-D_LARGEFILE_SOURCE -D_F
ILE_OFFSET_BITS=64’
stdchar=‘char’, d_stdstdio=define, usevfork=false
intsize=4, longsize=4, ptrsize=4, doublesize=8
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype=‘long’, ivsize=4, nvtype=‘double’, nvsize=8, Off_t=‘off_t’,
lseeksize
=8
alignbytes=4, usemymalloc=n, prototype=define
Linker and Libraries:
ld=‘cc’, ldflags =’ -L/usr/local/lib’
libpth=/usr/local/lib /lib /usr/lib
libs=-lnsl -ldl -lm -lc -lcrypt
libc=, so=so, useshrplib=false, libperl=libperl.a
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=’-rdynamic’
cccdlflags=’-fpic’, lddlflags=’-shared -L/usr/local/lib’

Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under linux
Compiled at Jan 19 2001 05:42:10
@INC:
/usr/lib/perl5/5.6.0/i586-linux
/usr/lib/perl5/5.6.0
/usr/lib/perl5/site_perl/5.6.0/i586-linux
/usr/lib/perl5/site_perl/5.6.0
/usr/lib/perl5/site_perl
.
"

I’m running Apache 1.3.17

Please let me know.
Thanx a lot,

  Davide Carnevali


±---------------------------------------------------------------+

  • The electrons of this E-mail are 100% recycled +
    ±---------------------------------------------------------------+

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Pelcgb-serrqbz abj!