Problem with rt installation

Hi,

i have installed RT: Request Tracker on the my RHEL3 server with apache
1.3.27 and mod_perl 1.26

i add in the httpd.conf the following line

<VirtualHost 192.168.3.1>
ServerAdmin webmaster
ServerName rt.example.com
ServerAlias rt
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
 SetHandler perl-script
 PerlHandler RT::Mason
</Location>

when i restart the httpd server there is a error message

Stopping httpd: [ OK ]
Starting httpd: [Thu Jul 14 14:51:27 2005] [error] Can’t locate
strict.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i386-linux
/usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux
/usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.6.1/i386-linux
/usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl .
/etc/httpd/ /etc/httpd/lib/perl) at
/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/Apache.pm line 3.!BEGIN
failed–compilation aborted at
/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/Apache.pm line
3.!Compilation failed in require at (eval 1) line 3.!
Syntax error on line 2653 of /etc/httpd/conf/httpd.conf:
Can’t locate Apache/DBI.pm in @INC (@INC contains:
/usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1
/usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1
/usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux
/usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl .
/etc/httpd/ /etc/httpd/lib/perl) at (eval 2) line 3.

                                                       [FAILED]

what is wrong with this httpd setting?

i have try to use fastcgi, i installed mod_ fastcgi change the
httpd.conf to

<VirtualHost 192.168.3.1>
ServerAdmin webmaster@perridot.my
ServerName rt.example.com
ServerAlias rt
#DocumentRoot /opt/rt3/share/html
#AddDefaultCharset UTF-8

#PerlModule Apache::DBI
#PerlRequire /opt/rt3/bin/webmux.pl

#<Location />
# SetHandler perl-script
# PerlHandler RT::Mason
#</Location>

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
# Adding the following for RT (the ticket tracker)
AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/ /opt/rt3/share/html/NoAuth/
FastCgiIpcDir /tmp FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 4 ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

there is still error when using fastcgi, error message in error_log

Can’t locate FCGI.pm in @INC (@INC contains: /opt/rt3/local/lib
/opt/rt3/lib /usr/lib/perl5/5.8.
3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386
-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_p
erl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1
/usr/lib/perl5/site_perl
/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/li
b/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-th
read-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5
.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1
/usr/lib/perl5/vendor_per
l/5.8.0 /usr/lib/perl5/vendor_perl .) at
/usr/lib/perl5/5.8.3/CGI/Fast.pm line 22.
BEGIN failed–compilation aborted at /usr/lib/perl5/5.8.3/CGI/Fast.pm
line 22.
Compilation failed in require at /opt/rt3/bin/mason_handler.fcgi line 55.
[Thu Jul 14 15:51:25 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 15654)
terminated by calling exit with status ‘2’
[Thu Jul 14 15:51:29 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" restarted (p

any one here have encounter such problem before?

what is wrong with this httpd setting?
(1) you are using a very old perl (5.6.1) according to your apache (but
your fastcgi is using 5.8.3?
(2) it doesn’t appear (other than the perl version) that there is
anything wrong with your apache. It appears as if you are missing a
perl module. Have you run the test depencancy program?

i have try to use fastcgi, i installed mod_ fastcgi change the
httpd.conf to

Can’t locate FCGI.pm in @INC (@INC contains: /opt/rt3/local/lib
Can you find this file on your machine? Is it there and just not in
your include. If it is not there at all, I’d say fastcgi program is not
properly installed.

Anne