Problem with RT 3.8.7 running on top of Nginx 0.8.33

I have a problem with RT 3.8.7 running on top of Nginx 0.8.33

It appears that the css and js files aren’t being properly rendered when
they are sent to the browser - RT has no css formatting. Additionally, I
can’t logout.

When I try to browse to one of the css files directly, I get the rt login
screen (assuming I haven’t yet logged in).

If I do log in, I still get no css formatting, but I do see my tickets (in a
REALLY ugly format).

TIA,

Jason

Extensive configs follow:
NGINX

location /customerzone/ {
root /opt/rt3-fcgi/share/html;
fastcgi_pass unix:/var/run/rt3/rt3.socket;

    fastcgi_param   DOCUMENT_ROOT   /opt/rt3-fcgi/share/html;
    fastcgi_param   SCRIPT_FILENAME

/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param PATH_TRANSLATED
/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param QUERY_STRING $query_string;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_param REDIRECT_STATUS 200;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_PROTOCOL $server_protocol;
fastcgi_param SERVER_NAME $server_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param REMOTE_USER $remote_user;
fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
}

location ~* .+.(html|js|css)$ {
fastcgi_pass unix:/var/run/rt3/rt3.socket;
fastcgi_param DOCUMENT_ROOT /opt/rt3-fcgi/share/html;
fastcgi_param SCRIPT_FILENAME
/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param PATH_TRANSLATED
/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param QUERY_STRING $query_string;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_param REDIRECT_STATUS 200;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_PROTOCOL $server_protocol;
fastcgi_param SERVER_NAME $server_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param REMOTE_USER $remote_user;
fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
}

RT_SiteConfig.pm
Set($rtname, ‘www.microsoft.com’);
Set($Organization, ‘microsoft.com’);

Set($CorrespondAddress , ‘cz@microsoft.com’);
Set($CommentAddress , ‘cz-comment@microsoft.com’);

Set($Timezone , ‘Africa/Johannesburg’); # obviously choose what suits you

THE DATABASE:

Set($DatabaseType, ‘mysql’); # e.g. Pg or mysql

These are the settings we used above when creating the RT database,

you MUST set these to what you chose in the section above.

Set($DatabaseUser , ‘rtuser’);
Set($DatabasePassword , ‘averysecurepassword’);
Set($DatabaseName , ‘requesttracker’);

THE WEBSERVER:

Set($WebPath , “/customerzone”);
Set($WebBaseURL , “https://www.microsoft.com”);

Set($WebURL, RT->Config->Get(‘WebBaseURL’) . RT->Config->Get(‘WebPath’) .
"/");

Set($WebFlushDbCacheEveryRequest, 1);

1;

!!NB : The domain is not really microsoft.com. We all do small things to
amuse ourselves and release pressure, this is mine. Besides, they could use
a good issue management facility.

(I apologise if this is a dupe - listmanager was doing funky things and I’m
not sure if the previous one went through…)

I have a problem with RT 3.8.7 running on top of Nginx 0.8.33

It appears that the css and js files aren’t being properly rendered when
they are sent to the browser - RT has no css formatting. Additionally, I
can’t logout.

When I try to browse to one of the css files directly, I get the rt login
screen (assuming I haven’t yet logged in).

If I do log in, I still get no css formatting, but I do see my tickets (in a
REALLY ugly format).

TIA,

Jason

Extensive configs follow:
NGINX

location /customerzone/ {
root /opt/rt3-fcgi/share/html;
fastcgi_pass unix:/var/run/rt3/rt3.socket;

    fastcgi_param   DOCUMENT_ROOT   /opt/rt3-fcgi/share/html;
    fastcgi_param   SCRIPT_FILENAME

/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param PATH_TRANSLATED
/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param QUERY_STRING $query_string;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_param REDIRECT_STATUS 200;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_PROTOCOL $server_protocol;
fastcgi_param SERVER_NAME $server_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param REMOTE_USER $remote_user;
fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
}

location ~* .+.(html|js|css)$ {
fastcgi_pass unix:/var/run/rt3/rt3.socket;
fastcgi_param DOCUMENT_ROOT /opt/rt3-fcgi/share/html;
fastcgi_param SCRIPT_FILENAME
/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param PATH_TRANSLATED
/opt/rt3-fcgi/share/html$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
fastcgi_param QUERY_STRING $query_string;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_param REDIRECT_STATUS 200;
fastcgi_param SERVER_ADDR $server_addr;
fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_PROTOCOL $server_protocol;
fastcgi_param SERVER_NAME $server_name;
fastcgi_param REQUEST_URI $request_uri;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param REMOTE_USER $remote_user;
fastcgi_param REMOTE_ADDR $remote_addr;
fastcgi_param REMOTE_PORT $remote_port;
}

RT_SiteConfig.pm
Set($rtname, ‘www.microsoft.com’);
Set($Organization, ‘microsoft.com’);

Set($CorrespondAddress , ‘cz@microsoft.com’);
Set($CommentAddress , ‘cz-comment@microsoft.com’);

Set($Timezone , ‘Africa/Johannesburg’); # obviously choose what suits you

THE DATABASE:

Set($DatabaseType, ‘mysql’); # e.g. Pg or mysql

These are the settings we used above when creating the RT database,

you MUST set these to what you chose in the section above.

Set($DatabaseUser , ‘rtuser’);
Set($DatabasePassword , ‘averysecurepassword’);
Set($DatabaseName , ‘requesttracker’);

THE WEBSERVER:

Set($WebPath , “/customerzone”);
Set($WebBaseURL , “https://www.microsoft.com”);

Set($WebURL, RT->Config->Get(‘WebBaseURL’) . RT->Config->Get(‘WebPath’) .
"/");

Set($WebFlushDbCacheEveryRequest, 1);

1;

!!NB : The domain is not really microsoft.com. We all do small things to
amuse ourselves and release pressure, this is mine. Besides, they could use
a good issue management facility.