Problem with outgoing mail

I’m trying to set RT up on a test server so I can evaluate it for my job.
I’ve got it all installed and working except for sending outgoing mail. I’ve
got Postfix installed as my MTA and it works fine itself as far as I can
tell. But when I send messages to the domain of what will most likely be the
customers receiving mail I get back:

450 4.1.8 user@localhost: Sender address rejected: Domain not found (in
reply to RCPT TO command))

user@localhost is the user that RT is running as (changed to that because I
don’t want to send my server info out to the whole list). I’ve got
$CorrespondAddress and $CommentAddress both defined, and email addresses
defined for each queue as well, including the General queue that all
incoming mail goes to. When I look at the Outgoing mail in RT from the
Ticket information, it has the correct From: and Reply To: email addresses
in the header information. But the Postfix mail.log is saying that the From:
address is my user@localhost address.
I’ve done a test with Postfix logging in locally with telnet, setting the
the mail goes through fine. So the fact that my test server isn’t the actual
domain that the email is coming from isn’t the problem. This won’t be the
case on the live server either. Postfix will be on the machine solely as a
means for local programs to send mail.

It’s something in the way RT is sending the mail as far as I can tell that’s
causing the problem. Anyone able to assist with this?

Keith

Hello Keith!

I think the problem is maybe the fact that the mail protocol
has two sender. The first is the envelope sender, “the real one”,
the second is the body “From:” where you can write whatever you
think is a good idea. The first on is something like
"apache@machine.domain.xx", the second one is what you set
as configuration in RT.

What I suspect is that your postfix config is not set up in the
right way.
Try to send as root s simple mail 'mail -s “testme” you@youdomain.xxx
Look if this mail is send, if not you have to look for
the postfix config. I expect that you try to send the mail directly
to the customer, but most mta wont accept mails from unknown
servers directly. So you should send them to a relayhost, maybe
your company mta, or your isp mta

hope this helps!

svenOn Di, 2007-12-11 at 13:42 -0500, Keith wrote:

I’m trying to set RT up on a test server so I can evaluate it for my
job. I’ve got it all installed and working except for sending outgoing
mail. I’ve got Postfix installed as my MTA and it works fine itself as
far as I can tell. But when I send messages to the domain of what will
most likely be the customers receiving mail I get back:

450 4.1.8 user@localhost: Sender address rejected: Domain not found
(in reply to RCPT TO command))

user@localhost is the user that RT is running as (changed to that
because I don’t want to send my server info out to the whole list).
I’ve got $CorrespondAddress and $CommentAddress both defined, and
email addresses defined for each queue as well, including the General
queue that all incoming mail goes to. When I look at the Outgoing mail
in RT from the Ticket information, it has the correct From: and Reply
To: email addresses in the header information. But the Postfix
mail.log is saying that the From: address is my user@localhost
address.
I’ve done a test with Postfix logging in locally with telnet, setting
the From: and To: addresses to exactly what they should be coming from
RT and the mail goes through fine. So the fact that my test server
isn’t the actual domain that the email is coming from isn’t the
problem. This won’t be the case on the live server either. Postfix
will be on the machine solely as a means for local programs to send
mail.

It’s something in the way RT is sending the mail as far as I can tell
that’s causing the problem. Anyone able to assist with this?

Keith


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

SAVE THOUSANDS OF DOLLARS ON RT SUPPORT:

If you sign up for a new RT support contract before December 31, we’ll take
up to 20 percent off the price. This sale won’t last long, so get in touch today.
Email us at sales@bestpractical.com or call us at +1 617 812 0745.

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Your description of the problem lead me to a working solution, so thanks
very much! Below is how I got it working in case anyone else has this issue.

I went to the #postfix chatroom on irc.freenode.net and asked about how to
set up Postfix to use an external SMTP server to send mail. Someone told me
to look into setting up Postfix to use Smarthost with Authentication. Found
this link below for setting up Postfix to use Yahoo SMTP.

http://efflandt.freeshell.org/sbc-smtp-auth.html

Just changed the host information to my own email server information and
everything is working great now!

KeithOn Dec 12, 2007 9:18 AM, Sven Sternberger sven.sternberger@desy.de wrote:

Hello Keith!

I think the problem is maybe the fact that the mail protocol
has two sender. The first is the envelope sender, “the real one”,
the second is the body “From:” where you can write whatever you
think is a good idea. The first on is something like
"apache@machine.domain.xx", the second one is what you set
as configuration in RT.

What I suspect is that your postfix config is not set up in the
right way.
Try to send as root s simple mail 'mail -s “testme” you@youdomain.xxx
Look if this mail is send, if not you have to look for
the postfix config. I expect that you try to send the mail directly
to the customer, but most mta wont accept mails from unknown
servers directly. So you should send them to a relayhost, maybe
your company mta, or your isp mta

hope this helps!

sven

On Di, 2007-12-11 at 13:42 -0500, Keith wrote:

I’m trying to set RT up on a test server so I can evaluate it for my
job. I’ve got it all installed and working except for sending outgoing
mail. I’ve got Postfix installed as my MTA and it works fine itself as
far as I can tell. But when I send messages to the domain of what will
most likely be the customers receiving mail I get back:

450 4.1.8 user@localhost: Sender address rejected: Domain not found
(in reply to RCPT TO command))

user@localhost is the user that RT is running as (changed to that
because I don’t want to send my server info out to the whole list).
I’ve got $CorrespondAddress and $CommentAddress both defined, and
email addresses defined for each queue as well, including the General
queue that all incoming mail goes to. When I look at the Outgoing mail
in RT from the Ticket information, it has the correct From: and Reply
To: email addresses in the header information. But the Postfix
mail.log is saying that the From: address is my user@localhost
address.
I’ve done a test with Postfix logging in locally with telnet, setting
the From: and To: addresses to exactly what they should be coming from
RT and the mail goes through fine. So the fact that my test server
isn’t the actual domain that the email is coming from isn’t the
problem. This won’t be the case on the live server either. Postfix
will be on the machine solely as a means for local programs to send
mail.

It’s something in the way RT is sending the mail as far as I can tell
that’s causing the problem. Anyone able to assist with this?

Keith


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

SAVE THOUSANDS OF DOLLARS ON RT SUPPORT:

If you sign up for a new RT support contract before December 31, we’ll
take
up to 20 percent off the price. This sale won’t last long, so get in
touch today.
Email us at sales@bestpractical.com or call us at +1 617 812 0745.

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

SAVE THOUSANDS OF DOLLARS ON RT SUPPORT:

If you sign up for a new RT support contract before December 31, we’ll
take
up to 20 percent off the price. This sale won’t last long, so get in touch
today.
Email us at sales@bestpractical.com or call us at +1 617 812 0745.

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com