Problem with initialize RT's database


#1

When I type:
/usr/sbin/rt-setup-database --action init --dba root --prompt-for-dba-password

… I am prompted for a password. I have entered the “root” password, left it blank, and used the password set in /etc/rt3/RT_SiteConfig.pm - however, no matter what I try the following error displays:

DBI connect(’;host=localhost’,‘root’,…) failed: Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at /usr/sbin/rt-setup-database line 105
Failed to connect to dbi:mysql:;host=localhost as root: Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at /usr/sbin/rt-setup-database line 105, line 1.

Is this an error because I am not using the correct password? Here are my /etc/rt3/RT_SiteConfig.pm settings:

Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘rt3p@55’);

Thanks,
Shannon


#2

When I type:
/usr/sbin/rt-setup-database --action init --dba root --prompt-for-dba-password

… I am prompted for a password. I have entered the “root” password, left it blank, and used the password set in /etc/rt3/RT_SiteConfig.pm - however, no matter what I try the following error displays:

DBI connect(’;host=localhost’,‘root’,…) failed: Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at /usr/sbin/rt-setup-database line 105
Failed to connect to dbi:mysql:;host=localhost as root: Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) at /usr/sbin/rt-setup-database line 105, line 1.

Is this an error because I am not using the correct password? Here are my /etc/rt3/RT_SiteConfig.pm settings:

This is not a password problem, but a communication problem between your
RT server and your MySQL server. It isn’t able to connect to it via the
socket ‘/var/lib/mysql/mysql.sock’. So Maybe your MySQL server is down
or listenning on another socket.

Here is the typical error for a password problem:

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using
password: YES)

Set($DatabaseUser , ‘rt_user’);
Set($DatabasePassword , ‘xxxxxxx’);

Never give passwords on mailing lists …