Problem with Fetchmail

Dear all,

I’m setting up RT3.88 on Ubuntu10.04. Now the UI works fine, but I cannot
receive emails thru Fetchmail. I followed the instruction on this wiki to
setup the fetchmail: http://wiki.bestpractical.com/view/fetchmail.

Following is my /opt/rt3/etc/fetchmailrc.

poll pop.126.com proto pop3:

username pisceswzh password [mypassword] mda “/opt/rt3/bin/rt-mailgate --url
[myurl] --queue General --action correspond”

If I run “fetchmail -f /opt/rt3/etc/fetchmailrc”, I got an response “1
message (1 seen) for pisceswzh at pop.126.com (6411 octers). Skipping
message pisceswzh@pop3.126.idns.yeah.net:1 not flushed”

Apparently fetchmail is able to see there is one mail in the mailbox, which
is correct, but it is unable to download that email. I’m doubting if I have
set the mda part correctly or there is some permission issues.

Anyone, please help. Any advice would be deeply appreciated. Thanks.

Tom

Dear all,

I’m setting up RT3.88 on Ubuntu10.04. Now the UI works fine, but I cannot
receive emails thru Fetchmail. I followed the instruction on this wiki to
setup the fetchmail: http://wiki.bestpractical.com/view/fetchmail.

Following is my /opt/rt3/etc/fetchmailrc.

++++++++++++++++++++++++++++++++++++++

poll pop.126.com proto pop3:

username pisceswzh password [mypassword] mda “/opt/rt3/bin/rt-mailgate --url
[myurl] --queue General --action correspond”

++++++++++++++++++++++++++++++++++++++

If I run “fetchmail –f /opt/rt3/etc/fetchmailrc”, I got an response “1
message (1 seen) for pisceswzh at pop.126.com (6411 octers). Skipping
message pisceswzh@pop3.126.idns.yeah.net:1 not flushed”

Apparently fetchmail is able to see there is one mail in the mailbox, which
is correct, but it is unable to download that email. I’m doubting if I have
set the mda part correctly or there is some permission issues.

Anyone, please help. Any advice would be deeply appreciated. Thanks.

I’d suggest you pop over to the fetchmail-users mailing list, having
read the FAQ, where we’ll be happy to help :wink:

You may want to add the fetchall (and nokeep) options. On the command
line use “-a -K”. That will force all emails, new and old, to be
downloaded and then deleted. If you want to leave them there don’t
use “-K”.

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche